Sign in with
Sign up | Sign in
Your question

LED on mobo is lit, but when button is pressed nothing happens

Last response: in CPUs
Share
Anonymous
a b à CPUs
April 30, 2010 1:45:36 PM

hi, im new to this site and im in a bit of a pickle.

I was trying to change the stock CPU fan with the an arctic model (CPU = AMD 965). As i tried to take the fan off it was stuck to the cpu and as i pulled a little harder the fan came off taking the CPU out of its socket. I had not lifted up the metal leaver...

When i took a close look at the CPU there were about a dozen bent pins, so i got a knife and bent them back with ease. I put the CPU back into the socket and it slotted in perfectly, attached the new CPU fan and tried to boot up... nothing happened.

The green LED on my Asus Mobo lights up but when i try to turn the PC on nothing happens not even fans moving or any other LEDs turning on..

Have i killed my CPU or Mobo? Or could something else be a problem?
Anonymous
a b à CPUs
April 30, 2010 10:27:59 PM

Thanks for the Reply falcon... i messed around with taking out various compoments and seeing if it would start up. After trying the RAM, fans, HDD taking them out one-by-one testing if it would start, it wasnt usintill i cam across the GFX card that it began to work... i removed the card booted up then placed it back in and hey-presto it started working again... strange!

By the way the CPU still works great and im not using the the new fan as pushes against my RAM

Thanks
Related resources
a b à CPUs
May 1, 2010 10:51:27 AM

This is a good story of what can go wrong and then resourceful ways how to fix it. Digital cameras are so chea these days $20, I wish more people would take photos of these CPU accidents and post them. I've never seen so many bent pins but would have liked to.
a c 172 à CPUs
May 1, 2010 11:13:28 AM

The illuminated motherboard LED only means that the small, always on, 5 volt standby power supply inside the PSU is working.
!