Asrock 890gx extreme 3 memory settings?

Why can I only set my 1600mhz ram to DDR3-800mhz in the bios?
11 answers Last reply
More about asrock 890gx extreme memory settings
  1. Hi.

    The speed that u see in the BIOS should be mutiplied by two because ur RAM works in dual channel (800x2=1600) go to windows download CPU-Z and check the RAM frequency in the RAM tab if u see 800MHz ur RAM is working at rated speed.

    If u want more help, please post all the specs of ur rig and maybe a pic of the problem can help too.
  2. CPU-Z Shows this in the memory section.

    http://img339.imageshack.us/img339/3296/ramuy.jpg

    Uploaded with ImageShack.us

    And my specs should be below.
  3. Your mobo should set the RAM @800MHZ by default so u need go to the BIOS and set all the specs of the RAM manually and also the voltage.
  4. I've set one setting in bios that said 800mhz-DDR31600? And how am I going to set it manually?
  5. Check where says "Memory Timing"
  6. Any setup I change in the Memory Timings has no effect on anything.
  7. When u select the 800 in the BIOS CPU-Z report 400MHz as in the picture right?
  8. Yes that's right.
  9. I have not more ideas, in the pics that I see of ur mobo's BIOS doesn't options to set the RAM manually and change the timings. You can try with the ASRock support, they should help u to solve the problem or u also can RMA the mobo and get another one from ASUS, Gigabyte or MSI.
  10. Found my system quite slow, therefore I was investigating the problem, what lead to this page.

    I have the same configuration same problem, but did see my BIOS version (Mainboard tab) shows P1.00

    Meanwhile they brought out Version 2.50. So I will upgrade my BIOS to see the memory modules get the right settings, let you know what it does.

    Rich
  11. Yes, with the new BIOS-version I do get the right Frequency of 800Mhz.
Ask a new question

Read More

Chipsets BIOS RAM Memory ASrock DDR3 Motherboards