Sign in with
Sign up | Sign in
Your question
Solved

EP45-UD3P > GSATA Raid + IDE drive = fail?

Last response: in Motherboards
Share
October 9, 2010 9:44:13 PM

I have no idea where to even begin, sorry. Here's the main story: i'm upgrading my system from a non-raid HDD to a RAID 1 setup with 2 HDDS on the GSATA (purple) ports. I also have a 10GB throw-away IDE drive that i partitioned into 2 parts: 1 for Windows Temp, other for Windows swap/paging file. i'd like to still use it, and that might be the root of the problem possibly. The errors I'm getting are occurring on both the "new" build, and the "current" build, and what happens is that - randomly almost - a partition will turn up as read-only (more below). It gets weirder: i can switch the drive letter for that partition, and then i can write to that drive. (The reason I'm switching back & forth is because it's my work computer, so i'm trying to migrate files/software and test stability before totally moving into it).

here's the basic details of the system:

- Win 7 HomePrem
- 8GB RAM, 3.4Gh Pentium D,

- "current build" HDD setup:
200GB SATA drive
10GB IDE swap drive

- "future build" HDD setup:
750GB SATA drive (x2) in RAID 1
10GB IDE swap drive

- nothing else fancy - video card, SATA DVD burner.

so here's what i'm wondering first: could there fundamentally be a problem with having an IDE drive running side-by-side a RAID array on the (purple) GSATA channel? under the "current" build, the only problem i've had is with one partition from the 10GB drive coming up as read-only. but under the "new" build, with the RAID array, I'm getting this problem with several partitions on the RAID disks. another thought: one of the partitions is encrypted via truecrypt.

anyway, i'm at a loss. is it the mobo? is it win7? is my initial setup? how come my IDE drive is now turning up screwy? hah any help appreciated! :)  apologies in advance for any pertinent info i've neglected to include. TIA...
a c 717 V Motherboard
October 9, 2010 10:19:38 PM

Welcome Newcomer! :) 

Before I even finished reading, but I did read it all - I would do the following:
1. I assume the 750's are identical HDDs.
2. Copy all of the data on 2-3 DVDs {decrypted of course}
3. Pull the IDE HDD
4. Reformat the RAID 1 750 ; I recommend 1 large Partition ; BIOS Refer to pages 27, 85-90
5. Install on ICH10R SATA2_0, SATA2_1 {YELLOW}:

CPU
| SATA2_4 | SATA2_2 | SATA2_0 |
| SATA2_5 | SATA2_3 | SATA2_1 |

6. Install OS
7. Verify RAID & Test ATTO {run 2-3 times} http://www.attotech.com/products/product.php?sku=Disk_B...
===

8. Shutdown and reconnect IDE HDD
9. Attempt data transfer from IDE if failure use the DVD copy
10. {verify ALL data is restored}Optional, but I would recommend a FULL format of the IDE 1 partition.

Good Luck!
m
0
l
October 9, 2010 11:06:19 PM

So you think I might've screwed the pooch then, with the RAID drives (identical = yes)? Smart move on my part then to not immediately start relying on them! Thanks for the reply, I think I get you pretty well. Re these 2 things you mention:

1. you prefer the South bridge/ICH10 vs the GSATA chip for the RAID 1

2. you prefer the RAID array to be one large partition, not several.

i'm pretty cool with all that. point 1 seems to be the general consensus all around, but i was actually hoping to have 4 or 5 partitions. is that generally a path to issues? and then after the benchmarking and stuff, it sounds like it should be ok to add back in the 10GB IDE drive (dunno why i insist on it, i really don't care - just seems like a good idea to put pagefiles & temp data on a separate partition/drive), and possibly i could also add back into the mix my 200GB SATA on the south bridge as well?

hey thanks much again!
m
0
l
Related resources
October 10, 2010 12:52:45 AM

i think i might have solved it actually: old OEM driver for the GSATA chip (jMicron JB36X). i tried running a "chkdsk /f /r" on one of the problematic partitions, and got "unspecified error occured", with an error of "696e647863686b2e dee". googling that term (plus "windows 7 raid") brought up about a dozen articles, and this one tipped me off: http://social.answers.microsoft.com/Forums/en-US/w7repa...

so i looked into it, and my driver version was at 1.38, and the current version is 1.59, with some of the write-protect issues being addressed in the 1.43 version.

i DL'd the very latest package (not the win7 specific one, just the very latest version), unzipped, and then via device manager, i updated the driver for Storage Controllors -> JMicron JMB36X Controller with (from the unzipped file) /floppy64/j_raid.inf ... reboot. done. all drives & partitions are writeable. even the IDE drive after plugging it in.

can't believe i fell for the old "outdated OEM driver" #fail. thanks! i'm going to mark this solved now.
m
0
l

Best solution

a c 717 V Motherboard
October 10, 2010 2:13:10 AM

A few things:
>the Intel RAID is more mature and therefore more reliable.
>partitions are fine if they server a purpose, but in many instances can cause excessive H/W reserve RAM usage.
>the Page File would b better served {off} the slower IDE drive, and in most instances will be cause much of a slowdown if there's adequate physical RAM. Use a Flash Drive it is a lot faster and doesn't "fragment." Solid State does not suffer fragmentation like HDDs.
>regarding the 200GB SATA just put it on SATA2_2 it will be a non-member RAID and typically runs in AHCI mode.

Again, chopping your HDD into small partitions on most Windows machines server little purpose; if you want multiple OSs running then indeed partition the HDD RAID. Also, keep in mind RAID 0, 1, and 10 do not require stripe calculations and are relatively simple, but the on-board RAID is marginally acceptable as it is and doesn't compare to a dedicated RAID controller.

Good Luck!
Share
!