Sign in with
Sign up | Sign in
Your question
Solved

SSD in AHCI after Windows is installed, with User Data on IDE HDD

Last response: in Storage
Share
March 9, 2012 2:05:33 AM

Hi guys,

I was attempting to set up my SSD to run as an AHCI instead of an IDE drive without reinstalling Windows. When I change it in the bios, it is no longer recognized as a boot device, and tried to boot from my hdd, which doesnt have an OS installed, so i get a message saying the NTLDR is missing. By pressing f8 and selecting to boot from the SSD it allows me to get through booting. However, instead of saying welcome at the loading screen on windows 7, it says preparing desktop. Once it loads, I get an error messege saying C:\windows\system32\config\desktop is an invalid location. Would this be due to the fact that I have my windows use data all stored on my D drive, a HDD? I had to do a system restore because even once i had switched my SSD back to IDE it was still not loading my desktop. I have already edited my registry as the win7 forums say.

So basically, my question is; Can I switch my SSD to run as AHCI with all my user data (such as desktop info) storred on my HDD?

I may be missing my AHCI drivers, I had some difficulty trying to install them. I have the latest BIOS version.

Thanks for your time and help!

Mobo: Asus M4a87td\evo
SSD: OCZ Solid 3 120gb
HDD: Seagate 500gb 7200 rpm
CPU: AMD Phenom II x2 965
OS: Windows 7 Home Edition

Edited for grammar.

Best solution

a c 289 G Storage
March 9, 2012 1:42:37 PM

Short answer: If you switch the controller mode to AHCI and get the SSD to boot, you should be able to see the other drives with no problems.

But, other than that bit of knowledge, I can't quite figure out your issue. Win7 should be able to reboot in AHCI mode after you make the registry tweak. Have you tried booting with only the SSD attached to the system? And once that goes smoothly, add the other drives back?

When you installed Win7 to the SSD, was your former boot HDD still attached to the system? That can lead to interesting issues.
Share
a b G Storage
March 9, 2012 1:52:29 PM

if you are switching from ide to ahci

REINSTALL WINDOWS

seriously
m
0
l
Related resources
a b G Storage
March 9, 2012 2:14:09 PM


I suspect your system restore dinked your registry hack.

I've had limited success with the hack on other machines -- 1 or 2 successes out of 6 or so attempts.

Best thing, really, is to set your drives to AHCI, copy the latest INF to a thumbdrive, load it when prompted and re-install as folks have noted.

I do think one of my successes was on an Asus mobo, though, so maybe you can keep banging away from that end (you would certainly need to redo the hack!)



edit: And yeah . . . Windows does get confused when you move default desktop folders and such.

m
0
l
March 9, 2012 8:01:57 PM

Best answer selected by Korrix13.
n
nI just started it over again doing the registry edit, then changed it in bios, and used F8 to select my SSD from the boot device list and everything is working. AS SSD shows my ssd as running in asahci. Thanks for the advice.
m
0
l
November 8, 2013 6:34:01 PM

i have a interesting case... backed up a IDE HDD with acronis true image 2014 to a SSD and windows fails to load - but it does load in safe mode so...
from there there should be the option to reinstall using windows dvd but keeping settings and programs by going through upgrade/repair option on disk (can be launched only from within windows) - but my dvd drive just died so im stuck now in limbo...
m
0
l
!