Asrock z77 extreme4-m overclocking help

Good evening all..so im having little issues with i5 3570k and asrock z77 extreme4-m...just tried overclocking disabled all option i needed...used a overclocking guide..but after all bios dont let me change multiplier to more than 38...that option not highlighted like other and whatever i write after pressing enter or other key it return to 38...any tips would be apriciated guys thank you...
5 answers Last reply
More about asrock extreme4 overclocking help
  1. First you should make sure your motherboard has the most up to date bios. Then you should set the bios settings back to stock. You don't need to disable/enable anything to hit 4Ghz (40). Just click advanced oc and change the multi to 40 and press enter..
  2. Bios updated to latest...i still cant change multiplier...whatever i do it returns to 38(i5 3570k)...its like that section locked..dont let me change multiplier...
  3. Are you sure you have the 3570k and not the non-k version?
  4. You're not adjusting the turbo multiplier are you? You should just disable turbo and then run the CPU Ratio/Multiplier up a bit. It sounds like you're limited because of the turbo multiplier and not the actual chips multiplier.
  5. Ho would he be limited by that? I have same cpu and I just put the turbo multi at 45 and that was it.
Ask a new question

Read More

Motherboards Overclocking ASrock Intel i5