PSU connection help

When connecting my 650w antec earthwatts PSU to my GA M770T UD3P mobo, do i connect both the 24 pin cable and the 8 pin cable, or does the 24 pin cable provide all necessary power to the mobo. Its been a while since i have done this and i am unsure and don't want to screw up.
13 answers Last reply
More about connection help
  1. plug in both
  2. You need both power cables plugged in. You also need the heatsink fan plugged into the correct fan power plug.
  3. I'll back up the last two posts. You absolutely need both connections plugged in. The 8-pin connector provides power to the CPU. The system doesn't have a chance of working without that plugged in.
  4. i turned the power on and the gigabyte screen popped up for a second and then it went to another screen that says:

    IDE Channel 3 HDD Smart Capability Disabled

    PCI Device listings

    Verifying DMI Pool Data
    AMD Data Change

    Update New Data to DMI
  5. That looks good. You need to boot onto a CD and install the OS now.
  6. Things are not going well. Have tried to boot win 7 3 times. actually had it runing and tried to install infrared mouse and keyboard and froze. Haven't been able to get it up and running since. I have mushkin memory that is not on the list. Suppose to have 7-7-7-20 timing and the mobo is defaulting it to 9-9-9-24. Should i send the memory back for one that is on the list of the mobo. This memory had gotten good reviews.
  7. I wouldn't send the RAM back. All you need to do is manually set the RAM speed/timings/voltage to the correct specs in the BIOS. The motherboard owners manual should tell you how to do that.
  8. I have tried all day to load windows 7 on GA-MA770T-UD3P Motherboard with a 630 propus chip, seagate 750GB SATA HDD, and Mushkin BLackline DDR3 1333-10666 memory. I have done so with the help of my neighbor who spends all day testing components for companies like intel and amd. He seems to think that the problem is with memory compatibility. This memory was not on the list of acceptable modules on the GIG site. Is there any reason to believe that this is not the reason for the failure that i am having. I have tried updating bios as well as drivers for sata. Windows will start and then say that it is unable to complete installation until after reboot then does the same thing. I am fried and have no idea what to do. I have windows 7 ultimate and a brand new rig and i can't even get the damn thing to work. I am a newb but i don't think that explains what is happening. Is their any reason this setup would do great with WIN 7 with the exception of the RAM because of incompatability. ANSWERS PLEASE!!!! I have already requested RMA for memory, do i need to add to the list.
  9. I've already told you what I think the problem is. This type of problem is most often solved by manually setting the RAM speed/timings/voltage to the correct settings in the BIOS. Mushkin makes very high-quality RAM. I would be very surprised if the RAM is not compatible.

    You should also download Memtest86+ from, burn it to a CD, and boot from the CD. A memory test will start automatically. Let it run overnight to test for RAM errors.
  10. I noticed that my board is rated for 1.5v and the memory is rated 1.7v. Could this be the problem. memtest86+ locked up the first time
  11. could i overclock the voltage for the memory to bring it up to spec without hurting the mobo
  12. Yes, setting the RAM voltage to its rated setting won't hurt the motherboard.
  13. apparently this was creating a problem. i changed the ram voltage as well as added a driver for setting hdd to achi instead of ide and got windows to boot up. hopefully it will continue to run.
Ask a new question

Read More

New Build Connection Cable Systems