Sign in with
Sign up | Sign in
Your question

Thief and XP

Last response: in Video Games
Share
Anonymous
June 16, 2004 1:42:12 PM

Archived from groups: alt.games.thief-dark-project (More info?)

Taffers,

Okay, I seen T3 needs Win2000 or XP. We've been upgrading to XP all
round, so that's not a problem. But will T1 and T2 also run under XP
okay?

I have the game. Iron self control is being used...
--
Terry Pratchett

More about : thief

Anonymous
June 16, 2004 1:42:13 PM

Archived from groups: alt.games.thief-dark-project (More info?)

On Wed, 16 Jun 2004 09:42:12 +0100, Terry Pratchett
<tpratchett@unseen.demon.co.uk> wrote:

>Taffers,
>
>Okay, I seen T3 needs Win2000 or XP. We've been upgrading to XP all
>round, so that's not a problem. But will T1 and T2 also run under XP
>okay?
>
>I have the game. Iron self control is being used...

Yes, they both run under XP fine. Depending on your setup you may
encounter small problems with either the initial installation or with
keeping the video codecs working for the cutscenes and briefings, but
those are both fixable.

--
Michael Cecil
http://home.comcast.net/~macecil/
Anonymous
June 16, 2004 1:42:13 PM

Archived from groups: alt.games.thief-dark-project (More info?)

"Terry Pratchett" <tpratchett@unseen.demon.co.uk> wrote in message
news:QnKBpeNkfA0AFAKX@unseen.demon.co.uk...
> Taffers,
>
> Okay, I seen T3 needs Win2000 or XP. We've been upgrading to XP all
> round, so that's not a problem. But will T1 and T2 also run under XP
> okay?
>
> I have the game. Iron self control is being used...
> --
> Terry Pratchett

I cannot get Thief2 to install on XP, even with the workarounds suggested.
Related resources
Anonymous
June 16, 2004 3:28:45 PM

Archived from groups: alt.games.thief-dark-project (More info?)

"Terry Pratchett" <tpratchett@unseen.demon.co.uk> schrieb:

> Okay, I seen T3 needs Win2000 or XP. We've been upgrading to XP all
> round, so that's not a problem. But will T1 and T2 also run under XP
> okay?

T1, T2 & T3 run perfectly on my XP

--
Dennoch gibt es einen gewaltigen Unterschied, ob ich mit Linux oder mit
Windows herunterfahre...d.h. mit Windows egal von welcher Version
passiert das nicht wie mit Linux <g>
("Merlinux" in <3D47918F.4070307@yahoo.de>)
June 16, 2004 3:48:29 PM

Archived from groups: alt.games.thief-dark-project (More info?)

Terry Pratchett <tpratchett@unseen.demon.co.uk> wrote in message news:<QnKBpeNkfA0AFAKX@unseen.demon.co.uk>...
> Taffers,
>
> Okay, I seen T3 needs Win2000 or XP. We've been upgrading to XP all
> round, so that's not a problem. But will T1 and T2 also run under XP
> okay?
>
> I have the game. Iron self control is being used...
The only problem I had with Thief 1/2/FM on XP was due to having a
processor that allows emulation of multi-threading. There are write
ups on how to get around that though.
Anonymous
June 16, 2004 4:09:50 PM

Archived from groups: alt.games.thief-dark-project (More info?)

ReddShadoe wrote:

> "Terry Pratchett" <tpratchett@unseen.demon.co.uk> wrote in message
> news:QnKBpeNkfA0AFAKX@unseen.demon.co.uk...
> > Taffers,
> >
> > Okay, I seen T3 needs Win2000 or XP. We've been upgrading to XP all
> > round, so that's not a problem. But will T1 and T2 also run under XP
> > okay?
> >
> > I have the game. Iron self control is being used...
> > --
> > Terry Pratchett
>
> I cannot get Thief2 to install on XP, even with the workarounds suggested.

I have had no problems at all running T2 or T2 FM's on XP.
Albert
Anonymous
June 16, 2004 4:17:37 PM

Archived from groups: alt.games.thief-dark-project (More info?)

"ReddShadoe" <reddshadoe2@comcast.net> wrote in message
news:VtKdnbqHxL8nhE3dRVn-jg@comcast.com...
>
> "Terry Pratchett" <tpratchett@unseen.demon.co.uk> wrote in message
> news:QnKBpeNkfA0AFAKX@unseen.demon.co.uk...
> > Taffers,
> >
> > Okay, I seen T3 needs Win2000 or XP. We've been upgrading to XP all
> > round, so that's not a problem. But will T1 and T2 also run under XP
> > okay?
> >
> > I have the game. Iron self control is being used...
> > --
> > Terry Pratchett
>
> I cannot get Thief2 to install on XP, even with the workarounds suggested.
>
>

What happens? Or doesn't, as the case may be!
Anonymous
June 16, 2004 6:04:47 PM

Archived from groups: alt.games.thief-dark-project (More info?)

Terry Pratchett <tpratchett@unseen.demon.co.uk> wrote in message news:<QnKBpeNkfA0AFAKX@unseen.demon.co.uk>...
>
> Okay, I seen T3 needs Win2000 or XP. We've been upgrading to XP all
> round, so that's not a problem. But will T1 and T2 also run under XP
> okay?

Depends - but I think every problem is solvable.

Pentium 4's Hyperthreading must be disabled for all Dark-Engine-games
(T1/T2/SS2).

Personally I have no trouble - but I needed to use a workaround for my
new Nvidia-card (drivers >= v53.03).
Also T1-Gold crashes, when I use the "Options"-screen (which I don't
really need to - one can modify the ini-files with an editor).

> I have the game. Iron self control is being used...

Don't wait - play it! Though it has some shortcomings I think its the
best installment of the franchise in some important aspects: Story &
plot, atmosphere, graphics- & sound-quality. Voice acting is awesome,
also.

Please post your experiences, when you have finished the instant
classic mission which is the highlight of the whole game! You'll know
which one, when you play it ;-)
June 16, 2004 7:33:06 PM

Archived from groups: alt.games.thief-dark-project (More info?)

I just installed ThiefGold on XP. I had to use the "setup -lgntforce" to
install the game, and also had to enable Vsync in the videocard display
properties. That's it!

rms
Anonymous
June 16, 2004 7:51:19 PM

Archived from groups: alt.games.thief-dark-project (More info?)

On Wed, 16 Jun 2004 05:56:17 -0400, "ReddShadoe"
<reddshadoe2@comcast.net> wrote:

>
>"Terry Pratchett" <tpratchett@unseen.demon.co.uk> wrote in message
>news:QnKBpeNkfA0AFAKX@unseen.demon.co.uk...
>> Taffers,
>>
>> Okay, I seen T3 needs Win2000 or XP. We've been upgrading to XP all
>> round, so that's not a problem. But will T1 and T2 also run under XP
>> okay?
>>
>> I have the game. Iron self control is being used...
>> --
>> Terry Pratchett
>
>I cannot get Thief2 to install on XP, even with the workarounds suggested.

What exactly is happening?
--
______________________________________________

What's up Chuck?


---------------------------------------------------------------------------------------------
Anonymous
June 17, 2004 3:19:58 PM

Archived from groups: alt.games.thief-dark-project (More info?)

juniper left a note on my windscreen which said:

> > Okay, I seen T3 needs Win2000 or XP. We've been upgrading to XP all
> > round, so that's not a problem. But will T1 and T2 also run under XP
> > okay?
> >
> > I have the game. Iron self control is being used...
> The only problem I had with Thief 1/2/FM on XP was due to having a
> processor that allows emulation of multi-threading. There are write
> ups on how to get around that though.

I think this is a problem I'm having. I'm looking now for a way to get
around it but haven't found anything yet.

Any chance of a link?
--
Stoneskin

[Insert sig text here]
Anonymous
June 17, 2004 4:09:02 PM

Archived from groups: alt.games.thief-dark-project (More info?)

"Stoneskin" <no@thanks.com> wrote in message
news:MPG.1b3b80a7cc8045d5989879@news.individual.net...
> juniper left a note on my windscreen which said:
>
> > > Okay, I seen T3 needs Win2000 or XP. We've been upgrading to XP all
> > > round, so that's not a problem. But will T1 and T2 also run under XP
> > > okay?
> > >
> > > I have the game. Iron self control is being used...
> > The only problem I had with Thief 1/2/FM on XP was due to having a
> > processor that allows emulation of multi-threading. There are write
> > ups on how to get around that though.
>
> I think this is a problem I'm having. I'm looking now for a way to get
> around it but haven't found anything yet.
>
> Any chance of a link?

http://www16.brinkster.com/salvage/thief/darkengine.htm
June 17, 2004 5:22:36 PM

Archived from groups: alt.games.thief-dark-project (More info?)

"Stoneskin" <no@thanks.com> wrote in message
news:MPG.1b3b80a7cc8045d5989879@news.individual.net...
> juniper left a note on my windscreen which said:
>
> > > Okay, I seen T3 needs Win2000 or XP. We've been upgrading to XP all
> > > round, so that's not a problem. But will T1 and T2 also run under XP
> > > okay?
> > >
> > > I have the game. Iron self control is being used...
> > The only problem I had with Thief 1/2/FM on XP was due to having a
> > processor that allows emulation of multi-threading. There are write
> > ups on how to get around that though.
>
> I think this is a problem I'm having. I'm looking now for a way to get
> around it but haven't found anything yet.
>
> Any chance of a link?
> --
> Stoneskin
>
> [Insert sig text here]

The information you need can be found here:
http://www.ttlg.com/forums/showthread.php?t=75031

Nightwalker


--
**Remove "leavemealone from my email address to reply.**
Anonymous
June 18, 2004 2:18:51 PM

Archived from groups: alt.games.thief-dark-project (More info?)

Nightwalker left a note on my windscreen which said:

> The information you need can be found here:
> http://www.ttlg.com/forums/showthread.php?t=75031

Thx to you and SpammersDie. It was the safe_texture_manager which fixed
the prob.

I can play my T2 again - w00t!
--
Stoneskin

[Insert sig text here]
!