Sign in with
Sign up | Sign in
Your question

2.5" SATA will not format or partition

Last response: in Storage
Share
March 10, 2012 11:52:39 AM

Hello everyone. I have a situation that is baffling me. We have recently upgraded our Dell PowerVault RD1000 data cartridges to 320gb. I now have (2) 80gb & (3) 160gb RD1000 cartridges availible. Inside of each cartridge is a 2.5" SATA II Fujitsu drive. Not having another RD1000 to use, I figured I would just remove the SATA drives from the cartridges and put them in a USB enclosure.

After removing all of the drives from the cartridges, I tested one of them in my USB SATA hard drive enclosure, which had another working drive in it. Once I plugged the USB drive in to a Windows 7 SP1 machine, it began to install the drivers just as normal. Even got the messege that the drivers installed successfully and drive is ready to use. Only thing is, Windows did not create a drive letter. In Device Manager, the drive shows up with the correct availible space but only lists it as 'Drive 5'. No drive letter association. It did ask me to choose MBR or GPT, so I chose MBR. I did this with all 5 drives and all of them resulted the same way. I am unable to format any of the drives.

So I figured maybe the USB enclosure might be the problem and I installed one using BIOS and connected it to my motherboard. BIOS recognized the drive size and serial number. Once I exited out of BIOS and restarted, the computer said I did not have boot disk. So I guess it disabled my other hard drives.

I then tried several software titles to try testing, formatting and what ever I could to get them to work, all to no avail.

I can 100% assure you that these hard drives do work properly, but only when in the cartridge and through the RD1000. Is it possible that Dell could have locked or secured these drives to only work with their hardware? I find that hard to believe. Even if they did, there should be a way to get through this and make these drives work.

Sorry for the long post. I wanted to make sure I expained everything clearly.

Thanks
Ken

More about : sata format partition

a c 261 G Storage
March 10, 2012 11:59:56 AM

And in disk management you can not allocate and assign them drive letters?
(computer management/storage/disk management)
m
0
l
March 10, 2012 12:14:32 PM

No. After I plug in the USB and all drivers install correctly, I go to Disk Management it pops up with 'Initialize Disk', and I select MBR. Then, a 'Data Error (cyclic redunancy check) comes up. Once Disk Managaement finally comes up, it just has Disk # and unallocated space. Right-clicking to format or any other options are not availible.
m
0
l
Related resources
a c 261 G Storage
March 10, 2012 12:21:16 PM

That is really strange, any jumpers on them? (only way I see them able to lock them)
m
0
l
March 10, 2012 12:33:44 PM

It doesn't have the terminals for the jumpers to fit on.
m
0
l
a c 261 G Storage
March 10, 2012 12:52:48 PM

I am stumped! Wonder if connected as only drive if you could install windows on them.
m
0
l
March 10, 2012 12:59:27 PM

I will try it that way. I currently have a RAID1 in SATA0 & SATA1. I will remove the RAID1 drives and disable all SATA ports except for SATA0 and put one of the problem Fujitsu 160gb drives in port SATA0. Of course leaving the SATA port with the DVD ROM drive that has the Windows disk in it.

Will report back shortly.

Results:
It didn't work. I did run some other tests while in BIOS though. From the 'Boot Device Menu', I ran a HDD diagnostics test, which it Passed. But it still would not boot up, not even to the CD ROM. I have never seen anything like this before.

I took several screenshots of what I have attempted so far.

Screenshots: http://slaydesigns.com/SATA_DRIVE_ISSUES/

Update:
I have found a little information from Experts Exchange

by: pgm554
"Knowing Dell and other vendors, I would say there is a pretty good chance the firmware on the Dell drives is proprietary and the RD1000 BIOS will not work with non Dell drives ."

I also read that it is probably a Linux file system. Does anyone have any suggestions from this newly aquired information? I have tried TestDisk and Explore2fs which did nothing. I have little knowledge with Linux.

Thanks
m
0
l
March 14, 2012 5:42:59 PM

I finally have found out exactly what the problem is.

From the Dell forum
dwalkes Writes:
"You cannot use RDX or RD1000 cartridges without an RDX or RD1000 dock. Using a generic SATA to USB adapter will not work. The reason for this behavior is that are areas of the disk are reserved for cartridge metadata. This explains the unrecognized file system displayed in disk management on your Server 2008 machine.

You will need to purchase an RD1000 dock to use with your Server 2008 machine in order to access RD1000 cartridges from that machine."

The RD1000 Docks are over $400, so all of the unused drives are useless now. Very disappointing. Thanks Dell. :heink: 

m
0
l
January 27, 2013 3:54:01 PM

Hi,

I have the same problem with a 1To hard drive extracted from HP RDX cartridge and impossible to format it or create a partition (I m on linux system) I tested with Acronis and other tools of Hiren's boot CD and with windows but always an error input/output.....
I search on the net and found this post and now I'm sure that's impossible to use this dard drive without a specific RDX dock! Thanks HP !
m
0
l
!