Closed

Sapphire Radeon HD5670 1GB GDDR5 won't work

Hi,

I got a new Sapphire Radeon HD5670 1GB GDDR5 but it won't work. I wanted to upgrade my old graphic card to HD5670 but there must be some compatibility problem with my motherboard (ConRoe945g-dvi, PCIe x16). Does anybody hove advise how to solve this problem ? Do I have to change some settings in BIOS or something? The card seems to be ok as when the DVI cabel is connected the massage on the screen is changing from "no DVI cable connected" to "Power saving mode"( something like "stanby" mode). Nevertheless when the system starts nothing is happening, the screen stays black. Maybe it is not possible to use my old motherboard with this new card.

My system spec:

Motherboard: ConRoe945g-dvi
Precessor: Intel 6600@ 2.40GHz
Memory: 4GB DDR II 667
PSU : 400W

Please help.

Thanks a lot
6 answers Last reply
More about sapphire radeon hd5670 gddr5 work
  1. I think the minimum PSU is 450 W for the 5xxx series, however did you connect the 6 pin PCI E connector if it needed one?
  2. No, the minimum PSU is 400W that is what it says on the box of the card anyway. I' ve connected it with 16pin PCI E connector there is no 6 pin...
  3. Did you disable the onboard GPU in the bios after installing?
  4. Yes truhls, the onboard GPU is disabled automatcally after you conect new card to the PCI. I had Asus x1050 series installed before.
  5. You may need to update the BIOS version:

    version 2.00 - Support ATI-HD5XXX series VGA card.

    http://www.asrock.com/mb/download.asp?Model=ConRoe945G-DVI&o=BIOS
  6. This topic has been closed by Mousemonkey
Ask a new question

Read More

Graphics Cards Sapphire Motherboards Radeon Graphics