Sign in with
Sign up | Sign in
Your question

Abit AV8 not detecting SATA drive

Last response: in Motherboards
Share
October 16, 2010 4:37:49 AM

I have been trying to figure this out all day and am beyond frustrated. I have searched all over the Web for a solution but nothing seems to be working.

I built my mother a computer not too long ago, and though I tested the drive I was reusing to ensure it was in good working order, it crapped out a couple of days ago. I ordered a new WD 160GB Caviar Blue SATA to replace it and it arrived today. I got it installed fine and went to install XP Pro when I got the "No drive" message. I checked BIOS and sure enough, it was not detecting the drive.

Obviously I am running the Abit AV8, which is a bit older and has SATA 1.5, so I set the jumper on the drive to slow it down. I have gone through every possible setting in BIOS as suggested by various boards I have visited in my search for a fix. I have the SATA/RAID floppy and have tried running the setup using F6 and loading the VIA as well as other drivers. I downloaded the last SATA drivers and put them on a floppy and tried those as well.

I moved the hard drive to another box to see if it was the drive or cable, but it was detected fine. I then decided to install the OS on the other box and see if it would detect the drive after the install was done, but nothing. I tried running a repair install on the existing OS on the AV8 with and without loading the SATA drivers. I wanted to try to load the drivers on the XP install while it was in the other box and see if it would detect the drive with the AV8 drivers installed, but I was unable to load the drivers without the relevant hardware.

I have rebuilt several machines with this motherboard in the past and have NEVER had an issue getting the install to work properly.

Any suggestions for what I may have missed?

thx
a c 92 V Motherboard
October 16, 2010 5:19:44 AM

The AV8 is one of those original S940 boards isn't it? I think it also have a Via controller. Rumor has it those controllers can't use SATAII drives at all, even with the jumper on them. I'd return that drive and see about getting an old SATA drive.

Updating the bios might help as well.
m
0
l
January 12, 2011 1:31:46 PM

Here's the sorry position I am in which at least confirms or answers some of your peripheral questions. Perhaps if we work together.
Hello,
I have the same problem as jb11 (Question 4745454b) (Who described it well). I bought this PC with an Abit AV8 Motherboard new and assembled by a shop and could not load an OS , (XP 32 bit) as it kept saying No Hard Drives. The BIOS seems to say nothing about SATA drives. So I took it back to the shop and they loaded an XP OS for me 32 bit I think? I have been installing 32 bit drivers so I guess it must have been a 32 bit XP. The machine ran fine for 5 years with 2 SATA drives and two DVD's on the first IDE port, master slave, running the OS from the first SATA drive. Trying to upgrade to SP3 I screwed up the OS so tried repairing then reloading it. (In case you’re wondering the shop I bought it from has since closed down or obviously I would have asked them.) All the time the system said "no hard drives detected". So I wiped and reformatted one of the two SATA drives, it is connected to port 1 of the two available ports straight off of the motherboard the same arrangement that worked before. Only difference is there's only one SATA drive so obviously can't RAID which maybe significant? I disconnected the other one as it had data on I did not want to screw up. I have tried using Nlite to add a SATA driver and also tried the F6 way with the XP OS load disc. I am trying to load a driver designated as 430g from the Abit site. Using the F6 way I get error at line # 2018 or some such number and it fails. I have googled this fault and again for one reason or another got no where having tried all suggestions. Tried reseting the BIOS by shorting with a strap as instructed in the manual and installed the latest BIOS yesterday. Can't find anywhere in the BIOS where SATA is mentioned. Some forums say you need RAID turned ON, some say turned OFF. Obviously have tried both ways. The drives are about 5 years old and are definitely 1.5 speed so that is not an issue. Some blogs say 3.0 speed drives won't work with VIA raid. Finally I have installed a PATA drive with a loaded XP SP3 OS and run it up. From here I have tried running the VIA SATA raid driver but it completes and says "failed No device". I have installed all the drivers from the Abit supplied DVD and still no good. I have emailed Abit 3 times, twice through their web site directly and once to another support email address and have had NO reply despite their claim to answer in 24 hours! Last time I buy an Abit product.
I have read tens of forums but no one actually identifies the driver versions they have used to get out of this mess or they don't come back and say how they succeeded. Some refer to drivers on a floppy which came with the machine but I have not had that floppy and they don't id the files on the floppy and their sizes which would give me a chance to id them and find them somewhere. Please be pedantic and specific in your reply identifying any components I need to use and avoiding pronouns as far as is reasonable. I feel like a fool so if you treat me like one that will work fine. I've spent 3 days plus up to now and learnt a fair bit but am getting a bit frustrated. Not least I’ve learnt how crap Abit support is.
I’m new to this site so sorry if I’ve posted this in the wrong place.
Thanks in advance for even reading this version of War and Peace.

Any help appreciated.
Desperate of Broadstone.
And by the way how do you find a post on this forum? I searched on the post number 4745454b and Abit and AV8. No result seemed to make any sense. And have you seen how many sites you have to allow to operate on this forum - a bit worrying.
Bob24lemans.
m
0
l
Related resources
a c 92 V Motherboard
January 12, 2011 2:51:59 PM

I doubt you'll ever buy an Abit anything again seeing as they are out of business. I also doubt you'll ever get a reply. Welcome to the world of a folded company.

Double check that the drives are 1.5. I've never heard of 1.5 drives not working. As for your search problem, what do you mean the results don't make sense?
m
0
l
January 12, 2011 4:24:53 PM

Thanks for the info on the closing of Abit that explains that.
The drives are 1.5 as I have read this on their labels.
I have just noted on the Abit AV8 Motherboard spec that it supports 1.5 speed hard drives which might be taken to imply they don't support 3.0.
I don't base fault finding on uncertain information or at least I would state my assumptions up front.
As I said this board has been running these 1.5 SATA drives for 5 years so it is clear I either don't have the right drivers or am doing something wrong.

I was trying to get back to the thread by a search from the home page:
Try searching in the search box for the thread Id for this thread (that is "4745454b") and see what you get? Also try searching on "AV8"
or "AV8 SATA"
or
"jb11" The name of the originator of the thread?
Then I tried the same searches in the Forum page, try that too.
bob24lemans
m
0
l
a c 92 V Motherboard
January 13, 2011 12:34:45 AM

To find threads I simply look at the upper right hand corner. You should see a box with "profile, threads, messages" up there. If there is a new post, then it should be listed under threads. To get to the forum I click on one of the random threads on the main page.

BTW, 4745454b is not the ID for this thread, its my name.
m
0
l
January 13, 2011 9:43:36 AM

Hello 4745454b,
Thanks for the info but I can't see a box with "profile, threads, messages" anywhere. I’ve looked on the home page or the forum page or this page. Have you got a login with different permissions? I also can't see a thread Id anywhere, now you've cleared up the confusion I had about your name being the thread Id.
This thread was the first I have looked at on this site so your Id looked like the thread Id so I used it. I have just re-looked and I can't find a thread id anywhere around the thread text - thinks have I gone blind?

Anyway to the PC problem. Last night (until 1.30 Am - Now into 4th day!) the machine stopped booting from the IDE hard drive after I re-organised the cabling to include the DVD writer drive which I wanted to use, on the second IED port. This port had not until then ever had anything connected to it. I used this connector as it was the most convenient port for the cable I had and the DVD writers location in the PC case. I only had a DVD reader connected up until then on IDE port 0. To my shame I accidentally plugged the IDE cable in upside down. Hey presto, re-booted and the motherboard was reporting the presence of the SATA Maxtor on IDE port 3 (I think or it may have been port 4) Not bad considering it only has 2 physical IDE port sockets. And why is it reported as an IDE component not a SATA ?? I have just looked up the official Abit spec for this MOBO and it states “2 x Ultra DMA 133/100/66/33 Connectors and 2 x SATA 150 Connectors”. I then tried every IDE and SATA / hard drives / DVD drives connection arrangement I could think of. Nothing got the IDE hard drive OS working again. It kept reporting this problem about a crc value not being the same as that in the file. (not even connecting the cables up properly ..Joke) It said - "Bad Image Checksum" "C:\windows\System32\MSVCRT.dll". This was the same problem that stopped the SATA hard drive OS from running up. So I put the IDE hard drive back in my old "IDE only" PC and ran windows up from it OK. I feared I had wrecked the OS on this hard drive alone with a load of precious data but thank heavens obviously not.
Back to the problem PC - I found I could see the SATA hard drive but it would not boot from it. That was quite encouraging as it was the first time since the crash the MOBO had even seen a SATA hard drive. During all the reconfiguring I had by now reconnected the SATA hard drive with the original OS loaded on it which I had kept unconnected for fear of messing it up and loosing the data it has. But as I said above the PC would not boot from it. So I put in the MS OS install DVD disc and tried an OS install. It detected the OS on the SATA hard drive and said "you really want to do a repair", so I agreeded and off it went until it asked for a VIAAGP1 driver file. I found this and offered it on a floppy (as explained on a forum somewhere in cyberspace) and it read the file off of the floppy but then just hung up?
That's where I am now but...
Conclusions:
1.) There is a very strong hardware aspect to this.
2.) What’s all this about a 3rd or 4th IDE port being reported by the MOBO??? Can't VIA or the BIOS refer to the ports properly, they are SATA ports surely? but at least I am getting a connection to the SATA drives and not being told "no drives are detected.
(It does not help that IDE ports on this board are numbered 0,1,2 etc as standard practice and the SATA ports are numbered 1,2 etc. Couldn’t they stick to the same convention of starting the numbering from 0 for both??)
3.) From above I am suspecting that either the VIA stuff is really *** and you have to struggle with different physical cabling configurations of hard drives, DVD drives and IDE & SATA ports to get the MOBO to play ball.
or
4.) I have a hardware fault which the original shop fix was a work around for and I have now stumbled into it OR both 3.) and 4.).

Not sure I expect anyone to attempt to help with this but at least it's a record for how I got what I got and what I have tried up to now. (War and Peace part 2 directors cut........)
If you fancy a shot at it I'm up for any conversation as this has made me into a hermit computer geek. I need to get out more! actually get out at all.

BTW: I got a very helpful reply from Kevin Wang (汪兆原)

Channel Service Department
Technical Service Centre
Sales and Services
Universal Scientific Industrial Co., Ltd.
Tel:049-2350876 Ext: 23165
http://www.usi.com.tw/

I can only assume they have taken over the Abit support. It took 5 days so be patient if you use them. I've been there and you are just snowed under by the incoming emails. Working for a company that really cares. (no hint of sarcasm honest.)

What would make this all worth, while Ha Ha, is if someone could explain how I can add an emoticon to my message?
10 years in IT and I can't do that. I'm just pathetic!
I ought to add an apology for right royally hijacking this thread. Sorry JB.
Takes deep breath.
Try “MUMFORD and SON’s” Album “No More Sighs” Truly excellent - lyrics are real poetry. That’s my pay back for you reading this. Thanks.
Not beaten yet!
Bob24lemans
Remember:
Two's company threes an erotic fantasy!http://img.tomshardware.com/forum/uk/icones/smilies/pt1...
Did the emoticon work? Yipee!!! ( Finally cracked under the pressure.)
I'm putting this in for a pulitzer.
m
0
l
a c 92 V Motherboard
January 13, 2011 12:21:25 PM

I skimmed that, your writing it hard to read. That box is up there. Right underneath the "IT resources" and "Compare prices" tabs.

You show a 3rd and 4th IDE channel because your SATA ports are in IDE emulation mode. This makes it easy to add SATA drives because you don't need drivers. It will prevent all the neat SATA only stuff like NCQ and stuff like that. If your having issues after adding a DVD or optical drive odds are the jumpers aren't correct.
m
0
l
January 14, 2011 4:44:14 PM

Hello again,
Thanks for your last input. You'll see I have born it in mind below:
Some progress I think.
I have somehow got the BIOS to show, under "Standard Cmos Features"
both the IDE Channel 1 & 2 Masters and slaves (These are always present) and
IDE Channel 3 Master and 4 Master with the Seagate Hard Drive shown against 4 Master. I assume this means SATA port 1. (Channels 3 & 4 only appear depending on some other BIOS setting and condition(s) it seems.)

I have also used a Seagate tool to add a c: Partition to the Seagate drive.

I booted up with a MS XP OS disk in one of the DVD drives expecting it to allow me to install a new OS on the Seagate.
It say "press any key to boot from CD" - which I do.
It then say "Inspecting Hardware and configuration....." and the screen goes blank and the PC hangs?

I now have 2 DVD drives connected to IED port 1 Master and slave. Definitely jumpered correctly. I took the drives out to read the jumper instructions.
The Seagate has no jumpers required for normal use. I check on Seagate web site.

What is odd is that I can do anything with this hard drive using tools when attached to this MOBO, wipe it, add a partition, whatever I want but the MOBO does not want to use it in normal operation?
And the BIOS now seems to see it yet still no go?
That's my lot for today.http://img.tomshardware.com/forum/uk/icones/smilies/sle...

I have got the Maxtor SATA drive to struggle into life but half of the folders are "missing" and it crashes if you search for anything in the explorer so I guess it needs the OS rebuilding but not before I have off loaded the data I want.
Bye for now. Remember twos company threes a fantasy.
m
0
l
January 14, 2011 7:12:05 PM

Just adding a note to say:
Has anyone out their added a 300Mb/s SATA drive to an AV8 MOBO successfully? With or without jumpers to slow it down. If so what make and type was it as I think thats where I am going with this problem. If I can identify one I can buy it with confidence.
Thanks.
Bob24lemans
m
0
l
a c 92 V Motherboard
January 14, 2011 11:27:43 PM

Honestly considering the age of the board I would just replace. Its ancient tech and there is little point to putting up with it. $200 or so can get you a faster newer AM3 dual core CPU, 4GBs of ram, and a new motherboard that can accept SATA II/3.0 drives. For example,

http://www.newegg.com/Product/Product.aspx?Item=N82E168...
Athlon 2 x2 240. $51 shipped.

http://www.newegg.com/Product/Product.aspx?Item=N82E168...
Corsair XMS3 2x2GB DDR3 1600. $50, $40 after rebate. I would like to point out that you could get even cheaper memory such as this G.skill DDR3 1333 ram for $40 out the door. http://www.newegg.com/Product/Product.aspx?Item=N82E168...

http://www.newegg.com/Product/Product.aspx?Item=N82E168...
Asus M4A79XTD EVO for the board. Expensive at $99 and fills the $200 price point, but does come with another $15 rebate so assuming you get both will run you $175. Considering you'll have a nice dual core, 4GBs of ram and a board that will handle any drive you want to throw in there. Reuse your case, drives, etc and you'll be free of this madness.

m
0
l
January 15, 2011 9:02:13 AM

Dear Voice of reason,
Can't argue with a word of your suggestions. I'm in Poole in Dorset UK so will look at UK suppliers but a good solid Asus MOBO and build from there, sounds good to me.
Just a quick rant:-
I have bought from the States before and had to return the goods due to a fault. There's a good little British scam going which looks like a hidden embargo on trade. When I tried returning the goods I found a bureaucratic pain when reclaiming the import duty. They grabbed the duty from me by not allowing me to pick up the board from the post office without paying it up front when it was delivered. They made it very easy for me to hand over the tax. However when I tried claiming it back because I was returning the goods and getting my money back, the Post Office directed me to customs and excise. Customs and Excise insisted I fill in a 2 page form and post it off to be agreed before I got the import duty back! I thought it was commercial law that who ever you paid the money to, that being the Post Office (who you had effectively made the contract with) had a duty to deal with you if there's a problem. But no the P.O. tell you to FO and go to the excise people who give you a form much of which you don't know how to fill in. It took 2 calls to excise to work it out. How about that for discouraging international trade! The tax was over and above the list price of the item so that's another thing to be aware of. The import tax only applies to items over about £15 about $20 approx.

Thanks for all your advice, it was helpful and encouraging. Your words "free of this madness" are exactly right. In man hours at £10 an hour my efforts have cost £500. That's about $790! But I have learnt a lot. My knowledge has gone rusty since retiring so I have no problem with this use of my time.http://img.tomshardware.com/forum/uk/icones/smilies/sol...
Cheers
Bob.
m
0
l
a c 92 V Motherboard
January 15, 2011 10:57:23 AM

I live on the other side of the pond, so I thankfully don't have to deal with that. I do understand some of the issues however and don't think people are rude for not selling their used stuff even to those who live in Canada. Its not rudeness, they just don't want to put up with the BS. (or should I say PS? Political $h!7)

Being retired helps seeing as you have the time, but every now and then you have to cut your losses and move on. Hopefully you and the OP can find a way past your issues.
m
0
l
January 15, 2011 11:16:49 AM

If you're ever over here look me up, we can catch a beer or two.
Bob24lemans@hotmail.co.uk I read this account about once a week.
Cheers.
m
0
l
a c 92 V Motherboard
January 15, 2011 3:34:41 PM

While I would love to visit my native motherland (Scotland, Gordon clan.) I seriously doubt I'll ever get the chance. Besides, you probably like loggers while I prefer Amber Ale's like Fat Tire. Thanks for the invite however, it would be fun to sit around the pub and tell a story or two.
m
0
l
!