Sign in with
Sign up | Sign in
Your question

IOmega external HD keeps "vansihing" from computer

Tags:
  • Hard Drives
  • Iomega
  • Computer
  • HD
  • Storage
Last response: in Storage
Share
March 14, 2012 12:18:41 AM

I got a call from my father in law, whom I built a computer for a few years ago. He uses an Iomega external HD on it, 850 GB USB powered. He told me over the past 3 weeks he would go to access the harddrive and it would no longer be there, as it is normally listed as "Drive F:". It's happened about 3 times. No funny noises or anything. I'm assuming the harddrive may be going but want to make sure it isn't something else before he goes out and buys a new E-Hd. The HD has worked flawlessly for 4 years up to this point. I had him change power settings to not shut down USB power or Hard Drives just to be sure and am having him run the HD from the front USB slots for now to see if the problem persists.
If anybody knows or is familiar with this and may have a suggestion i would greatly appreciate the input. :D  thanks
Edit:I should also mention that the Hard drive is powered by a plug in transformer(I don't use ex-hds that much but I understand some run purely off USB power?) so this may eliminate the power option of shutting the usb ports down. Plus he uses his computer quite regularly and the HD updates everytime his mirrored HD saves anything. So I don't think it's due to idling. Hopefully It's not a problem with the USB ports themselves, really don't want to take this thing apart. Thanks again

More about : iomega external vansihing computer

a b G Storage
March 14, 2012 12:29:52 AM

Try to assign another letter in Disk Management for that drive. That worked for me in a couple of similar instances.
m
0
l
March 14, 2012 12:46:17 AM

Ok thank you I will do that. When you had a similar instance did your disk start going in and out eventually and this fixed it? Or did yours start happening right away? Because there haven't been any problems on this computer for almost 2 years with it. Thanks again
m
0
l
Related resources
a b G Storage
March 14, 2012 11:14:40 AM

I had this problem with a drive at work. The PC was connected to some network HDDs, so it would re-assign drive letters according to how many drives were online at that time. I just assigned a remote letter to this one and it worked out pretty good. Hope it helps. In your case, it could be an HDD that is failing, causing it to lose the letter "assignment".
m
0
l
March 15, 2012 12:51:14 AM

Thanks a bunch. I'm going to try changing the drive letter and see if that helps. I am kinda hoping if that doesn't work the HD is just failing so i don't have to go in and replace components on an almost new computer. Thanks a bunch. I'll keep you posted
m
0
l
!