Sign in with
Sign up | Sign in
Your question

Help with i5 3570K

Last response: in Overclocking
Share
December 21, 2012 7:54:23 AM

Hello,

I recently re-installed my OS and updated my BIOS losing my OC settings, i did have it set at 4.2GHz.
Now I've been trying to get it back to that but for some reason it doesn't stick... In my BIOS my CPU Ratio is set to 42 but when i stress test using Prime CPU-Z and HWiNFO only show's that i reach 3.4GHz max (Stock speed for the CPU).

CPU-Z does mention that my CPU Turbo is a multiplier of 42 and i'm unable to disable Intel Turbo Boost Tech in my BIOS

Any idea on this?

My specs:

AsRock Z77 Extreme6
Intel i5 3570K
CoolerMaster 1000W

More about : 3570k

a c 218 à CPUs
a c 105 K Overclocking
December 21, 2012 7:58:07 AM

Try clearing CMOS and trying again.
December 21, 2012 8:15:15 AM

Just tried clearing CMOS didn't work.
Not sure what's up.
Related resources
a c 218 à CPUs
a c 105 K Overclocking
December 21, 2012 8:18:15 AM

Did you reinstall all the latest chipset and motherboard drivers from the ASRock website?
December 21, 2012 9:33:54 AM

Yup all drivers and chipsets are upto date.
I dont know if this would make a difference but i've recently RA'd my gfx card so its currently running on the intel graphics until a new card is sent out.

here is a screenshot of HWiNFO, in the BIOS it tells me that the CPU speed is 4.2GHz but here it says otherwise...

a c 218 à CPUs
a c 105 K Overclocking
December 21, 2012 4:27:07 PM

You are overclocking by increasing the chip multiplier right and not just the Turbo multiplier? You can do it both ways. That's what it looks like anyway. The only other thing I notice is your RAM is at DDR3 1333. You need to enable XMP to run at it's rated DDR3 1600. Should not have anything to do with the CPU clockspeed though.
December 21, 2012 8:12:15 PM

I dont have turbo enabled apart from Intel Turbo Boost Tech but i cannot change this setting while not on CPU Ratio Auto....

heres a screenshot of my BIOS



the above is without any OC just stock BIOS settings.
To OC i just change CPU Ratio to All Cores and change the multiplier to 42 then adjust voltage.
a c 218 à CPUs
a c 105 K Overclocking
December 21, 2012 8:49:58 PM

Try CPU-Z and HWMonitor and see what they report your CPU speed to be.

Get both here.

http://www.cpuid.com/

When BIOS and Windows report different things that sounds like a driver to me.
December 22, 2012 12:33:11 AM

Heres a screenshot of both CPU-Z and HWmoniter still getting the same information.
It does mention that my turbo boost is 4.2GHz but i cant find anywhere in my BIOS where to turn turbo off, as i said when i change the CPU Ratio the setting"Intel Turbo Boost Tech" is untouchable.



below is a snippit from CPU-Z report.

Processors Information
Processor 1 ID = 0
Number of cores 4 (max 8)
Number of threads 4 (max 16)
Name Intel Core i5 3570K
Codename Ivy Bridge
Specification Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz
Package (platform ID) Socket 1155 LGA (0x1)
CPUID 6.A.9
Extended CPUID 6.3A
Core Stepping E1
Technology 22 nm
TDP Limit 77 Watts
Core Speed 3400.0 MHz
Multiplier x FSB 34.0 x 100.0 MHz
Stock frequency 3400 MHz
Instructions sets MMX, SSE, SSE2, SSE3, SSSE3, SSE4.1, SSE4.2, EM64T, VT-x, AES, AVX
L1 Data cache 4 x 32 KBytes, 8-way set associative, 64-byte line size
L1 Instruction cache 4 x 32 KBytes, 8-way set associative, 64-byte line size
L2 cache 4 x 256 KBytes, 8-way set associative, 64-byte line size
L3 cache 6 MBytes, 12-way set associative, 64-byte line size
FID/VID Control yes


Turbo Mode supported, enabled
Max non-turbo ratio 34x
Max turbo ratio 42x
Max efficiency ratio 16x

Min Power 60 Watts
O/C bins unlimited
Ratio 1 core 42x
Ratio 2 cores 42x
Ratio 3 cores 42x
Ratio 4 cores 42x
TSC 3400.1 MHz
APERF 3400.2 MHz
MPERF 3400.0 MHz
a c 218 à CPUs
a c 105 K Overclocking
December 22, 2012 12:43:13 AM

You can't turn Turbo off before upping the multiplier? Turbo should be disabled before overclocking.

You can tell BIOS to Load Failsafe Defaults or whatever ASRock calls it and try starting over. Just make sure your SATA ports are set correctly before rebooting into Windows.
December 22, 2012 1:47:46 PM

Im having the same issue with extreme4-m bios 1.40 windows 8...it was ok with windows 7....multiplier locked to 38...when i try to change it,it just keeps returning to 38...tried keyboard + and - but still max 38
December 22, 2012 10:07:14 PM

yer not sure anymore, reset to stock, updated BIOS and all drivers/chipsets i think AsRock may have made it turbo on all the time not sure, HWiNFO tells me that 4.2GHz is the turbo speed, but try as i might i cannot disable turbo while changing the CPU Ratio manually.
a b à CPUs
a b K Overclocking
December 23, 2012 6:14:09 AM

Dude you have max non turbo ratio lower than max turbo ratio.. As someone else said - if you have having trouble with turbo disable it completely.

I do not have that type of mobo bios to play with, but it appears to me you are entirely the wrong section trying to overclock turbo etc....
!