Solved

Failing to install CCC and display driver? Help please!

I have a single Sapphire 4890 Toxic and today I was trying to update from Catalyst 10.1 to 10.2. Previously, I would just uninstall from the control panel, reboot, and install the new drivers. However, I was curious about using Driversweeper and I followed the instructions by uninstalling 10.1 from the control panel, rebooting, using Driversweeper, rebooting, but as I went to install the 10.2 version, the Catalyst installer would only list out several files and excluded CCC and the display driver. I've tried to uninstall any ATI software/files and have tried installing Catalyst 9.7-10.1 over again and each time, the installer would not install CCC nor the display driver. I've also tried using System Restore to revert to a few days ago, but still no luck. I'm guessing my problem has something to do with Driversweeper, but when I try to restore my previous files/registries, Driversweeper wouldn't show up anything in the restore section. I've been looking at many threads and I can't seem to find a solution. Help please!

I currently use Windows 7 Professional 64-bit and I keep just about everything updated. This is with a Phenom II x4 955(C2) on a MSI 790FX-GD70 mobo.
11 answers Last reply Best Answer
More about failing install display driver please
  1. Looks like I was able to restore some files and now I've got Windows Aero to work and I can play games now, though when using the Catalyst installer, I'm still missing the display driver, CCC, and other components such as Avivo and Drag and Drop transcoding. I have confirmed that those files have been extracted, but not installed.
  2. This is a problem with ATI's new software and Windows 7 (I've had the same problem).

    You can try to manually install the files from the directory that is created when the files are decompressed or do what I did and just use the 10.1 hotfix and submit a ticket to ATI.

    They should be releasing a working version soon.
  3. I STILL have to use the command line to install my drivers; can't ATI even get a working installer?
  4. gamerk316 said:
    I STILL have to use the command line to install my drivers; can't ATI even get a working installer?


    I haven't used ATI in a while (Untill recently...before using my current 5870 CF rig, I had an X1900 rig back in the day)
    , so I'm not sure when they implemented the new install/software manager, but it seems that is the problem. Gamerk316's workaround is worth a shot.

    I've heard a few people suggest using these workarounds:

    Uninstall your C++ library and either update it to the latest version or let CCC install it's specific library

    Install using the command line functions:

    Locate the latest extracted files (C:\ATI\Support\[Version]\Bin [Or Bin64 if you are on x64 OS) and make a note of the folder.
    Navigate to that folder in a command prompt window (in the run box, type cmd.exe)
    Type the following (without quotes):"atisetup.exe -Install -Output screen"
    OR
    Navigate into the latest bin folder and create a shortcut to atisetup.exe
    Then select the properties of that shortcut and add -Install -Outputscreen
    onto the installer path:
    Example -> "C:\ATI\Support\xxxx\Bin\atisetup.exe" -Install -Output screen


    Hope this helps.
  5. Thanks for all the replies, I'll try them out.

    My problem is, before trying out driversweeper, I could uninstall and install any ATI driver versions I wanted, but now that I have used driversweeper, most of the files included in the installer do not show up so they aren't installed, despite using the 9.x drivers or any of the 10.x drivers. I think it does have something to do driversweeper deleting certain registry files/system files, but I can't find out what.
  6. Well let me know how it goes.

    Also, did you run driver sweeper in safe mode?
  7. I tried the -Install -Outputscreen command, but there wasn't any difference.

    I actually didn't do it during safe mode, so that might be why I'm having this problem. I'm considering just reinstalling my OS, if I continue to have this problem.
  8. Best answer
    First try running it in safe mode.
    Check the device manager and make sure it's removed from there after running driversweeper in safe mode.
  9. Tried it in safe mode and it did delete everything and it was removed from device manager. Tried to install 9.7/9.9/9.12/10.1/10.2 and each one did not show CCC nor the display drivers. I'll do an OS reinstall and that should fix things. Thanks for your help cscott_it, I'll be back tonight with the results.
  10. Oops I never updated this thread, OS reinstall worked and I'm finally able to install any driver versions I want.

    For anyone reading, don't use Driversweeper unless you're having problems with conflicting drivers from ATI and Nvidia, since Driversweeper deletes a certain file or registry file that doesn't allow you to reinstall an ATI driver/CCC,
  11. Best answer selected by kokin.
Ask a new question

Read More

Radeon Control Panel Catalyst Graphics Displays