My pc dosen't boot and i can't see nothing on my monitor

Hello, i got a new pc and installed it myself.Motherboard Asrock880G, CPU Phenom II X6 the problem is that when i try to start it everything seems to work fine but i can't see nothing on my monitor...also dunno about the ATX12v thing but i have it on my motherboard do i have to plug in a 4 pin power conecter or it's just something extra thanks...sorry 4 the stupid questions
6 answers Last reply
More about dosen boot monitor
  1. p.s i don't hear any beep even tough i pluged the pin for the speaker...
  2. Quote:
    dunno about the ATX12v thing but i have it on my motherboard do i have to plug in a 4 pin power conecter


    it should be connected
    would be a lot easyer to help if you gave more info like vid card
    PSU

    if all power connections to the mainboard are connected (24 pin + 4 or 8 pin connectors) it should give beep codes
  3. wiro67 said:
    Quote:
    dunno about the ATX12v thing but i have it on my motherboard do i have to plug in a 4 pin power conecter


    it should be connected
    would be a lot easyer to help if you gave more info like vid card
    PSU

    if all power connections to the mainboard are connected (24 pin + 4 or 8 pin connectors) it should give beep codes


    well i have a hd5770 but i have also onboard video so i tought maybe first i have to disable the onboard but since i cant start the pc....about the atx12v i don't have a 4 pin power connecter....only with 6 ...
  4. wow i'm so stupid i pluged a 8 pin on a 4 ....and it works ....had this many probs because i didn't work with newer pc's for a while thx a lot u can close the thread now
  5. Look for the plug on the top left of the board, close to the CPU. You need to connect power to there as well. Its an 8 pin connector in your case.
  6. :D nice to see you figured it out :D have fun with the new build :D
Ask a new question

Read More

Chipsets Boot Monitors Motherboards