Sign in with
Sign up | Sign in
Your question

How To Install Win7 on new SSD and then format other SSD

Last response: in Storage
Share
March 17, 2012 1:15:13 PM

Hi

I have recently installed a 128gb SSD and would like to use that as the main drive for the OS and other programs. At the moment I have the OS and other programs on a 64gb SSD.

What is the easiest / best way of installing the OS on the new drive? I have tried just putting the OS disk in the CD drive and installing but it will not let me choose the new SSD (I have named this A drive).

I also have two external drives attached which I will use for storage of photos etc.

I don't know much about BIOS so if it involves changing something in it pls give very simple instructions!

Thanks.
a c 324 G Storage
March 17, 2012 1:25:48 PM

Unhook the old SSD and all external drives and internal HDDs, attach the new one, set bios to AHCI SATA mode then do your windows install -- it will become the C drive. Then attach the old SSD and reformat, then attach everything else.
March 17, 2012 1:40:24 PM

How do I set the BIOS to ACHI SATA? Will I need to do this for both SSD's?
Related resources
a c 324 G Storage
March 17, 2012 1:52:10 PM

No, you simply go into the computer bios at startup and somewhere like the advanced settings section (refer to your motherboard manual) set the SATA mode to AHCI just prior to the new install -- do not do it before then or you will get a BSOD. It is very simple to do, you just need to consult your manual. The usual choices are IDE, AHCI RAID. You want AHCI as it enables some advanced settings to improve SSD performance.
March 17, 2012 2:21:04 PM

I should've waited for your reply! I managed to get into the BIOS and have changed it already so now get BSOD - help - pls!!
March 17, 2012 2:40:23 PM

RealBeast said:

No, you simply go into the computer bios at startup and somewhere like the advanced settings section (refer to your motherboard manual) set the SATA mode to AHCI just prior to the new install -- do not do it before then or you will get a BSOD. It is very simple to do, you just need to consult your manual. The usual choices are IDE, AHCI RAID. You want AHCI as it enables some advanced settings to improve SSD performance.


Well my UEFI/BIOS is already set to ACHI with one HDD. I am going to install an SSD in a hour. I thought I would just disconnect the HDD -- after removing Linux dual boot -- attach SSD and then check UEFI and install win7. Would I get the BSOD?

Isn't there one place on Tom's that has this as a procedure?
a c 324 G Storage
March 17, 2012 3:32:40 PM

JJ2012 said:
I should've waited for your reply! I managed to get into the BIOS and have changed it already so now get BSOD - help - pls!!

Not a problem, just go into the bios and change it back to IDE until you are ready to install the OS on the new SSD.
a c 324 G Storage
March 17, 2012 3:38:14 PM

eXistenZ said:
Well my UEFI/BIOS is already set to ACHI with one HDD. I am going to install an SSD in a hour. I thought I would just disconnect the HDD -- after removing Linux dual boot -- attach SSD and then check UEFI and install win7. Would I get the BSOD?

Isn't there one place on Tom's that has this as a procedure?

Right, just disconnect the HDD and install Windows 7. You will not get a BSOD. AHCI is the default settings on the newer motherboards.

I don't know of a specific thread stickied for this, but that isn't a bad idea. There are a number of good articles and how-to's here though: http://www.tomshardware.com/forum/270102-32-useful-arti...
a c 353 G Storage
March 17, 2012 3:43:18 PM

If the system was properly set up, about a 20 Minute simple task;
1) create an Image of your 64 Gig ssd
.. Go to control panel, select backup and create an image of your "c"drive. this will place the image on your HDD. If you have your Windows installation disk you do not need to create the "Bootable repair disk" that it prompts you for when the image is completed.
2) Remove your SSD and install your new SSD
3) Insert windows installation disk, select repair, then repare using image.
4) When completed and you boot into windows. go to disk management and expand your "c" drive to the new larger size.
5) Reconnect your old SSD to a available sata port. Select disk management and delete the partitions and repartition and formate.
6) Walla 20 or 30 Mins later your done. No reinstall, no reload drivers, no reinstall programs.

Problem:
If your orignal instal to the 64 gig SSD was improper, IE the Bios was not set to AHCI, but was set to IDE then you MUST first correct. Not to dificualt (will post a link). First then repeat above procedure.

Steps to fix (go from IDE -> ahci)
You start with step 1 Bios should be in IDE boot to in windows.
1) Run the Registry Editor (regedit.exe)
2) Navigate to Registry Key: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci
3) Set the "Start" value to 0 (zero)
4) Navigate to Registry Key: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Pciide
5) Set the "Start" value to 0 (zero)
6) Shut down
7) Start up again, but before Windows boots go into the BIOS configuration screens and change the disk mode to "AHCI". Save the new BIOS configuration and restart so that Windows boots.

When Windows starts, it will detect the change, load new disk drivers, and do one more reboot to start up with them

Worst case: as the old saying goes, sorry charily, but the milk an't sweet - You will need to re-install. Using the proper sequence.
A) Verify/set bios to ahci
B) Only the New SSD connected
C) Install windows, all drivers and all programs
D) Verify all AOK
E) reconnect other drives.
March 17, 2012 4:12:52 PM

I can't seem to be able to.

What I've tried:

Re starting computer and pressing f8 to get to the Advanced Boot Options trying every option on this screen.

When I chose the safe mode I get to a page called Windows Error Recovery if i choose repair mode it goes through startup repair is checking your system for problems then I get Windows cannot repair this computer automatically when I look at the problem details I see the following

Problem Event Name Startuprepairoffline
Problem signature 01: 6.1.7600.16385
" " 02: 6.1.7600.16385
" " 03: unknown
" " 04: 21200231
" " 05: AutoFailover
" " 06: 7
" " 07: NoRootCause
OS Version: 6.1.7600.2.0.0.256.1
Locale ID: 1033



Diagnosis and repair details:

Session details:

System Disk = \Device\Harddisk 1
Windows directory = E\windows
Autochk Run = 0
Number of root causes = 1

I cannot get past this page and have to turn off the computer.
a c 324 G Storage
March 17, 2012 4:17:09 PM

Why not use the delete key to enter the bios? What is the model and brand of your computer?
a c 324 G Storage
March 17, 2012 4:22:56 PM

If it's a Dell hit F2, and I think F10 for an HP. F8 is not what you need.

How did you get in to make the change in the first place?
March 17, 2012 4:26:40 PM

Thank you - I feel such an idiot I forgot how I got to the Bios screen in the first place! Oh to be computer literate would be good. I will now try what you originally suggested and not skip ahead.

Thank You Thank You Thank you...........
!