Sign in with
Sign up | Sign in
Your question

Asus HD 5770, some questions...

Last response: in Graphics & Displays
Share
February 19, 2010 7:09:24 PM

Hello, I just got a new Asus HD 5770 and after installing the new catalyst, on catalyst control center it says I have a HD5700 series. Thats ok? I mean, I know it's a 5700 series, but shouldn't it display 5770?

Also, now every time I reboot Windows tells me there's new hardware to install, but there's none left... I guess it has to do with the HD audio, but don't know how to solve it.

Last, when I turn on my pc it gets way more time than before to start. It is not windows that takes long, but to really start up (do the first bip and show bios screen). This is normal? the guy at the shop told me it's due to the graphic bios that is bigger than the 8800 I had, so it's normal, but I find it odd..

Thanks a lot in advance :) 


More about : asus 5770 questions

a b Ĉ ASUS
February 19, 2010 7:26:17 PM

my 4850 causes a similar delay in time to POST, but is it really that significant? I know for me is about 3 seconds so it really doesnt matter, especially since my old machine was taking 3 minutes to boot to windows.

It lists it as a 5700 because the drivers for the 5770 and 5750 are identical so there is no need for them to differentiate the cards beyond that on their end. As long as GPU-Z lists it as having the right number of SPs dont worry about it.

If you download the full CCC install package it should install the audio driver during the main install which will solve your new hardware found issue.
February 19, 2010 7:34:59 PM

As far as the audio goes- make sure you get the WHOLE CCC download from ATI's website- not the drivers packaged with the card. Might solve your hardware install problem.
Related resources
February 19, 2010 7:59:54 PM

Thanks for answering so fast :) 

With my old 8800 it got bios post almost instantly and now takes almos a minute.

About GPU-Z and the right number of SPs, where can I see that?
February 20, 2010 8:16:56 AM

Thanks a lot hunter315!

I have downloaded it and everything seems ok :) )

Also I have downloaded and installed the "ATI HDMI Audio Driver" from the Catalyst site, but I still get the "new hardware found thing" at start up. I have tried downloading the microsoft driver but it says I already have a more recent service pack... any idea? :( 

Also, I have timed the star up and it takes a full minute to get to the first "bip" and bios post image. Is it normal??

Thanks a lot in advance :) 
a b Ĉ ASUS
February 20, 2010 12:51:20 PM

A full minute seems a bit long, especially since i can hit the windows login screen in a minute from a cold boot on mine, hop into your bios settings and see if 'quick boot' is enabled and set the time on the splash screen to the minimum, on mine its 10 seconds, that should reduce your post time a bit.

You can take a look in Device Manager and see if it will tell you what the new hardware without a driver is, otherwise im out of guesses on that one.
February 20, 2010 3:42:00 PM

Thanks a lot hunter315.

The funny thing is there's none hardware left to install on the device manager.. .:S

I tried letting windows search for the driver on windows update and says it's "Microsoft UAA Bus Driver for High Definition Audio", so i'm trying to see if there's something missing on my windows :S

Thanks a lot again

February 20, 2010 5:21:04 PM

Well, finally I solved the missing hardware problem :) )

I'll writte down how I did it just in case someone else need this info :) 

I couldn't install the microsoft driver becouse I already had SP3 installed (I have XP), but then the "new hardware install wizard" couldn't find the "hdaudbus.sys" driver at the "Windows\driver cache" folder. So I had a look at that folder and founded a cab called "sp3.cab". I could open it with winrar and TADA! there it was! "hdaudbus.sys"!! I just extrated it to "Windows\driver cache" and finish the wizard. Now it's all done! :) )

Thanks a lot for all the help and patience, specially to hunter315 :) 
!