Sign in with
Sign up | Sign in
Your question
Solved

OCZ SSD doesn't show up in boot devices in bios?

Last response: in Storage
Share
March 18, 2012 2:37:37 AM

Just bought my first SSD...

OCZ Agility 3, 120gb

Seems to work fine, but doesn't show up in the boot device section in the bios..and hence I can't choose it as a bootable drive...

It shows up everywhere else in bios and in windows...

I'm running a Asus P5BDeluxe, C2D cpu, Gigabyte 550 gtx something...

Raptor HDD as my current OS, 2 Seagates as storage...2gb of Team Xtreem Ram

OCZ 700 PSU...

I tried switching to AHCI, both in the registry and bios...not sure if the jmicron jumper has to be set to AHCI also, but I tried that and still the OCZ doesn't show up as a bootable device...both my optical drives do as well as the Raptor,

I initially installed win7 in IDE mode I guess? I haven't tried to install it yet after changing to AHCI, but I reformated the partition and will try in the morning. Not sure if that would trigger it to be picked up by the boot devices...

Thanks for the help.
a c 261 G Storage
March 18, 2012 3:43:36 AM

If it does not have the MBR on it it will not show up. When you reinstall the OS on it disconnect the other OS drive!
m
0
l
March 18, 2012 12:11:37 PM

ok I will try that,

meanwhile someone is suggesting a bios update but my mobo's last bios update, which is beta btw is from 2009...do you think this is wise?

my bios is quite stable, I don't think ssd's were even out in 2009...
m
0
l
Related resources
a c 353 G Storage
March 18, 2012 1:05:44 PM

Yes, SSDs were out in 2009.
The agility III when first came out had considerable problems, most have been solved with the latest firmware. I do not recommend the agility III, and yes I have two of them.

1) I highly recommend using the Latest firmware for your MB.
2)Also, if reinstalling the operating system I recommend that you do a secure erase prior to the reinstall - Check OCZs web forum for a bootable linux disk download. Can do a secure erase from windows (installed an a 2nd drive/or 2nd computer) using their toolbox.
3) Recommend using the Intel sata port, not the Jmicron port. And YES do the win 7 install with all other HDDs disconnected and the BIOS set to AHCI.
m
0
l
March 18, 2012 1:53:50 PM

Retired Chief...

I just switched my SATA slots, so the ocz is now in the 1st, my other OS drive in the 2nd and so forth...seems the issue is resolved but I have a few questions...

Now my OCZ is showing in boot devices but the other OS drive is not?

In regards to BIOS, all the BIOS updates are BETA, would you still recommend the update despite this fact? I have a very stable OC on this Bios, and I believe when I tried to higher, my OC failed so I dropped back down to a stable BIOS...

I mean, seems my SSD is working now well...I'm doing the updates now and it's booting fine...just my other OS is not found in the boot devices...

I'm not using the jmicron so that one doesn't have to be set in AHCI?

Should I also do a CMOS reset (pull out battery)?

Thanks!
m
0
l
a c 353 G Storage
March 18, 2012 2:42:33 PM

Did you do the Win 7 Install, with the Other HDDs disconnected?

When you first installed win 7 on the HDD, was the Bios set to AHci, if it was set to IDE and is now set to ahci that might be the reason it is not showing up.
If it was in ide, you can switch it to ahci - Look at the Link below. Before doing this you will need to disconnect SSD, return Bios to ide and boot to win 7 On the HDD.
http://www.google.com/#hl=en&sclient=psy-ab&q=switch+id...
When this is fixed, then reconnect SSD and hitting the Bootselect hot key should bring up SSD, HDD, and DVD drive.

On Bios, if everthing is fine, no need to down load a beta Firmware, nor do a clear Cmos.

Once done, Download AS SSD and run it. Look in upper left to insure that the driver is msahci. If Intel chipset down load the latest Intel RST matrix driver (believe it is upto 10.8). This should change the msahci driver to iaSTor. It will also show make/model and firmware version, and show if Partition is aligned correctly.

If you run the benchmark, don't be too disapointed as the Agillity III does not perform much better when on a sata III port.

Important - If setup OK and you are happy, DON'T forget to use win 7 back-up (in controll panel to image your SSD. Works great and save a lot of time re-installing win 7 to SSD. IE NO re-install, No reload drivers, no reload all programs. Just pop in win 7 installation disk and pick Repair, Repair from Image - and 10 Min later your windows 7 and ALL Drivers and All programs are restorewd to identical conf as when the image was made.
m
0
l
March 19, 2012 5:34:37 PM

Problem Solved: Here's what I did, with the help of you guys and another forum.

1) set registry to AHCI
2) change bios settings to AHCI
3) I have 6 SATA slots, 1,2,5,6 for Boot drives (red), 3,4 for optical (black)
4) Disconnect all other drives except SSD
5) Install OS etc...plug other drives back in their proper SATA mobo slots

Everything works fine except my second OS drive which I was using before doesn't show up in boot devices...seems my mobo only has one true HDD/SSD SATA slot...

This is not an issue because I can always enter post screen by pressing F8 to choose the drive I want to boot off of...

Thanks for the help.
m
0
l
March 19, 2012 5:35:14 PM

I did not update the BIOS, didn't feel it was a need especially since everything is running smoothly and my OC is stable on the BIOS I have...
m
0
l

Best solution

a c 353 G Storage
March 19, 2012 6:08:46 PM

Great, ENJOY
Share
March 26, 2012 12:29:11 AM

Best answer selected by pepi93.
m
0
l
!