Sign in with
Sign up | Sign in
Your question
Closed

I goofed up two 4 TB drives trying to mirror them. Help.

Last response: in Storage
Share
March 18, 2012 9:36:36 PM

Hi I bought two 4TB hard drives with the intention of mirroring them on a windows 7 Pro system.

The system recognized them as 4 TB when they were basic drives. I converted both to Dynamic Disks at the same time, and their size dropped to 1677.9 GB. I can't get the system to recognize them as larger hard drives.

Converting the drive back to a basic disk and using Extend Volume shows a total volume size of 3436332 MB (less than 4 TB) but a maximum available space of only 1718166 MB.

All other actions in disk management also show a maximum available space of 1718166 MB. Extend Volume is the only one that knows the hard drive is larger than 2 TB. Converting to MBR and then back to GPT did not help.

Is there any way to return the disks to 4 TB drives?

If I can get them back to 4 TB capacity, can I split the drives into 2 or 3 partitions, make them dynamic drives, mirror them, and still keep the 4 TB capacity?

I tried Googling this problem but I did not find any help.

I hope I am not the first lab rat running this maze.

Thank you for any help you can give.

More about : goofed drives mirror

March 18, 2012 9:58:56 PM

depending on your hardware some wont recognize HDD bigger then 2TB, i know my x3/gen3 has drivers just for 3TB+ hard drives.
March 18, 2012 10:06:02 PM

Ohmybad said:
depending on your hardware some wont recognize HDD bigger then 2TB, i know my x3/gen three has drivers just for 3TB+ hard drives.


Thank you for the reply, but the drives were originally recognized as 4 TB drives. The size was reported as over 3,700 GB (I did not write down the exact number - I was expecting to see it again)

Thanks
Jon
Related resources
March 18, 2012 10:19:16 PM

Oops, double post!
March 18, 2012 10:30:32 PM

NZSol said:
Try using GPT partitions.....
http://en.wikipedia.org/wiki/GUID_Partition_Table

MBR partition limit is just on 2TB


Hi Thanks for the suggestion.

The drives were originally GPT partitions, after converting to Dynamic Drives this was limited to 2 TB. So I changed the drives back to basic drives and converted them to MBR and then back to GPT to see if that would reset the size limit the Dynamic drive step introduced. It did not help.

Thank you for taking the time to reply.

Jon


a b G Storage
March 18, 2012 10:42:24 PM

what brand are the drives?
March 18, 2012 10:46:12 PM

Soda-88 said:
what brand are the drives?


Hitachi 5400rpm "Coolspin" $319 each :/ 

Best solution

a b G Storage
March 18, 2012 10:53:59 PM
Share

hmm, checked the hitachi support site but they don't seem to be having low level format tool and the freeware one i know about is limited to only 50MB/s so that'd take ages to spin

still, give this a try http://hddguru.com/software/HDD-LLF-Low-Level-Format-To...

just use the 'perform quick wipe' and try to reinitialize the drives as GPT again
March 18, 2012 11:11:57 PM

Soda-88 said:
hmm, checked the hitachi support site but they don't seem to be having low level format tool and the freeware one i know about is limited to only 50MB/s so that'd take ages to spin

still, give this a try http://hddguru.com/software/HDD-LLF-Low-Level-Format-To...

just use the 'perform quick wipe' and try to reinitialize the drives as GPT again


Thanks for the suggestion. The program recognizes the drive capacity:

"Full device capacity: 4,000,787,030,016 bytes"

The "perform quick wipe" option is quick. The disk management initialization still only sees the drive as a 1678 GB drive (my 2 TB drive has a capacity of 1862.89 GB - Odd)

I may try the 50 MB/second format or pay for the faster format time.

Thanks
Jon
a b G Storage
March 18, 2012 11:12:25 PM

You may need to investigate that your motherboard properly supports these drives.

There is another option:
There's a free version of a program called "Syncbackse" that I use. You can set it to scan Drive #1 every day then apply any changes to Drive #2.

The mirroring method has BOTH drives spinning at the same time and the Syncbackse method only spins up the second drive long enough to back things up (and shuts down after a certain time such as 30 Minutes of non-use as set in your Power Options.)
March 18, 2012 11:24:57 PM

photonboy said:
You may need to investigate that your motherboard properly supports these drives.

There is another option:
There's a free version of a program called "Syncbackse" that I use. You can set it to scan Drive #1 every day then apply any changes to Drive #2.

The mirroring method has BOTH drives spinning at the same time and the Syncbackse method only spins up the second drive long enough to back things up (and shuts down after a certain time such as 30 Minutes of non-use as set in your Power Options.)


Syncbackse sounds like a good option.

The motherboard is a Dell one from this time last year. I will check if it supports the drives. It recognized them and showed the correct size originally, so it should support them. (It will not support them as a boot drive, but I only want to use them as data drives).

Thanks for the suggestion.

Jon
March 19, 2012 1:16:10 AM

Soda-88 said:
hmm, checked the hitachi support site but they don't seem to be having low level format tool and the freeware one i know about is limited to only 50MB/s so that'd take ages to spin

still, give this a try http://hddguru.com/software/HDD-LLF-Low-Level-Format-To...

just use the 'perform quick wipe' and try to reinitialize the drives as GPT again


Thanks again
I found the problem after checking out Dell:

The 512e Advanced Format Hard Drive support was not installed.

http://support.dell.com/support/topics/topic.aspx/globa...

2. Determine if the Hard Disk Drive is Advanced Format or Not

Use Intel Rapid Storage Technology (RST) driver console to verify whether the drive is Advanced Format or not. The Intel Rapid Storage Technology driver must be revision 9.6.0.1014 or later and all the latest updates for the Windows Operating System must be installed from Windows Updates.
Click Start, Programs, Intel, then Intel Rapid Storage Technology.
Click the Manage icon.
Click Advanced and then click the desired drive.
If the physical sector size is 4096 bytes, it is a 4K hard drive.
If the physical sector size is 512 bytes, it is a regular hard drive.
If both the physical sector size and logical sector size are 4096 bytes, the drive is a native 4K drive.

I installed a sata update, and an Intel update, then did a low level quick wipe of both drives.
Then I could: create 4 TB basic drives, convert to 4 TB dynamic drives, and mirror them.

Weird that the drives were initially ok and the conversion to dynamic caused the problems. The intel rapid storage always indicated the drives true size but it still needed updating.


Thank you to everyone who took the time to help.
Jon
March 19, 2012 1:16:27 AM

Best answer selected by JonSAlberta.
a b G Storage
March 19, 2012 9:15:58 AM

This topic has been closed by Maziar
!