Sign in with
Sign up | Sign in
Your question

Intel i7 920 Problems - Need help!

Last response: in Motherboards
Share
October 24, 2010 9:04:06 PM

Hello all.

I've been having a very annoying problem with my current pc build, hopefully someone will be able to help me.

A few months ago, I've built up a system as below:
CPU: Intel i7 920
Motherboard: Gigabyte GA-EX58-UD3R
Memory: Corsair 3x2gb XMS3 1600 mhz
GPU: Sapphire Radeon HD 5770
PSU: Coolermaster RealPower 620w

Everything was working fine, until the day I installed Starcraft 2. It ran fine (on ultra) for the whole day. I shut the pc down and went to bed. The next day, it wouldn't turn on. The fans and lights turn on, but after a few seconds the system shuts down again. After a few more seconds, it would try rebooting but would also fail. It stays on this boot loop forever.

I've called the technician. He came over, re-seated all the parts, tested the PSU and, somehow, made the system boot again. At this stage, I flashed the BIOS to the latest version. After 2 or 3 days, the problem was back.

He then took it to his office, and again, made it work somehow. After it was back home, it stopped working again after a few days of normal use.

He came over once again, and this time he brought a different memory, as he suspected it was an incompatibility problem. We tested the new memory, and it didn't work at first, until we put my old RAMS back on, then the system decided to boot again. As expected, a few days later, it just went dead again. Always with the same symptoms:
It works great, and is shut down correctly. The next day it just wont boot.
I've RMAd the motherboard, and got an ASUS P6X58D-E instead of the Gigabyte one. I installed everything and the system was then able to boot. I immediately flashed the bios to the latest version and everything seemed to be working fine.
I could notice an overheating of the CPU. It reached temperatures of 55C idle and 90C while loaded. The system was functioning fine, but only for 2 days.
Now, after 2 days with the new motherboard, I get the same problem I had with Gigabyte. This time, the pc is not stuck in a boot loop, but stays on forever and never posts anything. I've tried pressing the MEMOK! button on the board, but it doesn't work.
I'm really out of options at the moment. I've tried a different Motherboard and different memories. Could it be a faulty CPU? Could the CPU have damaged the motherboard with it's high temperature?

Ps.: The system is NOT overclocked. Everything is running as per manufacture default.

More about : intel 920 problems

a b Ĉ ASUS
a c 435 V Motherboard
October 24, 2010 9:49:48 PM

Coolermaster isn't a great ps. I would use antec or corsair. But it may not be your problem. Heat may be your issue but it may be somewhere else in your system. I just upgraded my cooler. Frys has a big Dynatron K987 Intel cooler for $14.99 good for 775, 1156, and 1366 cpus. My cpu temps dropped about 5-6 degrees celcius after installing one. But again, I can't be sure this is your problem. Continue troubleshooting.
October 24, 2010 11:36:54 PM

I wouldnt say the PSU is the problem, if it was the computer wouldnt start properly or while gamming (stress) it would shut down, i might be the CPU, try RMA if you can.
I'm just guessing since i never had such problem.

Goodluck
!