Sign in with
Sign up | Sign in
Your question

Dell Insprion 9300 CPU won't run at max capable speed

Last response: in CPUs
Share
May 12, 2010 2:15:02 PM

I have a 4+ year old Dell Inspiron 9300 notebook running Windows XP Home Edition, as well as Slackware Linux in a dual boot configuration. I have SpeedStep enabled in the BIOS and in Linux the CPU speed would fluctuate depending on what I was doing. If I were to compile a program the CPU speed would go from 800MHz to 1.86GHz and then slowly climb back down once the compiling was done. This is how it should behave, but it no longer does! Now when I compile a program it stays at 800MHz, however the fan will kick up as if the CPU was getting excited. Booting into Windows used to also kick up the fan, which told me the CPU was revving up as well, but now it does not do that either. Running the RightMark CPU Clock Utility (RMClock) under Windows I'm told the speed is around 800MHz, as well as the utilities in Linux. Weird thing is the info under System Properties General Tab tell me it's running at 1.86GHz... BIOS tells me the min is 800MHz and max is 1.86GHz and once in a while it will actually say the speed is at 1.86GHz, but then it drops to 800MHz. I guess that latter part is usual since there's nothing CPU intensive while in the BIOS... anyone have any suggestions?
a b à CPUs
May 12, 2010 3:06:31 PM

Have you ever taken a can of compressed air and blown it out ?
m
0
l
May 12, 2010 3:10:03 PM

Actually I have! With some free time yesterday I used the service manual and opened up the notebook to give it a better cleaning, which to my surprise was not that dirty. After doing so, still no go on the max speed.
m
0
l
Related resources
a b à CPUs
May 12, 2010 3:14:52 PM

Thermal throttling was all I had to go on, sorry.

Have you tried disabling "C1E" using RMClock, this should force the cpu to run at full speed constantly.
m
0
l
May 12, 2010 3:50:37 PM

Due to my limited knowledge of the inner workings of a CPU, I have not wandered around much into the settings available in RMClock. Once I get home I will give this a try and report back. If I can't have SpeedStep working properly to give me the extra CPU when needed then I would rather have it constant at max speed.
m
0
l
May 13, 2010 3:07:29 AM

delluser1 said:
Thermal throttling was all I had to go on, sorry.

Have you tried disabling "C1E" using RMClock, this should force the cpu to run at full speed constantly.


*sigh* I'm look at the "Advanced CPU settings" in RMClock and to my dismay the C1E option is not choosable at all. In fact the whole section is not selectable, as it seems that is for Intel Core/Core 2 CPUs and mine is a Centrino. Any other suggestions to force?
m
0
l
a c 803 à CPUs
May 13, 2010 3:53:10 AM

what are your cpu temps? It could still be getting hot due to thermal paste needing to be re-applied.
m
0
l
May 17, 2010 4:29:24 AM

According to the apps used for monitoring the CPU, I'm roughly at 40 degrees when under stress. I've actually re-applied thermal paste to the CPU, but not to the heatsink... maybe I'll give that another shot.

I guess one final question in regards to this is, is this a problem with the CPU or a problem with the mainboard? If it's a CPU, I may be able to obtain one for cheap and replace.
m
0
l
a c 803 à CPUs
May 21, 2010 7:44:46 AM

40C under stress is nothing to worry about at all. That is pretty good actually.
m
0
l
April 5, 2011 12:56:04 AM

dimm0k said:
I have a 4+ year old Dell Inspiron 9300 notebook running Windows XP Home Edition, as well as Slackware Linux in a dual boot configuration. I have SpeedStep enabled in the BIOS and in Linux the CPU speed would fluctuate depending on what I was doing. If I were to compile a program the CPU speed would go from 800MHz to 1.86GHz and then slowly climb back down once the compiling was done. This is how it should behave, but it no longer does! Now when I compile a program it stays at 800MHz, however the fan will kick up as if the CPU was getting excited. Booting into Windows used to also kick up the fan, which told me the CPU was revving up as well, but now it does not do that either. Running the RightMark CPU Clock Utility (RMClock) under Windows I'm told the speed is around 800MHz, as well as the utilities in Linux. Weird thing is the info under System Properties General Tab tell me it's running at 1.86GHz... BIOS tells me the min is 800MHz and max is 1.86GHz and once in a while it will actually say the speed is at 1.86GHz, but then it drops to 800MHz. I guess that latter part is usual since there's nothing CPU intensive while in the BIOS... anyone have any suggestions?

All you have to do is download NHC and set the CPU max and it will immediately jump up to full speed.
m
0
l
!