Solved

Nas to Internal

I have a Western Digital Mybook World Edition ii NAS (2TB). I used it to store media between my 3 macs and win7 machines. It recently ran into some issues when my puppy decided to pee on said drive. The Urine damage the sata/ethernet controller inside rendering it useless. I deiced to take apart the enclosure to attempt to recover the data from my PC.

I installed the drive with some success, I can only see the Disk Management. It shows as Disk 1, Basic, 1863.02 GB and Online.
There are 4 partitions listed on the drive (1.87 GB Healthy, 251 MB Healthy, 965 MB Healthy, and 1859 GB Healthy) and 31 MB of Unallocated space. My only options for any of the partitions is to delete the volume or help. I'm at a loss as to what to do, I've tried booting to Ubuntu 11.10 to no avail.

I really need the data off of this drive as it has family pictures, any suggestions or ideas as to what I should do would be greatly appreciated.
7 answers Last reply Best Answer
More about internal
  1. Best answer
    Your HDD may format under Unix. or Linux - DO NOT FORMAT or write ANYTHING to it

    Download this utility

    http://sourceforge.net/projects/ext2fsd/files/Ext2fsd/

    Installed you may now able to read the File.

    BTW you should not care 251MB partition. You data maybe in 956M and 1859MB partition.

    Good luck
  2. Thank you.
    I did as you suggested and downloaded the program this is what I see when I run it.



    so where do I go from here? change the partition type of each partition to HPFS/NTFS?
  3. Mount the drive, then you can read it

    Last time i use this was 3yrs ago... very rusty
    Basically you need to mount a partition, i think under Tools then assign a drive letter??!
    Then read it - but you can always read the HELP menu
    That's it
  4. DO NOT DO ANY Write/convert to your drive

    YOU MAY LOOSE YOUR DATA

    READY ONLY
  5. No luck, When I mount the drive and then proceed to open it Windows tells me I need to format the drive before use. It then tells me that it does not contain a recognizable filesystem.

    Thanks again for trying, anyone have any other ideas?

    EDIT: I fooled around with it some more apparently you need to start the service manually, I was about to mount some of the partitions but not the 1.8 TB one

    EDIT2: Still no luck with mounting the drive
  6. Darn! I dont have any EXT3 format here.... :-(
  7. Best answer selected by P3ppy.
Ask a new question

Read More

NAS / RAID Storage