Sign in with
Sign up | Sign in
Your question

Gigabyte P55A-UD4P - Booting Ubuntu via USB Flash Drive

Last response: in Motherboards
Share
October 28, 2010 2:13:46 PM

I have a Gigabyte P55A-UD4P (F14 bios, which are the latest) and am trying to boot into ubuntu 10.04 on my Patriot PEF8GUSB thumb drive (which is supposedly bootable per reviewers who stated they run ubuntu off of the drive). I installed ubuntu on the drive via unetbootin, which, from my understanding, should allow me to run ubuntu off of my thumb drive (I'm doing this all so that I can secure erase my Vertex 2 3.5" SSD; unfortunately the people on the OCZ forums have not been able to help to this point, but I think my issue is specific to the motherboard so I am posting here). The bios recognizes the drive as an option in the boot options when I F12 to select the boot drive as well as in the bios boot priority settings.

After I choose the thumb drive as the boot device, the system says Loading Operating System ... and then there is a blinking cursor. It just sits there and does nothing (as far as I can tell; and I have waited for 30 minutes for something to happen). The activity light on my usb drive blinks rapidly in a uniform manner (not like random read/writes, but consistent blinking) but nothing comes up. Supposedly a unetbootin screen should come up and I am supposed to choose "Default". Then it should boot into ubuntu on the thumb drive. This never happens.

I am wondering if there is some bios setting I need to set to enable booting from usb. Obviously the bios recognizes the drive so that is not the issue, but something else is going on. I make sure to disconnect all of my drives and only have the usb drive attached when trying to boot into ubuntu. I have played with turning off USB3.0 options but that has not made a difference.

One poster mentioned that a raid setup could prohibit booting from usb. Although my normal win7 configuration boots off of a Raid 0 array built off of the motherboard, I have those drives disconnected when I try to use the usb drive to boot into ubuntu and no raid configuration is visible in the bios at that time.

Also, I have played with setting SATA to IDE and AHCI to no avail.

I have also completely reset the CMOS and tried to boot to ubuntu directly after reset (as suggested on the ocz forums) but received the same result (i.e. stuck at Loading Operation System screen).

Any thoughts on getting this to work would be greatly appreciated. I have been trying to solve this issue for almost two straight days. I guess that's what we have to deal with to get the best performance out of leading edge technology.

Thanks!
!