Sign in with
Sign up | Sign in
Your question
Solved

Z77 Sabertooth Overclocking HELP!!

Last response: in Overclocking
Share
January 2, 2013 8:14:11 PM

Quick Question,

I am trying to overclock my Intel i5-3570k on my Asus Sabertooth Z77 board. Now EVERYONE says launch the Asus TurboEVO and just set the clock in there, but the problem is that the Sabertooth as the Thermal Radar program and NOT the standard TurboEVO that I am used too and you can SET it but it doesnt save anything and every time I launch the computer it is still stock, SO I went into the BIOS and tried to change the BLK Frequency but every time I do that from 100 to 110 or even 101 it fails, any ideas?
a c 197 à CPUs
a b K Overclocking
a c 118 Ĉ ASUS
January 2, 2013 9:22:58 PM

chopperg said:
Quick Question,

I am trying to overclock my Intel i5-3570k on my Asus Sabertooth Z77 board. Now EVERYONE says launch the Asus TurboEVO and just set the clock in there, but the problem is that the Sabertooth as the Thermal Radar program and NOT the standard TurboEVO that I am used too and you can SET it but it doesnt save anything and every time I launch the computer it is still stock, SO I went into the BIOS and tried to change the BLK Frequency but every time I do that from 100 to 110 or even 101 it fails, any ideas?

make sure your running the newest bios 1708 for the board. in the bios dont set the asus mode to turbo set it to standard then go to the over clock settings and set them to man. if there set to auto on reboot the mb going to set your over clock back.
also the over clock software for our boards is the ASUS AI Suite II that on asus web page under our mb for downloads.
m
0
l
a b à CPUs
a b K Overclocking
January 2, 2013 9:45:06 PM

It's failing because you are trying to overclock with BCLK especially since your setting it so high right off the bat and not in steps. Since you have a K processor you need to overclock via the CPU multiplier or Turbo boost multiplier not BCLK. I also wouldn't recommend overclocking via the software, you are better off overclocking through the BIOS directly.
m
0
l
Related resources
January 3, 2013 7:02:36 PM

Orlean said:
It's failing because you are trying to overclock with BCLK especially since your setting it so high right off the bat and not in steps. Since you have a K processor you need to overclock via the CPU multiplier or Turbo boost multiplier not BCLK. I also wouldn't recommend overclocking via the software, you are better off overclocking through the BIOS directly.


How do I go in the BIOS of the Sabertooth to CPU Multiplier? I do not see it in the Sabertooth BIOS, I know this is a popular board but I can not locate it ANYWHERE!
m
0
l
January 3, 2013 7:02:58 PM

Orlean said:
It's failing because you are trying to overclock with BCLK especially since your setting it so high right off the bat and not in steps. Since you have a K processor you need to overclock via the CPU multiplier or Turbo boost multiplier not BCLK. I also wouldn't recommend overclocking via the software, you are better off overclocking through the BIOS directly.


I see you have the Sabertooth, ANY Help you did to OC would be awesome!!
m
0
l
a b à CPUs
a b K Overclocking
January 3, 2013 11:28:29 PM

When you get into the BIOS you have to hit F7 for Advance mode (bottom towards the left of the screen) since by default it boots into EZ mode, this will open up all the overclocking options. Once there you will see the tab labeled AI Tweaker.

These are not my screenshots FYI
Where you see AI overclock Tuner you want to set this to manual or XMP ( depending if you have ram that supports XMP) after you set that you will see Turbo Ratio open up it will be labled AUTO so set it to manual and you get more options that open up. Leave ratio Synhronizing control on enable since you want all the cores to sync together. Where you see 1-core ratio Limit you change that to the overclock you want to run so lets say 4.2 ghz so you set it to 42 and hit enter and all the rest of them will change since you have it sync'd
I am overclocking via Turbo Ratio since I want my processor to downclock back to 1.6ghz when it's not being used.



Here are your voltage setting options, this is where you will have to play around with voltages in order to see what is stable for you since it varies from chip to chip. I personally run a negative offset voltage of .040, idle at .986v under full load I top out at 1.096v under Prime95.



You will want to download CPU-Z to monitor voltage and Prime95 to run stability tests.


Also here's a good simple Z77 Sabertooth overclocking/bios guide that explains what most of the settings are.

http://www.mediafire.com/?l34d6j6c4wqfx69
m
0
l
January 4, 2013 1:11:35 PM

Awesome!! Thanks. I think I had the wrong memory, I had the Corsair Dominator Memory and it would NOT run in this mode. Double checked ASUS Website and ordered the correct memory and going to try again. Ill post my outcome on Monday!! Thanks
m
0
l
January 8, 2013 12:25:17 AM

Orlean said:
When you get into the BIOS you have to hit F7 for Advance mode (bottom towards the left of the screen) since by default it boots into EZ mode, this will open up all the overclocking options. Once there you will see the tab labeled AI Tweaker.

These are not my screenshots FYI
Where you see AI overclock Tuner you want to set this to manual or XMP ( depending if you have ram that supports XMP) after you set that you will see Turbo Ratio open up it will be labled AUTO so set it to manual and you get more options that open up. Leave ratio Synhronizing control on enable since you want all the cores to sync together. Where you see 1-core ratio Limit you change that to the overclock you want to run so lets say 4.2 ghz so you set it to 42 and hit enter and all the rest of them will change since you have it sync'd
I am overclocking via Turbo Ratio since I want my processor to downclock back to 1.6ghz when it's not being used.
http://images.tweaktown.com/content/4/8/4878_21_asus_sabertooth_z77_intel_z77_motherboard_review.png


Here are your voltage setting options, this is where you will have to play around with voltages in order to see what is stable for you since it varies from chip to chip. I personally run a negative offset voltage of .040, idle at .986v under full load I top out at 1.096v under Prime95.
http://images.tweaktown.com/content/4/8/4878_22_asus_sabertooth_z77_intel_z77_motherboard_review.png


You will want to download CPU-Z to monitor voltage and Prime95 to run stability tests.


Also here's a good simple Z77 Sabertooth overclocking/bios guide that explains what most of the settings are.

http://www.mediafire.com/?l34d6j6c4wqfx69


Installed the NEW Memory in the PC, I booted up the BIOS and I set it to Manual, set it to Ratio Sync to Enabled and I can not change the 4 cores listed OFF of AUTO. It is ONLY listed as AUTO and I cant mess with it, I can change the BLK/PEG Frequency from 100 to 110 or something but I was told not to mess with that, any ideas??
m
0
l
January 8, 2013 12:37:06 AM

I can only Change my BLK PEG Freq, when I do change it, It changes my memory crazy high and crashes, I dont know if I am doing something wrong but this sabertooth board is different than the other Z77 out there.
m
0
l
a b à CPUs
a b K Overclocking
January 10, 2013 10:24:30 PM

Apologies for the late reply.


Interesting, are you setting the AI overclock tuner to manual then Turbo Ratio to manual as well ?
m
0
l
January 14, 2013 1:00:28 PM

I couldnt change the cores from AUTO. They were locked. I ran the OC Tuner. I clicked that and clicked OK and then I was able to change it from AUTO TO 38 or 40. Thanks!
m
0
l

Best solution

a b à CPUs
a b K Overclocking
January 15, 2013 12:32:07 AM

Although weird but I guess whatever works for you just make sure the OC tuner didn't automatically increase voltage to a alarming level and keep tabs on temperatures. . Anyway good luck with the overclocking!
Share
January 15, 2013 5:31:24 PM

Best answer selected by chopperg.
m
0
l
!