Sign in with
Sign up | Sign in
Your question

I/O Device Error Segate External Hard Drive

Last response: in Storage
Share
March 26, 2012 10:50:15 PM

Hi,

Ok so my 1tb external hard drive is going wrong. Today it was having problems playing a video from it and taking a long time to find files. I unplugged and plugged it back in. Both power and USB. I could still access files but same issue it was very slow. I tried copying the file to my desktop but it said it would take over 35 minutes. After waiting 5 or so minutes nothing changed and I cancelled it. I then reset my pc to see if that would solve it. I also tried switching USB ports. All of a sudden vlc player says it can't find the file. I try opening another file and it comes up with the I/O device error. Now I can't access my files. I can see all folders etc inside of it but can't access anything. It won't let me run a chkdsk because it saw its RAW. I can't do error checking de frags or anything. It's odd. I have access for about 15 seconds then it stops working. I'm running windows 7 ultimate 64 bit. I7 980x 16gb ram. It's a 1tb Segate external hard drive. Does anyone have any ideas that I could try to solve this?

Thanks

Luke
March 29, 2012 10:07:36 AM

UPDATE

Ok I have mounted the drive internally. I am able to use my files i.e. use Spotify/iTunes and watch films etc open documents. However if I try and copy them to another hard drive then it fails and goes back to I/O error. Im going to make due and try and save important files. Then im going to buy a WD hard drive. Hopefully the prices start dropping soon. Will post again if any more updates happen.
!