Sign in with
Sign up | Sign in
Your question

Ncs cpu wont even load bios

Last response: in CPUs
Share
May 16, 2010 1:30:22 PM

Hello all,
I have an ncs tower pc that worked the last time i powered it up but its been boxed up for a couple of years. now i connected it to a dif monitor and tried to start it and i got beep codes and no boot. i read that it wast prob the monitor so i got the old one and sure enough the beeping stopped, but the comp wont even load to bios. the monitor comes out of sleep when it powers on, but it doesnt display anything. the monitor works fine connected to my laptop. a few things ive tried: replaced the bios battery with one i know works, tried a hard drive from another junker (but one that works) removed the modem card, tried loading "ultimate boot disk", ive taken out the ram and put it back. this was a comp built by a company for home schooling. its an NCS tower, the motherboard says asus psrd2-vm. it has built in video, a pentium processor (sorry, dont know what kind but i remember it being at least 2ghz). thank you to anybody that reads this and all who can offer advice.

More about : ncs cpu wont load bios

a c 141 à CPUs
a b C Monitor
May 23, 2010 10:47:45 PM

Try removing and reinstalling all the cards, cpu, & ram. Often I find they. esp the gpu, just needs to be reseated a few times to clean up the connectors.
m
0
l
!