Sign in with
Sign up | Sign in
Your question

Why does Toshiba screen go blank?

Last response: in Laptops & Notebooks
Share
Anonymous
a b D Laptop
August 27, 2004 2:43:09 PM

Archived from groups: comp.sys.laptops (More info?)

I put Slackware 9.1 with KDE 3.1 on wife's new Toshiba A45 laptop. Works fine
except for one annoying thing. When she is playing a game where there is no
keyboard interaction (like Solitare), every 10-15 minutes the screen goes
black. You hit any key and it comes back up and all is OK. I think it has
something to do with the fact that the machine has not 'heard' a keystroke in
a while.

I do NOT have APM or ACPI loaded, nor does KDE have any of the power saving
'features' enabled. Also, there is no screen-saver set.

I tried xset -dpms but that did not work.

Anyone have any idea of what the hardware is doing? I don't think it is a
Linux thing... but I could be wrong.

Thanks,

Al

More about : toshiba screen blank

Anonymous
a b D Laptop
August 27, 2004 4:08:13 PM

Archived from groups: comp.sys.laptops (More info?)

"Al C." <no.spam.acanton@adams-blake.no.spam.com> wrote in message
news:10iusldq3fpakf8@news20.forteinc.com...
>I put Slackware 9.1 with KDE 3.1 on wife's new Toshiba A45 laptop.
>Works fine
> except for one annoying thing. When she is playing a game where there
> is no
> keyboard interaction (like Solitare), every 10-15 minutes the screen
> goes
> black. You hit any key and it comes back up and all is OK. I think it
> has
> something to do with the fact that the machine has not 'heard' a
> keystroke in
> a while.
>
> I do NOT have APM or ACPI loaded, nor does KDE have any of the power
> saving
> 'features' enabled. Also, there is no screen-saver set.
>
> I tried xset -dpms but that did not work.
>
> Anyone have any idea of what the hardware is doing? I don't think it
> is a
> Linux thing... but I could be wrong.
>
> Thanks,
>
> Al
>
>

This is going to be a Slackware/KDE issue. Probably taking it to a
Slackware/Linux forum will offer better assistance. Linux is perfect
according to the experts, so harden yourself to the inevitable onslaught
for daring to ask the question before spending a year with man.

Q
Anonymous
a b D Laptop
August 27, 2004 7:44:03 PM

Archived from groups: comp.sys.laptops (More info?)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi Al,

Some laptops have power saving options in the BIOS.

Ciao . . . C.Joseph

That which a man buys too cheaply . . .
~ He esteems too lightly

Al C. wrote:
| I put Slackware 9.1 with KDE 3.1 on wife's new Toshiba A45 laptop. Works fine
| except for one annoying thing. When she is playing a game where there is no
| keyboard interaction (like Solitare), every 10-15 minutes the screen goes
| black. You hit any key and it comes back up and all is OK. I think it has
| something to do with the fact that the machine has not 'heard' a keystroke in
| a while.
|
| I do NOT have APM or ACPI loaded, nor does KDE have any of the power saving
| 'features' enabled. Also, there is no screen-saver set.
|
| I tried xset -dpms but that did not work.
|
| Anyone have any idea of what the hardware is doing? I don't think it is a
| Linux thing... but I could be wrong.
|
| Thanks,
|
| Al
|
|
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.2 (MingW32)

iD8DBQFBL48D6bFq6mlbLOwRAqPsAJ9YyhO3sKf/swppJ6LOmg/IMAW9KACfTKv9
LKw8vTckSODKTagPAGZaBL0=
=iHR3
-----END PGP SIGNATURE-----
Related resources
Anonymous
a b D Laptop
August 28, 2004 12:51:20 AM

Archived from groups: comp.sys.laptops (More info?)

There are two possibilities, the first is that a screen saver is
activating, the second (more likely) is that power managment is turning
the screen off. What you describe is normal default behavior. To set
the screen saver, right-click on a blank area of the desktop, then
"Properties". Power management is controlled from within "Control
Panel", and I think for that model, there will be a "Toshiba power
management" icon.


Al C. wrote:

> I put Slackware 9.1 with KDE 3.1 on wife's new Toshiba A45 laptop. Works fine
> except for one annoying thing. When she is playing a game where there is no
> keyboard interaction (like Solitare), every 10-15 minutes the screen goes
> black. You hit any key and it comes back up and all is OK. I think it has
> something to do with the fact that the machine has not 'heard' a keystroke in
> a while.
>
> I do NOT have APM or ACPI loaded, nor does KDE have any of the power saving
> 'features' enabled. Also, there is no screen-saver set.
>
> I tried xset -dpms but that did not work.
>
> Anyone have any idea of what the hardware is doing? I don't think it is a
> Linux thing... but I could be wrong.
>
> Thanks,
>
> Al
>
>
Anonymous
a b D Laptop
August 28, 2004 12:51:21 AM

Archived from groups: comp.sys.laptops (More info?)

"Barry Watzman" <WatzmanNOSPAM@neo.rr.com> wrote in message
news:412FA0D2.4030307@neo.rr.com...
> There are two possibilities, the first is that a screen saver is
> activating, the second (more likely) is that power managment is
> turning the screen off. What you describe is normal default behavior.
> To set the screen saver, right-click on a blank area of the desktop,
> then "Properties". Power management is controlled from within
> "Control Panel", and I think for that model, there will be a "Toshiba
> power management" icon.
>
>
> Al C. wrote:
>
>> I put Slackware 9.1 with KDE 3.1 on wife's new Toshiba A45 laptop.
>> Works fine
>> except for one annoying thing. When she is playing a game where there
>> is no
>> keyboard interaction (like Solitare), every 10-15 minutes the screen
>> goes
>> black. You hit any key and it comes back up and all is OK. I think it
>> has
>> something to do with the fact that the machine has not 'heard' a
>> keystroke in
>> a while. I do NOT have APM or ACPI loaded, nor does KDE have any of
>> the power saving
>> 'features' enabled. Also, there is no screen-saver set.
>>
>> I tried xset -dpms but that did not work.
>>
>> Anyone have any idea of what the hardware is doing? I don't think it
>> is a
>> Linux thing... but I could be wrong.
>>
>> Thanks,
>>
>> Al
>>

Linux, L-I-N-U-X, not Windows.

Q
August 28, 2004 10:43:34 AM

Archived from groups: comp.sys.laptops (More info?)

Al C. wrote:

> I put Slackware 9.1 with KDE 3.1 on wife's new Toshiba A45 laptop. Works fine
> except for one annoying thing. When she is playing a game where there is no
> keyboard interaction (like Solitare), every 10-15 minutes the screen goes
> black. You hit any key and it comes back up and all is OK. I think it has
> something to do with the fact that the machine has not 'heard' a keystroke in
> a while.
>
> I do NOT have APM or ACPI loaded, nor does KDE have any of the power saving
> 'features' enabled. Also, there is no screen-saver set.
>
> I tried xset -dpms but that did not work.
>
> Anyone have any idea of what the hardware is doing? I don't think it is a
> Linux thing... but I could be wrong.
>
> Thanks,
>
> Al
>
>
I think my Sony laptop has a power saving option in the BIOS. But the
action of your Toshiba is a little strange. Mouse movement and clicks
should be enough to keep it awake.

jimbo
Anonymous
a b D Laptop
August 28, 2004 11:17:36 PM

Archived from groups: comp.sys.laptops (More info?)

Ok, but there is power management in the BIOS as well.

>
> Linux, L-I-N-U-X, not Windows.
>
> Q
>
>
Anonymous
a b D Laptop
August 29, 2004 3:48:41 AM

Archived from groups: comp.sys.laptops (More info?)

On Fri, 27 Aug 2004 10:43:09 -0700, "Al C."
<no.spam.acanton@adams-blake.no.spam.com> wrote:

>
blanked
>

This looks like the default Linux kernel 10 minute terminal
screensaver. All it does is blank the video but the lamp stays
on. Check the Slackware docs and the manual pages for:
setterm -blank 0
xset s noblank
xset s off

You may have to put one in a startup script.

comp.os.linux.portable.
Anonymous
a b D Laptop
August 29, 2004 4:45:08 PM

Archived from groups: comp.sys.laptops (More info?)

jimbo <jimbo62@spamex.com> wrote:
> Al C. wrote:
>
> > I put Slackware 9.1 with KDE 3.1 on wife's new Toshiba A45 laptop. Works fine
> > except for one annoying thing. When she is playing a game where there is no
> > keyboard interaction (like Solitare), every 10-15 minutes the screen goes
> > black. You hit any key and it comes back up and all is OK. I think it has
> > something to do with the fact that the machine has not 'heard' a keystroke in
> > a while.
> >
> > I do NOT have APM or ACPI loaded, nor does KDE have any of the power saving

You are probably setting screen blanking in X.

> > 'features' enabled. Also, there is no screen-saver set.
> >
> > I tried xset -dpms but that did not work.

Well, keep "trying". That's not the only thing that xset can turn on
and off!

For screen-saver control:
s [timeout [cycle]] s default s on
....


And read you XF86Config for appropriate settings, and the X release
notes on your graphics driver, and the linux-laptops knowledge base on
your machine. AIR that is a known problem with a known solution on some
toshiba models.

> > Anyone have any idea of what the hardware is doing? I don't think it is a
> > Linux thing... but I could be wrong.

> I think my Sony laptop has a power saving option in the BIOS. But the
> action of your Toshiba is a little strange. Mouse movement and clicks
> should be enough to keep it awake.

It's probable that he has two mice, and he is using the secondary
mouse, and the secondary mouse is not set to provide "core events"
to X (which would wake it up). Shrug. That's his decision and his
configuration choice.

Peter
Anonymous
a b D Laptop
August 29, 2004 4:45:09 PM

Archived from groups: comp.sys.laptops (More info?)

P.T. Breuer wrote:

> jimbo <jimbo62@spamex.com> wrote:
>> Al C. wrote:
>>
>> > I put Slackware 9.1 with KDE 3.1 on wife's new Toshiba A45 laptop. Works
>> > fine except for one annoying thing. When she is playing a game where
>> > there is no keyboard interaction (like Solitare), every 10-15 minutes the
>> > screen goes black. You hit any key and it comes back up and all is OK. I
>> > think it has something to do with the fact that the machine has not
>> > 'heard' a keystroke in a while.
>> >
>> > I do NOT have APM or ACPI loaded, nor does KDE have any of the power
>> > saving
>
> You are probably setting screen blanking in X.
>
>> > 'features' enabled. Also, there is no screen-saver set.
>> >
>> > I tried xset -dpms but that did not work.
>
> Well, keep "trying". That's not the only thing that xset can turn on
> and off!
>
> For screen-saver control:
> s [timeout [cycle]] s default s on
> ....
>
>
> And read you XF86Config for appropriate settings, and the X release
> notes on your graphics driver, and the linux-laptops knowledge base on
> your machine. AIR that is a known problem with a known solution on some
> toshiba models.
>
>> > Anyone have any idea of what the hardware is doing? I don't think it is a
>> > Linux thing... but I could be wrong.
>
>> I think my Sony laptop has a power saving option in the BIOS. But the
>> action of your Toshiba is a little strange. Mouse movement and clicks
>> should be enough to keep it awake.
>
> It's probable that he has two mice, and he is using the secondary
> mouse, and the secondary mouse is not set to provide "core events"
> to X (which would wake it up). Shrug. That's his decision and his
> configuration choice.
>
> Peter


I tried 'setterm -blank 0' and that does not see m to work either. After
reading man I see that xset works with X (duh!) but not sure 'who' setterm
talks to? The kernel? Anyway, no help there so far.

(BTW I tired to put setterm -blank 0, xset s noblank AND xset s off into a
script run by rc.local. The setterm executed but xset took an error "Not able
to open display 0:0." Isn't rc.local run by root? How can root not be able to
open a display? Probably a good reason, but I don't know it.... but I'm
tryin' here!)

As for mouse on laptop, yes I have two devices, but we diabled the finger-pad
mouse but I forget how. I think we used some kind key-stroke hardware setting
when in Windows. When both mice were running, the finger-pad 'got in the way'
when wife was typing so she figured out how to get rid of it and just use the
USB mouse. Wife has bad arthritis (full disability, 3 total hip replacements
(first one went bad) and the finger pad hurts so she uses a traditional 2
button + scrol/button mouse.)

As for 'SendCoreEvents' I have it the Xconfig for the laptop (below), but when
I checked my tower (both run Slack 9.1) there is no mention of this parm.
Does the current version of X use it?

Thanks for your help Peter. Teach me where else to look.

-Al


Xconfig from laptop:



Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "PS/2 Mouse" "CorePointer"

InputDevice "USB Mouse" "CorePointer"
EndSection

=========

Section "InputDevice"
Identifier "PS/2 Mouse"
Driver "mouse"
Option "Protocol" "auto"
Option "ZAxisMapping" "4 5"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "true"
Option "Emulate3Timeout" "70"
Option "SendCoreEvents" "true"
EndSection

Section "InputDevice"
Identifier "USB Mouse"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "SendCoreEvents" "true"
Option "Protocol" "IMPS/2"
Option "ZAxisMapping" "4 5"
Option "Buttons" "5"
EndSection
Anonymous
a b D Laptop
August 30, 2004 1:16:21 PM

Archived from groups: comp.sys.laptops (More info?)

Al C. <no.spam.acanton@adams-blake.no.spam.com> wrote:

(posting style FIXED!!!!)

> P.T. Breuer wrote:
> >> > I tried xset -dpms but that did not work.
> >
> > Well, keep "trying". That's not the only thing that xset can turn on
> > and off!
> >
> > For screen-saver control:
> > s [timeout [cycle]] s default s on
> > ....
> >

> I tried 'setterm -blank 0' and that does not see m to work either. After

Not surprising, since it is a non-sensical random character-buzz.

For screen-saver control:
s [timeout [cycle]] s default s on
s blank s noblank s off
s expose s noexpose
s activate s reset

There is no "-blank".

> reading man I see that xset works with X (duh!) but not sure 'who' setterm
> talks to? The kernel? Anyway, no help there so far.

Why would you care about setterm? For the "-powersave" options? Perhaps
if you were not running a terminal emulation under X! You don't have
the last word on what the "monitor" does, and even if you did, it would
only apply to the emulation, which is a small fraction of the screen
real-estate at any one time!

>
> > And read you XF86Config for appropriate settings, and the X release
> > notes on your graphics driver, and the linux-laptops knowledge base on
> > your machine. AIR that is a known problem with a known solution on some
> > toshiba models.
> >
> >> > Anyone have any idea of what the hardware is doing? I don't think it is a
> >> > Linux thing... but I could be wrong.
> >
> >> I think my Sony laptop has a power saving option in the BIOS. But the
> >> action of your Toshiba is a little strange. Mouse movement and clicks
> >> should be enough to keep it awake.
> >
> > It's probable that he has two mice, and he is using the secondary
> > mouse, and the secondary mouse is not set to provide "core events"
> > to X (which would wake it up). Shrug. That's his decision and his
> > configuration choice.
> >
> > Peter
>
>
> (BTW I tired to put setterm -blank 0, xset s noblank AND xset s off into a

Only two of these are sensical.

> script run by rc.local. The setterm executed but xset took an error "Not able
> to open display 0:0."

Then set it to point to your display instead! Or allow your display to
be manipulated from localhost (using xhost).


> Isn't rc.local run by root? How can root not be able to
> open a display?

Root from a remote machine is not privileged on your display. Nor from a
local one, come to that, for all the difference it makes to X!



> Probably a good reason, but I don't know it.... but I'm
> tryin' here!)
>
> As for mouse on laptop, yes I have two devices, but we diabled the finger-pad

Then you now know what to do ...


> As for 'SendCoreEvents' I have it the Xconfig for the laptop (below), but when
^^^^^^^^^^^^^^

(but not for the device you are interested in!).

> I checked my tower (both run Slack 9.1) there is no mention of this parm.
> Does the current version of X use it?

I have no psychic powers to know what version of X you consider
"current".

Peter
Anonymous
a b D Laptop
August 30, 2004 3:26:07 PM

Archived from groups: comp.sys.laptops (More info?)

P.T. Breuer wrote:
>
>> I tried 'setterm -blank 0' and that does not see m to work either. After
>
> Not surprising, since it is a non-sensical random character-buzz.
>

What does that mean?




> For screen-saver control:
> s [timeout [cycle]] s default s on
> s blank s noblank s off
> s expose s noexpose
> s activate s reset
>

I've tried s noblank and s off. I don't see any of the other xset s parms
having an effect. I hate trial and error when it just looks like stabbing in
the dark with no logic behind it. But what the hell.


> There is no "-blank".
>
There is for 'setterm'
man 'setterm":

-blank [0-60] (virtual consoles only) Sets the interval of inactivity,
in minutes, after which the screen will be automatically blanked (using APM
if available). Without an argument, defaults to 0 (disable console
blanking).



>> reading man I see that xset works with X (duh!) but not sure 'who' setterm
>> talks to? The kernel? Anyway, no help there so far.
>
> Why would you care about setterm? For the "-powersave" options? Perhaps
> if you were not running a terminal emulation under X! You don't have
> the last word on what the "monitor" does, and even if you did, it would
> only apply to the emulation, which is a small fraction of the screen
> real-estate at any one time!
>

The laptop IS running X. What do you mean by 'terminal emulation" in this
context.




>>
>> > And read you XF86Config for appropriate settings, and the X release
>> > notes on your graphics driver, and the linux-laptops knowledge base on
>> > your machine. AIR that is a known problem with a known solution on some
>> > toshiba models.
>> >
>> >> > Anyone have any idea of what the hardware is doing? I don't think it
>> >> > is a Linux thing... but I could be wrong.
>> >
>> >> I think my Sony laptop has a power saving option in the BIOS. But the
>> >> action of your Toshiba is a little strange. Mouse movement and clicks
>> >> should be enough to keep it awake.
>> >

>> (BTW I tired to put setterm -blank 0, xset s noblank AND xset s off into a
>

>> script run by rc.local. The setterm executed but xset took an error "Not
>> able to open display 0:0."
>
> Then set it to point to your display instead! Or allow your display to
> be manipulated from localhost (using xhost).

Hmm, that makes sense. Had not thought of that (xhost +localhost command).
However, the xset commands I've tried as 'user' do not seem to have any
effect at all, so it seems moot. I don't see xset as my salvation here.



>> As for mouse on laptop, yes I have two devices, but we diabled the
>> finger-pad
>
> Then you now know what to do ...
>

I do? What?

>
>> As for 'SendCoreEvents' I have it the Xconfig for the laptop (below), but
> ^^^^^^^^^^^^^^
>
> (but not for the device you are interested in!).

What did I miss here? There is a SendCoreEvents on both.

Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "PS/2 Mouse" "CorePointer"

InputDevice "USB Mouse" "CorePointer"
EndSection


Section "InputDevice"
Identifier "PS/2 Mouse"
Driver "mouse"
Option "Protocol" "auto"
Option "ZAxisMapping" "4 5"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "true"
Option "Emulate3Timeout" "70"
Option "SendCoreEvents" "true"
^^^^^^^^^^^^^^^^^
EndSection

Section "InputDevice"
Identifier "USB Mouse"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "SendCoreEvents" "true"
^^^^^^^^^^^^^^
Option "Protocol" "IMPS/2"
Option "ZAxisMapping" "4 5"
Option "Buttons" "5"
EndSection


-Al
Anonymous
a b D Laptop
August 30, 2004 10:48:00 PM

Archived from groups: comp.sys.laptops (More info?)

On Mon, 30 Aug 2004 09:16:21 +0200, ptb@oboe.it.uc3m.es (P.T.
Breuer) wrote:

>
snip
>
>> I tried 'setterm -blank 0' and that does not see m to work either. After
>
>Not surprising, since it is a non-sensical random character-buzz.
>

That's interesting indeed.

>
snip
>
>Only two of these are sensical.
>

Sensical is not an English word (unless jargon) but it makes sense
for it to become one. Your posts are always an education!.

>>
snip
>
Anonymous
a b D Laptop
September 5, 2004 1:06:00 PM

Archived from groups: comp.sys.laptops (More info?)

"Al C." <no.spam.acanton@adams-blake.no.spam.com> wrote in message

<snip>

> I tried xset -dpms but that did not work.
>
> Anyone have any idea of what the hardware is doing? I don't think it is a
> Linux thing... but I could be wrong.

I was just looking for the same thing and ran across your post. I
think if you look under the KDE "control panel" labeled "Configure
your desktop" there is an option under Powercontrol -> display power
control -> enable display power management (check box).
See if that is checked.

good luck
Anonymous
a b D Laptop
September 5, 2004 5:10:30 PM

Archived from groups: comp.sys.laptops (More info?)

bad_knee wrote:

> "Al C." <no.spam.acanton@adams-blake.no.spam.com> wrote in message
>
> <snip>
>
>> I tried xset -dpms but that did not work.
>>
>> Anyone have any idea of what the hardware is doing? I don't think it is a
>> Linux thing... but I could be wrong.
>
> I was just looking for the same thing and ran across your post. I
> think if you look under the KDE "control panel" labeled "Configure
> your desktop" there is an option under Powercontrol -> display power
> control -> enable display power management (check box).
> See if that is checked.
>
> good luck

That was the FIRST thing I did.

I'm sure this is a hardware problem OR a bios change. I will get back to it
when time permits.

Thanks,

Al
!