Sign in with
Sign up | Sign in
Your question

HD 5770 - no bootup

Last response: in Graphics & Displays
Share
February 26, 2010 7:55:27 AM

Hi all,

I recently tried to upgrade my GPU to a XFX ATI Radeon HD 5770 XXX Edition 1024M from here.

I (wrongly) assumed it would be a very simple operation, just swapping the cards. How wrong was I???

Firstly, my setup...

Custom built by me.

Mobo ASUS A8V XE (Socket 939)
CPU - Athlon 64 X2 3300+
PSU - Akasa 400W Ultra Quiet PSU
which i subsequently replaced with a 700W PSU this one
Ram - 2G DDR2
Generic Optical Drive & SATA HDD

My old GPU, A PX1600XT Bravo overclocked edition 256mb still works if I swap it back in.

So, when I install the new GPU, the PC powers up, all the fans spin up and I get nothing. No beeps and no signal to the monitor. I tried switching the power from the 6-pin PCI-E connector direct from the PSU to the 2into1 (standard 4 pin cable) provided, using power from each rail of the PSU. Same result.

At this point I swapped out the PSU to the 700W one listed above. Same result.

I have tried moving RAM from slot to slot. No improvement.

From google searches, I have discovered that quite a few people on older setups like mine are having problems with this GPU.

I would be very grateful for any advice or suggestions.

James

More about : 5770 bootup

February 26, 2010 8:07:32 AM

You sure you did a complete driver sweep before inserting the card?
February 26, 2010 8:17:11 AM

Possibly not...
I followed the instructions on the ATI website for removing drivers. Found here

Basically, use the add/remove programs to uninstall the software.
I did not however run any further checks to see if any drivers remained.
Related resources
February 26, 2010 8:49:29 AM

You should try driversweeper, its possible you removed the program that supports your driver, but not the actual driver.
Anonymous
February 26, 2010 1:09:18 PM

Its not drivers. Have looked and you are not alone with this problem, Nforce n400 northbridge for some reason does not like the cards.

Try the following, with your 1600xt installed go into the bios and set the PCI frequency to 100mhz, it is probably on auto at the moment. reboot in to windows, switch off and install the 5770, reboot and see what happens.

Other than that contact Asus to see if there is a bios update for this board resolving 5770 issues.

By the way, keep the 700w installed throughout all of this.
February 26, 2010 1:27:28 PM

I think is time for u to change the system, motherboard,CPU,RAM if u want to use the new graphic card. there is an issue with Ati newest related to old chipsets that features for the first time PCI E.
February 27, 2010 4:32:37 AM

I had the same problem with my nforce 590sli amd mobo. The 5770 just didn't work with it. Did alot research before determining the was no way around it... It is time to build a new system. Good luck
February 28, 2010 7:17:22 AM

Thanks for all your replies and helpful advice.

However, I could find no way of getting that GPU to work with my setup. I believe that there must be an issue with the backwards compatability of that card with PCI-E V1.0

I have now replaced the Mobo, CPU & RAM and everything is working as it should.

Now running:
ASUS M4A79XTD Pro
Phenom X2 545
A-DATA 2Gig DDR3
And the XFX Radeon HD 5770 xxx
!