Sign in with
Sign up | Sign in
Your question

Diagnostic Policy Service fails - Vista networking

Last response: in Wireless Networking
Share
April 18, 2010 8:05:58 AM

Hey folks. I'm banging my head against the desk over this one, and if you can solve it, I will tattoo your name on my arm.

Before I start - understand that this is a personally owned computer, I'm on the admin account, and believe I have the admin token. UAC is disabled. System restore is useless, because no restore point exists prior to the date this issue started.

Problem:

I have a laptop running Windows Vista Home Premium, SP2. Three days ago, it suddenly was unable to connect to any of the four types of Internet Access I have available (Wireless Router, 3g/4g network, Direct DSL, and a 'anytime' wireless USB stick).

I've updated drivers, and done everything software-wise I can think of. So let's assume that is not the issue. The network center detects each connection and can pick it up with "limited" connectivity, yet no web browser or online service can connect.

After fiddling around, I discovered that many vista services were failing to launch. Among these were 'DHCP Client', and the 'Diagnostic Policy Service' (along with anything that counts this as a dependency' .


When attempting to restart these services, I get "Error 5: Access is denied."

So I started editing permissions on all registry keys that should have anything to do with my problem. They include:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DPS

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dhcp\

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BFE\

Not only have I given permission to all users, Local Service, Service, SYSTEM, and my dog, I have also tried adding in NT Service\MpsSvc and NT SERVICE\dhcp with full permissions.

I have been able to get DHCP client to start. But I am still getting this access denied message on the Diagnostic Policy Service.

The very last thing I tried, was to set the account for this service to the admin username I use. When I do this, I get a new message that says:

"Error 1297: A privilege that the service requires to function properly does not exist in the service account configuration." (And tells me I can use the non-existent secpol.msc snap-in to fix this).

I realize that the equivalent of what can be done in secpol, can be done here:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System

But I have no idea how. Any ideas? Am I even going down the right path for a solution?

Thanks very much ahead of time.

Anonymous
April 18, 2010 8:15:38 AM

Personally, when things appear so trashed I go looking for the OS install CD -- preferably a copy of XP.
m
0
l
April 18, 2010 8:32:42 AM

I sincerely wish that were an option...you have no idea! I'm trying to get this thing running for my dad. He does not have any OS on a cd.
m
0
l
Related resources
Anonymous
April 18, 2010 9:05:48 AM

Does the hard drive have a partition with the Vista factory install image on it ?
m
0
l
April 18, 2010 7:58:57 PM

Thanks for mentioning that Fihart! When I'd gone through that process before, I'd chosen a Microsoft Restore. Discovered that an OS did exist on the hard drive if I skipped the MS restore step.

Easy fix - Cheers. =)
m
0
l
June 4, 2010 6:25:45 PM

Hi Mars0740
I'm having exactly the same problem you mentioned in my wife's laptop.
How have you fixed it?
Thanks
m
0
l
!