Sign in with
Sign up | Sign in
Your question

Disable USB 3.0 when not in use?

Last response: in Storage
Share
April 3, 2012 7:44:49 AM

Hello, I hope this is the right thread. Maybe it's more of a BIOS-question. But here goes:

I have a MB with USB-3.0, I have fine blue ports on the back of my case. But I have no equipment that uses 3.0.

I have a mouse/key bluetooth-thingy, I charge the iPhone, occasionally I empty my camera - and my USB-key is most definately not 3.0.

The 3.0 controller (at least some of them) are on a seperate chip. Could I gain anything by disabling all 3.0 features? I mean start-up-time, power a.s.o.

Also, are there any benefits in using a 3.0 port in stead of one of the (red) 2.0 ports with my equipment?
I could easily live with 2 ports enabled - IF there is nothing to gain in using 3.0-standard with 2.0 equipment.

I have a code-43 device unknown-error recurring occasionally on the usb hub. Turn off: problem solved :) 

Thanks for any info/lessons in 3.0

More about : disable usb

a c 88 G Storage
April 3, 2012 8:29:56 AM

You should be able to turn off the USB 3.0 controller in the system setup if it is a separate chip (which it usually is) but you won't gain anything from it. The controller will enter sleep state if it's not used and you will lose the ability to use the ports even at 2.0 speed. If you're getting errors you should check for new drivers as USB 3.0 controllers are still fairly immature
Anonymous
a b G Storage
April 3, 2012 8:37:34 AM

what motherboard do you have?

chances are you did not install the usb3 drivers from the disk that came with the mobo.
Related resources
April 3, 2012 8:50:26 AM

To get it straight: If I put my (2.0) equipment in the chipset-controlled (red) ports, I will get the same speeds as in a 3.0 (blue) port. Correct?

Concerning the error: it's way too complicated to get into here. I cannot update the driver for an unknown device. When I try. windows says the best are already installed (for an unknown device, that is...)

I'm on a Gigabyte GA-Z68-UD5-B3, all drivers updated from homepage (NEC 3.0) - I've googled AND fixed it once, but when I use the port, it eventually happens again. So: I disable the port and don't use it.

Here's how it looks:
http://gyazo.com/eb7e35fdcbb53a847c4f63427584713c

I think it could be power related, but I have a Corsair AX850 which should be total overkill, since I dont have SLI or Crossfire or anything remotely close to drawing 850W.

But, really, as much as it bugs me that I have an error in device manager, I'd just like to learn about USB 3.0. If I don't/can't use it - should I disable it and use my red ports - and front/case USB for camera and iPhone (there's on/off charge in front, so I do that anyway)

Thanks :) 
Anonymous
a b G Storage
April 3, 2012 9:51:06 AM

USB 3.0

you will not get usb 3 speeds using usb 2 devices. usb 3 has twice as many data connections to enable bi-directional transmission.

right now there isn't many usb3 devices like usb2 so you won't be missing much. looking at your mobo specs you have two different usb3 controllers:
1 x Renesas D720200 chip and 2 x VLI VL810 hubs
one of them, that is used for what ports are giving you the problem, is flonky. if you want/need usb3 i would suggest getting a usb3 adapter for the usb3 headers on the motherboard
Biostar USB 3.0 Aluminum Front Panel CABLEUSB30 - Black
http://www.amazon.com/Biostar-Aluminum-Front-Panel-CABL...

but seriously, getting a board with a bogus chip is something i'd talk to gigabyte about.
April 3, 2012 10:17:52 AM

The biostar front adapter (or similiar) is actually included in the MB. But my case has 3.0 front ports as well, so I don't need the extra ports.

I have no way to test if it is 3.0-speed, since I don't own anything compatible - but they work. As do all ports on the back except "port 6, hub4" and that's because windows has disabled it. It used to work. I'm not sure I can blame Gigabyte or hardware in general. But I can live without that one port in the back next to the ethernet-cable.

Still, device manager errors hurt my nerd-eye. But still, I'm really talking about 2 different things here. Let's fix the error another day.

And I think you guys gave me the answer: I cannot in any way make use of 3.0 technology as long as I don't own a device (like an external USB 3.0 HDD) that is made for 3.0.
I can still use the port, but there is absolutely no difference if it's in 2.0-ports og 3.0-ports.
I could therefore disable all 3.0-technology in my bios. BUT, there's nothing to gain from it. Not half a second faster boot time, a single watt of power consumption less.

Correct?
Anonymous
a b G Storage
April 3, 2012 10:37:10 AM

that is correct. disabling usb3 will default your devices to usb2 speed and thats it.
April 3, 2012 10:51:36 AM

I seem to remember hearing about some USB 3.0 issues on Gigabyte boards. I would check on their website to see if you have the most up to date BIOS, as there may be a fix for the Device Manager error.

Update: I just checked out their BIOS downloads and didn't see any mention of a USB 3.0 fix... still worth a check, but I must have been mistaken.

I agree with everything looniam has said regarding disabling the ports. I pretty much disable anything I'm not using in the BIOS. eSata, 1394, wireless.... you can always flip the switch if you do need them.
April 6, 2012 3:21:02 PM

Today, I changed the power to my system so that it is grounded. When I turned the system back on, win7 automatically found the drivers and nothing is wrong in device manager anymore. I just knew it was power related :) 

I'm sorry if anything gets 'lost in translation' or in other cultural differences here, but over here in Scandinavia, we have 220-230 Volt current. The plug itself has either 2 or 3 'legs'. The third one is ground connection (Geez, it's difficult to translate technical stuff like this) - it's totally random if it's there or not when you buy electrical devices. AFAIK, it's only in kitchens and bathrooms that the outlet (erh, wall socket?) must be grounded (by law)

My stock Corsair AX850-plug looks like this:
http://gyazo.com/ea71614d402320f7715303cf9d54f633

Now it looks like this:
http://gyazo.com/30c2131421d10aa1423c5aec6827e5e2

...and code 43 problem is gone.

Is it a coincidence? I don't know. But if somebody came googling here to fix that problem, my suggestion is: try it. Plug PSU directly in the wall, using a 3-legged power cable.
Anonymous
a b G Storage
April 6, 2012 3:27:56 PM

thanks for the update!
i never would have thought about a grounding issue but it makes sense.
!