Sign in with
Sign up | Sign in
Your question

Rampage III Extreme eSATA port not functioning

Last response: in Motherboards
Share
November 9, 2010 11:11:42 PM

I have a new computer from Cyber Power built around the RIIIE, and as seems to be typical of their systems, it came out of the box with a few issues.

The last issue I can't seem to fix is the eSATA port on the backpanel. My Fantom Drive(s) won't register via the eSATA port.

*I have multiple drives, and have the same issue with each one, no eSATA connectivity.

*They show up just fine if I use the USB port to connect the drives.

*The eSATA connector on the drive and the eSATA cable is working, I plugged it into my laptop and the drives show up just fine.

*I have tried plugging the drive in, power on, and booting up the PC, to see if it would show up then: No drive showing up in Windows

So, any ideas on a solution to this problem?

------------------------------
I've given up, I will try calling ASUS to see if they can figure out what the problem is. Perhaps it's an issue with Windows not recognizing the controller that handles the eSATA port.
a b Ĉ ASUS
a c 236 V Motherboard
November 10, 2010 3:54:47 AM

1) Is your SATA controllers set to IDE or AHCI in your BIOS? You need it set to AHCI for the hot swap features of an eSATA to work. (how to switch it to AHCI, if needed... http://support.microsoft.com/kb/922976 )

2) Have you plugged the device in first, powered it up than booted up your PC to see if it recognizes the drive now?
m
0
l
December 16, 2010 6:34:01 PM

Well assuming you still have this issue and have followed tecmo34's advice I have something else to add.

None of my eSata devices worked with the ports provided. The one in the backplane is a power eSata, so it needed a cable that I do not have. I tried using the USB/esata back plate that is provided (black cables) and it kind of worked but would often crash the drive and Windows.

I had a spare duel esata backplate but the cables were not long enough to reach the available spare internal sata ports, so after finding some cables that would extend those, it now works perfectly on AHCI.

So I can only assume there is something unusual about the provided esata cable.
m
0
l
July 20, 2011 3:14:53 AM

Agree with Dunc. Had a similar issue to yours and it was to do with the cable. Bought a new cable from the local supplier and switched over to AHCI (previously, switching to AHCI would produce a BSOD everytime) which resolved the issue. Upon searching the mobo manual I found this answer (who reads the manual nowadays....).
m
0
l
!