Sign in with
Sign up | Sign in
Your question

WHAT TO DO IF MY MICRO SD CARD IS NOT FORMATTING

Last response: in Storage
Share
April 8, 2012 12:34:31 AM

I have bought a 32 gb micro sd card made by sandisk, will not format, downloaded formatter from sdcard.org, still no luck. keeps saying the write protection is on, I have unlocked it hundreds of times and reinserted, same thing over and over again. I want to use for a tablet, my computer and the tablet recognize the 32 gb card but I can't put anything on it and can't format it.

Help.

Thanks.

More about : micro card formatting

a c 261 G Storage
April 8, 2012 12:40:53 AM

Chances are it is faulty since it does not matter where the write lock is positioned!
m
0
l
April 8, 2012 12:52:34 AM

Really? I bought one from amazon and bought another off another reputable site. Same thing for both of them. Many google searches say it must be unlocked in order to format. Thanks.
m
0
l
Related resources
April 8, 2012 4:21:08 AM

One card says there is 29.71 GB, the other card says 0 bytes used or free, guessing that one is no good. I already went to that link you suggested, that is how I got here. The card is recognized by my tablet and I thought stuff was being downloaded until I checked it yesterday, nothing on it but it said 29.71 GB free, same as putting on my laptop. Tried the normal format, windows cannot format, went to google and clicked on many links, downloaded the formatter, seemed to format for about 30 minutes and then a window popped up saying windows could not format. I even tried copying various items from my laptop, said the disc is write-protected and could not be copied, something to that effect. Currently using a Windows 7 laptop and I also have a Windows XP laptop, tried the cards on both, same readings. No idea what to do now except probably just return them on try again. I have formatted other discs before, no problem. Not these two. Very strange.
m
0
l
!