Sign in with
Sign up | Sign in
Your question

DX10/DX11 not working

Last response: in Graphics & Displays
Share
March 2, 2010 2:23:08 PM

None of the games with DirectX10/11 enabled work on my PC, even though my graphic card supports it and I'm running Windows 7 64 bit. I can run them just fine with DirectX9 I have the latest nvidia drivers, and the latest DirectX installed. What to do?
Here are my specs:
Processor: Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz (4 CPUs), ~2.4GHz
Operating System: Windows 7 Ultimate 64-bit (6.1, Build 7229) (7229.winmain.090604-1901)
Memory: 2048MB RAM
Card name: NVIDIA GeForce GTX 260

More about : dx10 dx11 working

a b U Graphics card
March 2, 2010 2:45:06 PM

Can you please name the games?

Your card should run dx10 games fine although not dx10.1/11 as it does not have the capability.
a b U Graphics card
March 2, 2010 2:46:55 PM

The Geforce GTX 260 is not a Direct X 11 card. It is Direct X 10. The maximum you will be able to run is DX10. Some games that have come out recently (Alien Vs Predator included) Only have DirectX 11 or DirectX 9 support. So depending on the game you are playing it will automatically choose your version. Also remember that the higher the direct X the more physical memory your system will be using, it may be time to upgrade those 2 gigs of ram to 4 gigs, especially when 1gig is automatically used by Win 7.
Related resources
March 2, 2010 3:19:28 PM

Battlefield Bad Company 2, Alien vs Predator and STALKER: Call of Pripyat. BFBC2 is DX11, AvP is DX11, but STALKER is DX10 and it still crashes in the same manner the other two do.
March 5, 2010 1:16:00 PM

Any ideas? It sucks not being able to play DX10 even though I have a PC capable of it. :/ 

Oh, also, I found out I can run DX10 in windowed mode a while ago. It still crashes in fullscreen.
March 5, 2010 2:02:25 PM

After some research I found out that it has got something to do with the refresh rate, and Win7 being stuck on a certain rate. Mine is stuck at 60Hz even though my screen (ASUS MW221C) supports 75Hz, and I can't find a way to change it.
a c 217 U Graphics card
March 5, 2010 2:39:08 PM

You should be able to right click your desktop. Click screen resolution->advanced settings->Monitor tab, from here adjust your frequency.
March 5, 2010 7:54:35 PM

bystander said:
You should be able to right click your desktop. Click screen resolution->advanced settings->Monitor tab, from here adjust your frequency.


No sh*t? Lol, if it was so easy, I'd change it. Can't change it in NVidia control panel either.
a c 217 U Graphics card
March 5, 2010 11:04:44 PM

Perhaps you should try to find drivers for your monitor.
!