Sign in with
Sign up | Sign in
Your question

My USB is Write-Protected

Last response: in Storage
Share
April 10, 2012 12:13:50 PM

Kingston DataTraveler G2 32GB


As you can see, it doesn't have any switch. I tried this:
My USB Flash device is write protected

How to remove a write protection from your USB memory Stick if there is no Write protection ON or OFF button or tab:

1. Shutdown your computer or laptop
2. Insert USB Memory Stick into your laptop or Computer
3. Turn on computer and then immediately start pressing (F8) key then Advanced Boot Options screen will come up
4. Select Safe Mode with Command Prompt
5. After loading files if your USB Memory Stick drive letter is (G) for example then write as
6. C:\windows\system32>G: and press enter
7. G:\>format G: and press enter
8. If ask you (Y/N) then press (Y) and press enter
9. Now a full format will start which remove write protection from USB Memory Stick.


But I had "Insert new disk for drive G...
press ENTER

I press enter, it says the USB's capacity then it says it's write protected.
Any ideas?

More about : usb write protected

a b } Memory
April 10, 2012 8:46:57 PM

Have you tried removing the write protection from your system registry?
m
0
l
a b } Memory
April 10, 2012 8:49:58 PM

This topic has been moved from the section CPU & Components to section Storage by Proximon
m
0
l
April 12, 2012 7:53:10 AM

Proximon said:
Have you tried removing the write protection from your system registry?

I searched the registry but couldn't find it.
I have Windows 7 Ultimate N, is it a problem?
I'd Appreciate it if you can give me something.
m
0
l
!