Sign in with
Sign up | Sign in
Your question

WD Elements SE Portable 1tb Power Issues

Tags:
  • Hard Drives
  • Western Digital
  • Power
  • Storage
Last response: in Storage
Share
April 11, 2012 5:24:58 AM

Hi All,
This is my first post, and i've scoured the forums and google for an answer to my problem, but nothing has helped so far. I have a macbook pro 17" and a WD elements SE portable 1tb external drive which has the (ugh) problematic usb micro drive. It's was working fine, as I never really moved it around. Then one day carried it over to my friend's place (5 minutes away), didnt drop or rattle it, and it just began giving me the "USB device is drawing too much power" error. The drive never comes to life as OS X immediately cuts power to the USB ports. Now here's what I tried:

1. Same error pops up when plugged into other macs too
2. Tried different micro usb cables
3. Plugging into my tv

Now I contacted wd and they're willing to replace the drive, but my problem is that I need to recover the data, it's only a 2-month old drive so I hadn't even backed it up!! Don't have the money for professional recovery, so need some help to either get the drive working or at least recover the data myself. Of course, since it's that funny micro usb drive, i can't even transfer the drive to a different enclosure and backup. I do however have formal permission from wd to open the drive and backup my data without voiding the warranty. Whew, long post, but would really appreciate some help! Thanks!

More about : elements portable 1tb power issues

Anonymous
a b G Storage
April 11, 2012 5:51:23 AM

"formal permission to open ur drive". Recently had a conversation with WD people. They told me that drives can only be opened by qualified people as qualified data recovery companies and i will have to back that up with a proper letter or mail from those ppl. WD also told me that they dont allow any form of repair on their in warranty products, so it makes no sense in opening the drive unless u need a data recovery. Check about this. Warranty policies may differ from region to region but do inquiry about this with the RMA center in ur region.
m
0
l
April 12, 2012 4:33:49 AM

Hi,
I am in Singapore, and i'm sure of this, I spoke to their customer service representative, inquiring about backing up my drive, they sent me this response:

Dear Kaizad,

Thank you for contacting Western Digital Customer Service and Support.

You have been authorized by Western Digital for Data recovery to be performed on product (Serial: WXW1E31FSEF7) by means of yourself or a preferred 3rd party data recovery service provider.

Kindly attach this email (write the RMA # on it) to the product when returning it to our service center or the place of purchase for warranty claim after the data recovery process is completed.
http://websupport.wdc.com/warranty/rmainfo.asp?custtype...

Failure to attach this email will result in non acceptance of the product.

If you have any further questions, please reply to this email and we will be happy to assist you further.

Sincerely,
Rovile V
Western Digital Service and Support
http://support.wdc.com

Now back to the problem at hand, any advice/tips/tutorials guys?
m
0
l
Related resources
April 14, 2012 4:07:08 AM

bump
m
0
l
April 14, 2012 4:12:26 AM

[UPDATE] Just bought a powered usb hub last night to try it out, alas the drive gave me the same error!! :

"Because a USB device was drawing too much power from your computer, one or more of your USB devices have been disabled.
To prevent damaging your computer, the USB device drawing too much power has been disabled. Other devices may have also been disabled. When you disconnect the device drawing too much power, your other USB devices will be enabled again."

Grrr, so im guessing some internal connection must be awry! Please help since I do have permission to attempt a recovery on my own or by a professional (which is waayyyy too expensive - $1000-$3000 here in singapore)
m
0
l
!