Sign in with
Sign up | Sign in
Your question
Solved

Why wont my computer recognize anything plugged into the USB ports

Last response: in Components
Share
May 25, 2010 6:00:49 PM

Whenever I insert something into one of my computer's USB ports, such as a flash drive, it doesn't get recognized. This happens with things other than just a flash drive as well, like my iPod. I have numerous USB ports on my computer, but they all act the same. I'll insert a flash drive and even after it's not automatically recognized, I'll go into "My Computer" and it shows all the "Removable Disk" drives as being empty. I'll click on one and a prompt will come up and say, "Please insert a disk into drive F" or whatever drive I happen to click on. I've tried this with all the drives but to no avail. Any suggestions?
May 25, 2010 7:11:47 PM

System Specs ?????

Have you tried reinstalling OS
m
0
l
May 25, 2010 8:52:32 PM

Well, my computer crashed a while ago and I had Windows XP Pro reinstalled with all the necessary updates. The problem started after the reinstallation.
m
0
l
Related resources
May 26, 2010 6:19:14 AM

Check the device manager to see if the USB ports are all identified & try re-installing the USB driver
m
0
l

Best solution

May 26, 2010 9:19:55 AM

you'll probably find that when you go into control panel -> system -> hardware -> device manager, that there are a few warning signs. You'll need to reinstall your motherboard drivers, I'd say if it's one in particular it's probably your USB Host Controller, you can get them at the motherboard manufacturer website, most of them can determine the model number by a simple active x control, but if you're unsure and dont want to take it apart, when you boot up it normally says the model number. Stick that in and you'll find your solution
Share
May 26, 2010 11:52:05 AM

To the OP:
Another thing to consider is whether somehow in the BIOS, you set it to "safe default" or something similar. What it does is disable to USD ports and no setting under the OS can enable it.

If you did set it to safe default, just set it back to "recommended setting".
m
0
l
July 28, 2010 10:00:23 AM

Best answer selected by buwish.
m
0
l
!