Sign in with
Sign up | Sign in
Your question
Solved

Storage Drive help

Last response: in Storage
Share
April 11, 2012 9:31:36 PM

Hi all and thanks for help in advance,
My problem is that I have an external storage drive that broke but could still be used internally, now when I first was setting up my 2 storage drives I had no problems with it. What has now happened is that windows wont let me access it saying semaphore timeout has expired (or something like that as Im in class and didnt bring the written note of it with me) but currently Im running a full western digital life program to check for errors as I read that might help(first time had errors and failed to repair, second time as of right now its running better, also I've swapped sata cables which did nothing. So not quite sure what to do. Any help would be great as like I said it was fine and I even had a system backup on it and then it messed up while I was doing other things I suppose.

i7 2600k
16gb Ram
Win7 Pro
570 gpu
OCZ vertex 3 120gb
WD Caviar Green 1.5TB(the one with the problem)
WD uhh something 500Gb

More about : storage drive

a c 99 G Storage
April 11, 2012 9:37:05 PM

Quote:
external storage drive that broke


I think there is your problem! Broke what and how?
m
0
l
April 11, 2012 10:57:57 PM

foscooter said:
Quote:
external storage drive that broke


I think there is your problem! Broke what and how?


just the part that made the mini usb to the hdd itself, the hdd as far as I know was never damaged and it was working fine and I did a windows backup with it and then this situation happened
m
0
l
Related resources
a c 99 G Storage
April 12, 2012 12:17:04 AM

Can you see it in Disk Management?

Can you format the drive? But, you'll lose everything, which I think has happened anyway.
m
0
l
April 12, 2012 2:54:04 AM

I can see it and I've tried to format and it fails delete and try again fails, windows install to custom to delete and format that fails, I honestly dont know what happened. Prior to this happening I had an error on my ssd to which I tried a windows repair and it only listed my 1.5tb(the problematic one) which had the backup on it and I hit the fix button but a little ways through it I shut my computer off to stop it because I was worried about my other drives getting messed up. The drive still will show in my computer as drive F: but wont let me access stating the "the semaphore timeout period has expired" so I did the whole formatting stuff through disk management, deleted the drivers, switched sata cables, and no avail. Right now Im currently running Data Lifeguard tools from WD, and the extended test said errors that might be fixable then it couldnt fix them, now Im trying a write zero's to whole drive and at first it wouldnt work was just popup error after error, so I did a quick one which worked and now Im doing a whole drive zero write again and so far no errors, but a helluva long wait lol like 4 hours.
m
0
l
April 12, 2012 2:55:38 AM

My ssd is good btw and I still have a 500gb storage drive Im using so all in all I'm fine, I just would like to keep this drive and use it to ghost my ssd along with storing extra things if I wanted
m
0
l

Best solution

a b G Storage
April 12, 2012 3:32:11 AM

this for semaphore time out http://support.microsoft.com/kb/2570355
Share
April 12, 2012 3:13:43 PM

Thanks all for the help, I was able to correct the problem using the tools from western digital........I had to do a full write of zero's first and then do a extended test using the data lifeguard software. Afterwards went to disk management and set it up as usual, works fine again and I was able to do a system backup. Thanks again :) 
m
0
l
April 19, 2012 1:41:39 PM

Best answer selected by adayyum.
m
0
l
!