Solved

Overclocking AMD FX8120 with Asus Sabertooth 990FX

I'm trying to OC my AMD FX-8120 black edition on my Asus Sabertooth 990FX.
I went into my BIOS and I've disabled all the "green" settings, set everything to manual, and I increased the CPU ratio to 20 (to get 4 Ghz, something that was easily stable for me when I tested it in AMD overdrive utility).

Now, it shows the target CPU speed at 4 Ghz, but the Current CPU Speed isn't changing (still at 3.1 Ghz), even after saving and resetting (via F10 key).

When I run CPU-Z in my OS, it still has the Default Turbo speed of 3.4 Ghz and a 17x multiplier. (I have disabled the automatic turbo core boost in the BIOS).

Am I doing something terribly wrong or just incredibly stupid??? Thanks for any suggestions!

Here are screenshots:







Is it possible that this is the case because I previously had AMD overdrive installed? (I set it back to default settings and uninstalled it)

Also, I noticed it saves my settings if I set it to DOCP instead of manual in the BIOS, and this works fine showing a 20x multiplier in CPU-Z. My only concern is the DRAM OC speed of 1600 mhz, since mine is only rated 1333 mhz.
4 answers Last reply Best Answer
More about overclocking fx8120 asus sabertooth 990fx
  1. Best answer
    yeah I was reading someone else having difficulty with amd overdrive lingering.

    may want to default your bios. start in safe mode. uninstall the over drive, look for left over files. run a ccleaner(or what have you). restart into windows. then restart and go back into your bios and try again.


    ...oh yeah and disable the apm, if your cpu is throttling. I had trouble with it on the fx6300
  2. First update your bios from here to the latest version:
    http://support.asus.com/download.aspx?SLanguage=en&m=SABERTOOTH%20990FX&os=30

    Then try again and get back to us, and as Mt Power said disable apm under cpu config
  3. Thanks for the help all; I was able to resolve the issue by switching over to DOCP mode and inputting the values that way (After that point, I was able to change values in manual mode as well).
    I have also disabled APM now as well.
  4. Best answer selected by fingolimod.
Ask a new question

Read More

Motherboards Sabertooth AMD CPUs Overclocking