Sign in with
Sign up | Sign in
Your question
Solved

Enabling AHCI and using SSD

Last response: in Storage
Share
April 14, 2012 5:00:40 AM

I just bought a mushkin chronos (not the enhanced one). Anyways i have tried enabling AHCI on my bios but for some odd reason i ge the feeling its not really enabled. I ran an SSD benchmark utility crystaldisk and my read and write are really really slow -169/179 mb/s. I believe i should have it atleast 300 or even close to 500. I know it will perform less then the 515 its supposed to give but 169/179 is just lame lol.

Specs of my pc:
Gigabyte 990-fxa ud5
fx 6100 @ 4.9
RAM @ 1866
saphire 6970

I have downloaded all the driver updates including newer bios as well. What im thinking is my cables must not be hooked on to the correct ports-they could by on the marvel ones-GSATA3_6, GSATA3_7. However, when i try to hook those cables on SATA3_0~SATA3_5 my ssd is picked as slave not master no matter what configuartion i do since i do have another HDD hooked up as well. I dunno what to do next.

The webpage to my mobo:http://www.gigabyte.com/products/product-page.aspx?pid=...

Thanks for any help

More about : enabling ahci ssd

a b G Storage
April 14, 2012 6:20:16 AM

AHCI mode must be selected before install of the OS. Trying to change to AHCI mode after installation will not work. I am not sure if this is applicable to your situation as its not clear which disc is the boot disc.
Also running in mixed mode doesn't really work. So the best solution is to do a fresh install on the SSD after setting AHCI mode in BIOS. And yes, I would move the SSD to the SATA III 0 channel.
m
0
l
April 14, 2012 6:32:58 AM

oh no i hope your just joking man. haha so do a re install all over again. Okay although i did go in bios and set it to AHCI before install. But i dunno maybe i didnt do it properly.
m
0
l
Related resources
April 14, 2012 6:33:51 AM

My boot disk is my chronos, the HDD is just a back up disk really
m
0
l
a b G Storage
April 14, 2012 6:44:46 AM

Well, if it is in AHCI mode then you are on the wrong controller.
m
0
l
April 14, 2012 6:53:07 AM

hmm i just went into bios and set my Gsata to ahci since it was in ide. My speeds have somewhat improved. Im still hooked on to the 6/7 port though but its getting recognized as AHCI although those ports i thought were marvel? Not sure whats going on?
m
0
l

Best solution

a b G Storage
April 14, 2012 7:25:26 AM

Yeah the marvel controller sucks. When you have time, move the SSD to channel 0 and then you'll have to set it as the boot drive. Should work out from there. It will only be put as slave if in IDE mode. There is no slave in SATA mode.
Share
April 14, 2012 7:37:15 AM

Yup did it and it works! Im getting good speed too. Thanks man
m
0
l
April 14, 2012 7:37:27 AM

Best answer selected by gary215.
m
0
l
!