Sign in with
Sign up | Sign in
Your question

5770 won't boot

Tags:
  • Radeon
  • Boot
  • Graphics
Last response: in Graphics & Displays
Share
March 4, 2010 3:34:38 PM

Hi, I recently bought a XFX HD5770 on the advice of some people on here as an upgrade for my old geforce 7900gtx, but when installed it and tried to start the PC up, it wouldn't boot at all. No beep code or anything, just some intermittent whirring and flashing of lights on my dvd drives.
Fairly sure its seated properly, tried removing it and then put it back but no change. I tried removing my old nvidia display drivers before changing the card, then tried not removing them but it made no difference. Tried connecting the 6-pin cable directly from the psu, or through the Y adapter supplied for 2x 4-pin --> 6pin but still nothing. Is the card a dud, or have i missed something?
When I put my old 7900gtx back in, everything works fine

My system specs, if that helps:
Core 2 duo E6700, ASUS P5N32-SLI SE Deluxe, 2GB DDR2 800MHz, 550W PSU

More about : 5770 boot

March 13, 2010 12:36:58 AM

Not sure of the problem either, got a spare other mobo you can try it on. You said you posted earlier got a link to that thread?
April 15, 2010 1:18:27 AM

I´m having the same problem. My new computer i3 540 + MB Intel DP55WB _ Seventeam 650W PSU works fine with my Geforce 7600GT but when i put my new hd5770 the computer won´t boot. I´ve send the 5770 back to the seller and he told that it´s working perfectly. I don´t know what to do. I´m in cantact with XFX support but at this moment nothing. Somebody help me please!!!
!