WD 1TB HDD won't show up on BIOS

I am building a computer for the first time and it all seems to be working except i cant get my BIOS to register that there is a hard drive. When i go to the SATA port that my hard drive is plugged into on the CMOS Standard Settings page of my BIOS Setup the brackets, where there should be either a "[hard drive name]" or a default "[auto]", are completely blank. The BIOS is detecting the CDROM, it just isn't finding the HDD, and I need to have the HDD in order to load the operating system (Windows 7), thus continue doing anything to set the computer up.

Here's the parts I'm using:
Hard Drive- Western Digital Caviar Black WD1002FAEX 1TB 7200 RPM 64MB Cache SATA 6.0Gb/s 3.5" Internal Hard Drive -Bare Drive
Motherboard- GIGABYTE GA-Z68A-D3H-B3 LGA 1155 Intel Z68 HDMI SATA 6Gb/s USB 3.0 ATX Intel Motherboard
CPU- Intel Core i5-2400 Sandy Bridge 3.1GHz (3.4GHz Turbo Boost) LGA 1155 95W Quad-Core Desktop Processor Intel HD Graphics 2000 BX80623I52400
PSU- KINGWIN Lazer LZ-1000 1000W Modular 80 PLUS BRONZE Certified Active PFC W/ 3-Way LED Switch and Universal Modular Connector Power Supply

Any help will be greatly appreciated
15 answers Last reply
More about show bios
  1. Yes, you will need the HDD to continue the installation (Win7 needs to be stored somewhere :) ).

    The simple things first:
    - Check the power and data cables are connected properly. Even if they look like they're seated properly, unplug and plug again, just in case.
    - Possibly trading the CD-ROM's cables with the HDD cables (because you know the CD-ROM's cables are working).
    - When you power on the system see if you hear the HDD spin up (if you've exchanged cables and all that, yet no spinning, you may have a dead HDD)
    - Lastly try a different SATA port on the mobo.

    Your BIOS being set to Auto is the ideal setting for you at this point. There are other steps we can take, but do the simple stuff first. Let us know how you get on...
  2. You can also make sure the drive works by plugging it into another system.
  3. also look in the bios setting to see if all the sata ports are turned on and if your using the ones that are turned on.
    with these new mb there two sets of them one set is run by the intel mb chipset the other by marvel or other controller.
  4. I suspect you have it plugged into a dedicated raid controller that motherboards sometimes include which will not show up in that section. if you have the hdd plugged into 2 ports of different colour to the other say 4-6 sata connections (eg i have 2 white and 6 blue ones, the white ones being this extra controller) then that will be your issue
  5. Ok, thanks for the replies.
    I checked to make sure all the cords were plugged in correctly, they were.
    I switched the SATA cord on the motherboard from the white slot i had it in to a blue SATA slot, it still didnt detect.
    I plugged the HDD in with the cords that were on the CD-ROM, it didnt work.
    I checked to make sure the HDD actually turned on (made noise, vibrated, etc...) and it was.

    I dont really have another machine to test the hard drive on though
  6. in the bios the default setting is ide you need to change it to achi (sp) mode.
  7. Oh, ok i saw the IDE and ACHI modes and to be honest i didnt know what they meant and i didnt want to screw around with the default settings. ill go try that now
  8. I tried the ACHI mode and the hard drive still didnt show up
  9. 1) You Do NOT have to worry about the "Marvel" controller as your MB only has an Intel controler (2 Sata III ports and 4 Sata II ports). SO, If not showing up, and this Is a NEW drive - Your choices are:
    ..Drive.
    .. cables,
    .. MB.

    Since you A) used the data cable that the DVD drive used - No workee.
    .. You swapped ports. No workee, BUT you know the DVD drive works. You tried IDE and ahci (ahci is the recommended setting).
    Sounding like it is the drive.

    Download from the manufs website the WD BOOTALE utility disk. The disk should show up, if it does not then Contact either vender, or WD for RMA. NOTE, if NO computer to download and create the Bootable CD, Hopefully you have a friend.
  10. ok, ill try the CD, thanks
  11. I downloaded the Data Lifeguard Diagnostic for DOS that the Western Digital site said i should for my Caviar Black HDD and when i put the disk into my new computer it said no hard drive detected. The disk worked but the hard drive wasnt detected. Should i RMA the hard drive at this point?
  12. The fact that the hard drive seems to turn on and the fact that when i plugged it in, the slot on the CMOS screen where it shouldve shown up was blank, brackets and all were gone, lead me to believe that there is something going on in the HDD. I simply dont know enough about this whole process to figure out what the issue is.
  13. Looks like a RMA is infact inorder - sorry
  14. thanks for the help everyone. Going to RMA it
  15. greenknight75 said:
    thanks for the help everyone. Going to RMA it



    Hey, I'm actually experiencing a similar issue atm. The difference is that my computers been fine for a year, and recently it hasn't been able to detect my hard drive. My CD drive is working though and I've tried all the cable switching. After you RMA'ed the HDD, did it all become ok?
Ask a new question

Read More

Hard Drives BIOS Storage