Sign in with
Sign up | Sign in
Your question
Closed

ATI HD 5770 crashs/freezes/odd colors you name it this card has it.

Last response: in Graphics & Displays
Share
March 5, 2010 11:37:30 PM

i been with Nvidia for over 3 years, however at this moment, im seeing Price vs Performance is leaning towards ATI no doubt about that, plus they offer dx11 and alot of cool features that i really got interested in.

so i gave it a shot and bought this HD 5770, installed win 7 64, installed ati drivers, 5 mins later it crashed and i had to do hard reboot to get out of it, now again booted to windows 7, 4 mins later, it showed me some gray colors that are beautiful, froze my screen for 10 seconds and then message appeared "driver had a problem and has been recovered" (something like that)

so i thought about formatting the computer thinking that it might fix the problem, did a format with clean fresh windows 7, everything is fine, this time i went to xfx to install the drivers, everything is fine till i rebooted to take effect, got in windows, but this time something new... vertical lines all over the screen and i had to hard reboot to get out of it.

then i wanted to test the hardware to see if its a memory/psu/cpu problem, i loaded up my old 9500gt (formatted win once again) installed drivers, everything seemed fine, played left for dead for 20 mins to test, kept surfing the net for about 2 hour, everything is perfect, from this you can conclude that its not a hardware problem (ram/cpu/psu/mobo) is all working perfect.

that just makes me wonder if its a driver issue or could it be a hardware issue, but most likely its a driver issue, because im using it right now as im writing this topic using safe mode (uninstalled ati drivers) with no problems, however using the lowest resolution and cant play any of my games, the reason i dont want to RMA this one because alot of people are having the same problem, so RMA is 90% isnt gonna work and just waste of time.

so is there a solution for this yet? is ATI working on this or they just release the New TOP END DX11 CARDS WITH THE MOST UNSTABLE DRIVERS ??

my specs are:

600 OCZ modxstream PSU
2x2 corsair 1600 8-8-8-24 ram
core i5 750 cpu
asrock extreme p55 mobo
win 7 64

if anyone has any solution for this, please do post in this topic, thanks in advance.
March 6, 2010 12:28:41 AM

if you check the newegg reviews and tomsforums

the 5XXX series of cards seemed to be plagued with issues
some people think its the cards themselves
some the drivers from ATI
some state the issue is with Win 7 64 bit
new drivers fixed these issues for some people but not all

most people I would say have no issues at all but its not a real good time to be purchasing a video card.

P.S. It seems Nvidia got jealous of the ATI issues and released a new driver that causes problems also.



March 6, 2010 12:31:08 AM

so based on your experience, what do you advice me to do? i can still get full refund from new egg since i just bought it 3 days ago, or i can RMA and get a new one (but i'll leave this as the last option)

or wait till they fix the drivers, or should i just go with 260gtx?
Related resources
March 6, 2010 12:41:06 AM

the GTX is over priced (more then a 5770 on newegg), you can get an ATI 4870 for less and it has the same performance.

You tried both the drivers on the disc and the AMD web site's latest and greatest?

I suggest you RMA and try a different brand. The Sapphire cards "seem" to be fairly stable, although you read the consumer reviews and they state similar issues as well.

March 6, 2010 12:52:46 AM

So, this was a fresh install (thus no driver issues), correct?

PSU looks good.

Newest MB BIOS?

If all that checks off, I'd try RMAing the card for the same thing. Bad cards happen now and then, nothing you can do about it.
March 6, 2010 1:03:45 AM

yes i had no errors while installing the drivers, 3 times 2 of with fresh win 7.

bios dam i dont know i forgot about that one, i'll go update and reply back.

thanks for the help.
March 6, 2010 1:49:02 AM

it was already 1.90 which is the latest update from asrock, tried this time installing 9.11 from ati, still same thing.
March 6, 2010 1:51:13 AM

Yep, that's enough testing in my opinion. I'd try RMAing the card. If the next one is still defective, then we'll have to reevaluate.
March 6, 2010 2:08:57 PM

EXT64 i see you have the 5850 in your specs, did u get in any troubleshoting for that one, or did it just work out of the box?
March 8, 2010 12:27:31 AM

ok here is an update, i hope this might help.

it only crashes while im in 2d mode, today i played devil may cry on full settings for over 2 hours it didnt crash not even once, but then after i got out of the game it only took 10 mins and then it crashed.

so it appears that it only crashes when its on idle in 2d mode, do you guys think if i overclock my gpu would fix the problem? however i dont know how overclock ati cards, if someone can point me to a tutorial please.

thanks in advance.
March 8, 2010 3:24:58 PM

finally!!! i solved the problem, its good that i didnt RMA it back.

the reason why it crashes in 2d mode because it goes to 157 core speed which is too low, short answer, overclocked it in 2d mode to 400 and now been running for 5 hours without a problem.

if anyone has the same problem and wants help with that just let me know.
March 8, 2010 7:19:48 PM

It is supposed to go that low however. So, raising (or disabling) the 2-D clock may fix the issue, however the card is still defective (albeit in a not very annoying way).
March 8, 2010 7:24:35 PM

Quote:
The Sapphire cards "seem" to be fairly stable, although you read the consumer reviews and they state similar issues as well.
Mine's worked fairly well for the time that I've had it.

Mine also goes to 157 core speed, so as EXT said it is supposed to go there. I'm just wondering how you OC'ed the 2D clock speeds, I can only OC the 3D clock speeds.
March 8, 2010 7:29:42 PM

I noticed if I maxed my OC of the 3D, the 2D would go up to 500 (like the old cards do).
March 8, 2010 7:32:54 PM

In what ratio? Like, OC 3D by 50MHz and 2D is OCed by 100MHz?
March 8, 2010 8:14:01 PM

I didn't really check. All I know is when 3D went from 725/1000 => 775/1125, 2D went from 157/300 to 500/750. No idea why, may have been a glitch.
April 6, 2010 3:10:15 AM

surda said:
finally!!! i solved the problem, its good that i didnt RMA it back.

the reason why it crashes in 2d mode because it goes to 157 core speed which is too low, short answer, overclocked it in 2d mode to 400 and now been running for 5 hours without a problem.

if anyone has the same problem and wants help with that just let me know.



Hello,

I have an XFX HD 5770 and I've had problems with game crashes and with idle crashing. Completely updated my BIOS, ATI Drivers, chipset drivers, the works...

I have tried a slight overclock with Catalyst and with AMD Overdrive to no avail so far.

What frequencies would you recommend for the Ati card overclock? I'm not sure what runs stable with it.

All temps are good so I ruled that out. Also, my PSU is a 700W Thermaltake and it seems to be running just fine. Please let me know if I should RMA or not. Thanks!
April 6, 2010 6:14:02 AM

I'm running a Sapphire Toxic 5850 and I've been experiencing the exact same problems. I've tried about everything. I put in a ticket on sapphires website and they told me to email my part and sku number to another email to request a bios that might fix my issue. Waiting for them to send me that to try. But it definately doesnt seem to be a hardware issue as I can sometimes get games/benchmarks to run for a bit before it freezes with vertical lines. Perfect frames/temps when it does work.
April 6, 2010 7:32:10 AM

I also have a Radeon HD5770. I was getting frequent TDR issues when I was at the desktop or browsing the internet. Nothing serious. ( TDR is Timeout Detection and Recovery, a feature introduced first with Windows Vista to overcome gfx card problems in earlier OSs, which then turned out be the problem itself. )

Later I learned over the internet that people increased the idle ( 2D ) clock speeds to overcome the 2D crashes. Therefore, I followed them and increased 2D clocks thru the profile thing.

I increased core clock from 157 MHz to 200 MHz and memory clock from 300 MHz to 400 MHz ( I got at these figures by trial and error ). Now everything is perfect.

People having 2D problems with HD 5xxx series cards, please check first if your PSU complies with version 2.2 and then increase 2D clocks.

Hope the above is helpful.

Regards
April 6, 2010 12:00:14 PM

Games will be using the 3-D clocks, which are high. You could try downclocking your card (since it is factory OC'ed) to see if that helps stability.
April 6, 2010 12:54:06 PM

HD5970 is a different card than OP's HD5770 and increasing 2D speeds higher than necessary is wasting energy.

Regards
April 6, 2010 1:48:45 PM

suat said:
HD5970 is a different card than OP's HD5770 and increasing 2D speeds higher than necessary is wasting energy.

Regards


Yes, but it works.
April 7, 2010 1:55:39 PM

Testimonial: Using tips in this post, my PC went from crashing/rebooting/pink lines every 5 to 20 mins to being stable now for 5+ days without a single visual error.

The problem with the HD 5770s is a combination of the idle voltage, which the bios sets to 0.95v when the card is idle (2D), and the swapping to-and-from that voltage. The exact cause likely depends on each card, but from what I've read, almost all cards will run fine if you can lock the idle voltage to something higher than 0.95v.

The problem is worst in Windows 7/x64 because it has advanced user interface feedback to the GPU driver that allows the GPU to enter idle state a lot more than any other operating system. (I would think x32 versions of Win7 should be about the same, though it's possible ATI's x86/32 drivers are simply less aggressive for some reason).

I think some cards have such voltage control options now, but most HD 5770s do not (it's hard-coded into the BIOS rom). Without that, the only sure-fire fix right now is to use ATI Tray Tools, and manually set yourself a couple of Overclocking profiles: one for 3D games and one for desktop/2D.

Mine, for example:

157/300/0.98v - 2D*
600/900/1.0v - 3D Oldskool
850/1200/1.125v - 3D Default*
960/1350/1.15v - 3D OC*

* You can try 0.96v or 0.97v also, if you want. If it's stable, you'll save a wee bit of energy in the long run. :) 

** My MSI is an OC edition so it defaults to 850. Lower-end HD 5770s default to 800. ATI Tray Tools and/or GPU-Z will tell you what your card defaults to, if you aren't sure.

*** If you don't like overclocking, you can ignore the last one. :) 

I got this tip from another site where other people also confirmed that it was working well for them. Technically this fix makes sense: ATI made a mistake setting the idle voltages to 0.95v. It's just too low for a large section of cards. It doesn't even mean the cards are bad really. They'll probably run fine for years at 0.98v idle -- and it's hardly much of a difference in power consumption either.

Other fix: The ATI Tray Tools solution is awkward. Some people have literally been hacking their bios roms to force the card's idle logic to use 0.98v instead of 0.95v. It's a more complete fix, though I'm no fan of rom hacking, myself.
April 7, 2010 2:02:44 PM

Regarding RMA'ing the card: It's not necessarily a bad idea, but do keep in mind that there's a decent chance the replacement card will have the same problem. Several people have RMA'd successfully and several others have not, so it's a real gamble for now. Too many of the cards coming off the line simply aren't stable at the stock Idle settings. :( 
April 9, 2010 1:42:51 AM

overclocking 3d mode does not effect 2d mode.

so for people who have problems ONLY in 2d mode, here is how to fix it.

using win 7 x64 bit

install latest ati drivers from ati, start ati overdrive and unlock it, create a new profile name it whatever you want but make sure that you check ati overdrive.

then go to

c: /users/"username"/appdata/local/ati/ace/profile/"your profile name" You must have 'show hidden files checked' to get there

rightclick edit, and change the bold numbers, By defalut the 20000 is 15700 and the 40000 is 30000.

<Profile>
<Caste name="Graphics">
<Groups>
<Group name="Overdrive5">
<Feature name="TimeUnlocked" />
<Feature name="OverclockEnabled">
<Property name="OverclockEnabledProperty" value="True" />
</Feature>
<Feature name="AutoTuneSupport" />
<Feature name="CoreClockTarget_0">
<Property name="Want_0" value="20000" />
<Property name="Want_1" value="60000" />
<Property name="Want_2" value="85000" />
</Feature>
<Feature name="MemoryClockTarget_0">
<Property name="Want_0" value="40000" />
<Property name="Want_1" value="120000" />
<Property name="Want_2" value="120000" />
</Feature>
<Feature name="CoreVoltageTarget_0">
<Property name="Want_0" value="950" />
<Property name="Want_1" value="1000" />
<Property name="Want_2" value="1125" />
</Feature>
<Feature name="MemoryVoltageTarget_0">
<Property name="Want_0" value="0" />
<Property name="Want_1" value="0" />
<Property name="Want_2" value="0" />
</Feature>
<Feature name="FanSpeedProtocol_0">
<Property name="FanSpeedProtocolProperty" value="Percent" />
</Feature>
<Feature name="FanSpeedAlgorithm_0">
<Property name="FanSpeedAlgorithm" value="Automatic" />
</Feature>
<Feature name="FanSpeedRPMTarget_0">
<Property name="Want" value="1413" />
</Feature>
<Feature name="FanSpeedPercentTarget_0">
<Property name="Want" value="50" />
</Feature>
</Group>

doing this will overclock it in 2d mode thus not letting your gpu go below 200 or lower Volts to prevent crashing and will solve your problem

did this on mine, so far it been over 2 weeks, no problems or any crashs at all.

Ati should include this in their new drivers, that will fix alot of their problems.
April 20, 2010 3:26:41 AM

surda said:
finally!!! i solved the problem, its good that i didnt RMA it back.

the reason why it crashes in 2d mode because it goes to 157 core speed which is too low, short answer, overclocked it in 2d mode to 400 and now been running for 5 hours without a problem.

if anyone has the same problem and wants help with that just let me know.


I have AMD GPU Clock Tool....does that set idle speeds or is there a better program, I have an HD 5770 from XFX and sometimes have issues. I searched for a couples weeks time for solutions and just tried one I came across a while ago. I set the settings for my favorite game BFBC2 to refresh at 70MHz but could you tell me how to set 2D idle clock please. After games it crashes within a few minutes, or even during a movie.....but for some reason I can watch movies on defaul 150MHz clock and 300MHZ Visual Ram, mind you that is after a system boot......thanks if you can give me info.
April 20, 2010 6:04:11 AM

KrazyYTE ARE YOU BLIND ?? MY POST IS JUST ABOVE YOURS EXPLAINING HOW TO SET UP 2D CLOCKS, Please do Read before you ask questions.
April 20, 2010 8:22:17 AM

I seem to have fixed this problem I built a new system asus p7p55d pro mb i5 750 overclocked to3.2 ghz (3.86 ghz with turbo boost ) 4 gigs of mem sapphire 5770 hd graphics card windows 7 it ran great for a month or so then windows up dated had nothing but problems after that. I looked all over the internet for help then ati reported driver issues so i waited and waited 10.1 then 10.2 then 10.3 nothing worked. I called sapphire they had me update my graphic card bios now instead of gray line crashes I was getting windows blue screens mem dump errors. Was about to rma my card back to sapphire but I tried my 8800gt same issue so I update my mb bois to the newest ver. and update chipset drives also. seems to be working fine played bioshock2 and left 4 dead 2 the last couple of days not one crash also ran 3d mark 2006 no problems also running cat 10.3 drivers hope this helps good luck
April 20, 2010 12:56:15 PM

Hey maddog724, completely off topic, but what setting did you use for your i5 OC? I assume you had to increase voltage.
April 30, 2010 5:01:58 PM

EXT64 said:
Hey maddog724, completely off topic, but what setting did you use for your i5 OC? I assume you had to increase voltage.


i got lucky my cpu runs nice and cool. i have a cooler master hyper 212 with 2 fans i have my vcore set at 1.28 the only time i had my vcore over 1.4 was at ( 3.5/ 4.2 fsb 175x20/175x24) ghz but system had errors when i ran prime 95. 4 ghz is about my max setting with a stable system i went with 3.2 / 3.8 ghz just to keep the vcore in spec.

I'm assuming your fsb is 180x 20 to get 3.6 ghz
April 30, 2010 5:06:28 PM

Yeah, they are pretty cool chips, especially with the Hyper. I only have one fan (and I've never seen it spin up to full speed) yet absolute max temps are only in the 55-57C range. I'm using a non-turbo 3.6, and amazingly my chip only needed 1.15V.
April 30, 2010 5:10:51 PM

EXT64 said:
Yeah, they are pretty cool chips, especially with the Hyper. I only have one fan (and I've never seen it spin up to full speed) yet absolute max temps are only in the 55-57C range. I'm using a non-turbo 3.6, and amazingly my chip only needed 1.15V.



have u tried to go higher then 3.6 ghz
April 30, 2010 5:16:35 PM

My goal was stock volts OC (which this approximately is; stock was about 1.153 I think). I tried once for 3.8 at around 1.175 or 1.2, but that blue screened.
April 30, 2010 10:31:26 PM

r u changing the fsb or the multiplier or both (3.6ghz 180 fsb 20 multiplier or 3.6 ghz 200 fsb 18 multiplier) i have tried all different ways to over clock my i5 so far i'm sticking with the set up I have right now its a little slower then a straight 3.8 ghz but i like that my system clocks down when its not stressed


this is my set up

fsb 160 multiplier of 20 - 3.2ghz
turbo: fsb 160 multiplier of 24 - 3.84ghz
April 30, 2010 10:44:40 PM

I'm using 20 x 180 Bclk with Turbo off.

My system no longer downclocks when not stressed, but I found that downclocking doesn't actually save power on my i5.
April 30, 2010 11:33:32 PM

I'm thinking of upgrading my graphics card i was going to get a gtx 470 because of all the problems ati is have but now that I seem to have fixed my problems I might get another one and run it in crossfire. I see u have a 5850 how do u like it? do u think the 5850 is better then 2 5770 in crossfire
April 30, 2010 11:56:28 PM

2x5770 is better than 1 5850, however I do really like my 5850. A 470 would be an excellent choice as well assuming sufficient PSU and cooling.
January 11, 2012 5:10:07 PM

found a fix !!!!!!!!!
go download ATI tray tool
its free so no extra cost

the problem with the card is that when it switches to 2d and 3d there is a voltage spike when it spikes, that causes the gray lines and hangups

after downloading ATI tray tool open as admin
play around with your settings and configurations
it takes some trail and error to get it 100 percent right

brought to you by gamer "Stone "so if you ever see me
DON'T SHOOT ME !!! :lol:  :kaola: 
!