Sign in with
Sign up | Sign in
Your question

Broken ethernet port?

Last response: in Motherboards
Share
November 21, 2010 3:57:41 AM

So here I am, minding my own business in Ubuntu 10.10, when Ubuntu tells me it wants to update. After I restart, I can't connect to the internet. (Note: this may or may not be Ubuntu's fault, could just be coincidence)
I figure it's just the glitchy nature of linux, and so I reboot. Still no internet. I boot into Windows 7. No internet.
I figure it's a problem with my network layout (I'm using an old Dlink as a bridge from my Linksys). But no, the Mac Mini and Xbox both using that same bridge are fine.
So I try a different cable, and it still doesn't work. I can't even get it to connect simply using a wireless gaming adapter. Is the ethernet port on my computer totally dead?

MSI 785gm-e65 motherboard
Networking adapter is a Realtek RTL8111DL

More about : broken ethernet port

a c 716 V Motherboard
November 21, 2010 12:36:41 PM

Q - "old Dlink as a bridge" do you mean 'Wireless Ethernet Bridge' if so then does the MSI run okay directly off the Linksys? If so then your Dlink is the problem - reconfigure or try: 1. trun-off the Dlink, restart the Linksys, and then power on the Dlink then your MSI last. You 'may' have a lease issue. Clear DNS - http://www.tech-faq.com/how-to-flush-dns.html

Okay, you've got 1 NIC port. In Windows I would first delete and set-up a new Connection - if that fails then open the Device Manager right-click a Delete the Realtek, and restart. This will rule-out and fix the 'typical' corruptions.

If you're running VMware then D/L and update the 'player'. Otherwise is this a Dual Boot or Virtual arrangement with Ubuntu?

MSI Drivers http://www.msi.com/index.php?func=downloaddetail&type=d...
m
0
l
November 21, 2010 4:22:23 PM

It's not the dlink; the computer won't even work with the wireless gaming adapter (basically a bridge). The wireless on the dlink broke so I am using the wireless gaming adapter as the antenna (using the dlink as a port multiplier)
I am dual-booting the OS's. It can't just be a windows error because it doesn't work booted into either OS.
m
0
l
Related resources
a c 716 V Motherboard
November 21, 2010 4:52:48 PM

So you're 'bridging' to a 'broken' device?? You know how that sounds - right?

Only an Ethernet Bridge can be used, you cannot 'bridge' to a Wi-Fi Access point it is NOT a repeater there's no IP address. My assumption, is 'how' you have everything connected.

Example:
1. PC NIC -> Wireless Ethernet Bridge {IP} <= Wi-Fi => Linksys Router {IP}
2. PC NIC -> Access Point {N/A} <no connection> Wi-Fi <no connection> Linksys Router {IP}
3. PC NIC Wireless Adapter/PCIe/NIC <-> Access Point {IP} <= CAT5 => Linksys Router {IP}

Example 1 & 3 will work but 2 will not.

Please post all parts with links.
MOBO/NIC -> ?DLink? <= Wi-Fi => Linksys Router {IP}

To rule-out the PC; direct connection.
MOBO/NIC <= CAT5 => Linksys Router {IP}
m
0
l
November 22, 2010 12:08:29 AM

Trust me, the bridge works. The main Linksys router is connected to the wireless ethernet bridge (wireless gaming adapter - Trendnet TEW-647GA), which is connected to the dlink router which is ONLY serving as a port multiplier.
The reason I don't use the dlink is that the connection is not consistent and drops too frequently to be of any use. It is not using any of its wireless functions.
The Linksys is providing the IP addresses. The computer is not even on the Dlink network; to the computer, it's just connected straight to the Linksys.

I know the bridge works because I have other computers that are using it (Mac mini and Xbox) that work fine. I have tried different ports on the Dlink, I have tried different cables, and they all work with the Mac and none with supposed broken computer.
The computer will not connect to anything through the ethernet port. I have tried connecting it to my laptop too and neither computer recognizes the connection. Trust me, the bridge is not the problem.
BTW I can't connect directly to the Linksys w/cat5 it's too far away (hence the bridge).
m
0
l
a c 716 V Motherboard
November 22, 2010 12:37:11 AM

Just checking, I still won't use a Router as a Switch; I too can see all sorts of oddball things coming from (2) DNS devices and configuring it would require you to turn-off the Router the IP addressing would need to be as a pass-through.

Link http://www.cisco.com/cisco/web/solutions/small_business...

I had used a similar set-up in my last house, but I purchased a small Switch + Wireless Ethernet Adapter w/single port.

However, I did also state the following - did you do it?
"Clear DNS - http://www.tech-faq.com/how-to-flush-dns.html
Okay, you've got 1 NIC port. In Windows I would first delete and set-up a new Connection - if that fails then open the Device Manager right-click a Delete the Realtek, and restart. This will rule-out and fix the 'typical' corruptions. "
m
0
l
November 22, 2010 3:54:15 AM

So I cleared the DNS... nothing.
But how do I "delete" the Realtek? The options in Device Manager say I can disable or uninstall... which one? I really don't want to mess anything up even more than it is right now.
And also, I don't see how it could be anything to do with Windows if the issue happens in both OS's... How would reinstalling a device in windows do anything to Ubuntu?
m
0
l
a c 716 V Motherboard
November 22, 2010 12:07:52 PM

Uninstall is 'delete' a restart will cause the driver to be installed and re-write the registry entries --> reinitialize NIC.

As 'most' of the discussion is based upon an 'odd' configuration as I've been 'stressing' all along, if it were 'me' I would but a new ~5 port switch. My 'bet' is using a Router to do the job of a Switch -- my feeling is that it even working is bizarre luck. I actually feel the best 'test' is to physically move the PC {I get that it is a pain} and have a direct connection to the Router --> MOBO/NIC <= CAT5 => Linksys Router {IP}
m
0
l
!