Sign in with
Sign up | Sign in
Your question

Fps drops

Last response: in Graphics & Displays
Share
March 6, 2010 7:47:35 AM

Hey guys...this is my config
1024mb gddr5 4870 powercolor
2gb ram
amd phenom 9650
600 W coolermaster PSU
my cod4 used to run in 92-96 fps when i first had the card(i oc'ed it from 770-800Mhz the GPU clock)
recently i had reinstalled drivers and stuff.when i check cod4 frames its constant at 60 fps(i set fps cap of cod4 to 90)
dead space(with everything highest) is only 34..but when there is fire and smoke in the game..it drops to 29
farcry2(with everything highest) goes from 28 to 42
cod mw2 used to be constant at 60...now it ranges from 42 t 60(never constant)

why is this happening?

More about : fps drops

a b U Graphics card
March 6, 2010 7:55:55 AM

Did you reinstaled the drivers that came originaly with your graphics card in the box?
m
0
l
March 6, 2010 8:13:21 AM

No.should i?i just downloaded the latest catalyst drivers from the site
m
0
l
Related resources
a b U Graphics card
March 6, 2010 8:25:56 AM

tariq9112003 said:
No.should i?i just downloaded the latest catalyst drivers from the site

Oh, then i really don't know:( 

Well try reinstaling with your last used driver

And DON't install that driver which camed with your CD. They always suck and i thought you installed from the cd, thats why i asked that.

edit-when you install new catalyst drivers again, it restores the factory settings for the core and memory. Try to OC to those frequencies (770-800MHz like you said) and see what will happen
m
0
l
March 6, 2010 8:32:09 AM

but dude 30 MHz is small right...and oh yes i changed my processore from amd 9550 to amd 9650
m
0
l
a b U Graphics card
March 6, 2010 8:34:55 AM

What is the version of the last driver you used?
m
0
l
a b U Graphics card
March 6, 2010 8:40:26 AM

Try reverting back to that driver and then post back. I really don't know what the hell is happening with Cat 10.2 :??: 

edit- try with 10.1 Do you have 64 bit windows? Cos i searched across the net and found some people having an issue with 64-bit versions of 10.2
m
0
l
a c 110 U Graphics card
March 6, 2010 1:54:51 PM

If you are locked at 60 fps it most likely means Vsync is turned on. By locking to the refresh rate, you avoid unwanted page tearing, since it does not bug you, i suggest turning it off for max fps. Vsync also causes drops if you can not hold 60, it sometimes drops to 30(all to keep that pare tearing effect from happening).

In the Catalyst control center(3d->all->Wait for vertical refresh), set it to always off

If the game has this option, turn it off as well. It will be called sync every frame, vsync or similar
m
0
l
!