Sign in with
Sign up | Sign in
Your question

Dreaded BIOS Checksum Error! GA P55 USB3 REV 2.0 Reboot Loop

Tags:
  • Gigabyte
  • Reboot Loop
  • BIOS
  • USB3
  • Checksum
  • Motherboards
Last response: in Motherboards
Share
November 21, 2010 11:12:34 PM

Guys,

I am having periodic reboot loop with my P55 USB3 Rev 2.0. I have updated it to F8 and loaded the Optimized Setup but at times the BIOS will go into reboot loop and recover the BIOS to the older F5.

My power supply is Seasonic SII-520W, pretty sure that's sufficient.

Thanks!

More about : dreaded bios checksum error p55 usb3 rev reboot loop

November 22, 2010 12:07:33 AM

Thanks, I am pretty sure the BIOS is corrupted, it tried to recover the HPA but failed, it then tried to recover to the older F5 bios...
m
0
l
November 22, 2010 12:43:28 AM

Here's the message from the black screen:

Warning! MAIN BIOS CHECKSUM ERROR!

Retreiving recovery source from HPA.... HPA BIOS recovery not available!!
Retrieving recovery source from Back-up BIOS.... Done!

BIOS Auto-Recovering
m
0
l
a c 177 V Motherboard
November 22, 2010 1:34:54 PM

If you are having this problem repeatedly, you may need an RMA (and, trust me, I'm not one to recommend RMA's lightly!). I have seen this issue before, and the only possible explanation is a bad bit in the EĀ²ROM that holds the working copy of the BIOS. This diagnosis has been reinforced by the fact that, in a couple of cases, the problem could be cured by loading a different BIOS, where my assumption is that the bad bit which is 'stuck' at, say, 1, is actually set to 1 in an alternate BIOS copy. The symptom here is that you get a BIOS checksum error, the board recovers, you reload the copy of the particular BIOS that you've been using, and you have the problem again. In some cases, the problem occurs without you loading a BIOS, and my assumption there is that the 'as shipped' BIOS which restores itself has a 'conflicting bit', so when it autoloads, it triggers the whole cycle again...

The things to try:

Make sure your BIOS copy is good - try D/Ling it again, from a different source. It is possible to have a corrupt BIOS pass checksum - don't ask me how, but I've had it happen!

If you are willing, and the older BIOS 'cooperates' with your hardware (especially verify that your RAM works), you might try loading a different BIOS revision - possible to 'get lucky' and have the bad bit 'match'...

Other than that, it's time to contact GB regarding an RMA...
m
0
l
November 22, 2010 11:59:45 PM

bilbat,

Thanks for the reply. I have flashed it from F5 to F8 (again!) yesterday. I loaded the Optimized Settings TWICE just to make sure the newer F8 is written properly into the main BIOS.

I have DLed the BIOS from both GB USA and GB Taiwan, both yielded the same results. I have not tried a different version other than the newest version though, will give it a try if all else fail.

I am still monitoring and see if it can pass one month without it recovering back to the old F5 version. I hate RMA, takes forever to get a replacement and I am hoping I don't need an RMA...

Here's the thing, I googled on GB's BIOS checksum error and tonnes of results came up but can't seems find a definitive answer to what causes it and how to fix it. I tried to search on GB site as well, NONE came up. Google's results vs. GB's results, the conspiracy theorist in me feels that GB is hiding something there...

Wish me luck!

Thanks!
m
0
l
!