ACPI.sys using CPU during idle.

I looked around couldn't find another forum for this, I have searched around and all of the other solutions are either for Xp, or simply don't work for me.

This use to not be a issue, periodically it would crop up but was fixed simply by a restart, without warning after no peticular install or anything it seems to have become permanent and hasn't gone away for a day.

It shows up as Usage under System.exe in Task manage but under a closer look it is the Thread ACPI.sys that is responsible, and I can't suspend or Kill it in Windows 7 with Process Explorer.

It uses CPU in Small Spikes I can post a picture if needed, from watching it, it would Running, Wait:executive, Then Ready

This is what I have tried so far in Bios:

Set to S1 and S3 with no Success from Auto, ACPI 2.0 Support is Disabled but didn't have any effect either way.

Windows wouldn't boot without ACPI APIC Support Enabled. So it is enabled.

It will idle at 13% which is keeping my processor from going into Idle state aka costing me $$ and wearing it out.

My PC specs are:

CPU: i7 860 @ Stock, 1.11V
RAM: 8Gb DDR3 @ 1.65V , 1333mhz
GPU: XFX 5870 @ Stock
Mobo: Asus Maximus Formula III, Stock
PSU: Corsair 850HX


Any help would be appreciated, I have not tried disabling all of my non Microsoft Programs and weeding it out but I am fairly sure it is something else since it didn't seem to be triggered by a specific application installation. Although if there is no other solutions I will have to try it.
5 answers Last reply
More about acpi idle
  1. Have you tried using Xperf or Process Explorer from Systernals to further your diagnostics?
    BIOS updates available?
  2. That is what I have used to further my Diagnostic so far, and I have identified that that is the culprit, I'm sure BIOS updates are avaliable but I want to avoid flashing all together is possible.
  3. Bump, Any help would be greatly appreciated.
  4. What happens if you try to suspend the thread in Process Explorer?
    Are you sure you have all the latest drivers/utils for that motherboards?

    You may want to ask in the Microsoft forums as well.
    http://social.technet.microsoft.com/Forums/en-US/category/w7itpro/

    I would probably start looking at disabling any ACPI reliant features in the BIOS and in Windows 7. Things like Power management, Suspend or Hibernation. Wake up on LAN ,Hardware monitoring etc. I realize you can't disable ACPI entirely.

    Failing success there, I would restore the BIOS to factory defaults. Failing that, I would flash the BIOS.

    I am sure you have tried much of this already so please exuse any repetition.
  5. I tried everything ya, So I resorted to flashing, I was using the first version of Bios so that may have been why... Wow what a difference with the new Bios, CPU auto clocks it self down now when in Idle.

    Everything is fixed now though

    Thanks
Ask a new question

Read More

CPUs