Sign in with
Sign up | Sign in
Your question
Solved

PC game graphics twitching erratically...

Last response: in Graphics & Displays
Share
March 7, 2010 8:08:33 AM

I've recently built myself a new computer forgaming for the first time, and it's been working great! Till now :( 

Some games now have this really crazy twitching problem going on. Here's a video:
http://www.youtube.com/watch?v=4SLC6k1zyDQ

It's weird because the FPS stays smooth; it's just the in-game models that are twitching and stuff. Anyone know what's going on?

In the past few days I've overclocked my GPU and also unlocked the 4th core on my CPU. Those might've been the source of the problem, but I un-overclocked the GPU and disabled the 4th core, and the problem is still there. It can't be anything overheating because all my parts are running below 50C.

My specs:

ASUS M4A79XTD
ATI Radeon 5770
Athlon II x3 435
4GB DDR3 RAM
a b U Graphics card
March 7, 2010 3:58:15 PM

My guess would be graphics drivers. I've heard that there were issues for a couple of weeks with the 5000 series drivers, but I believe they are cleared up now.

Could you list your power supply and which drivers you're using and OS? If using Win7, are you using the microsoft supplied drivers?

Did you make any other hardware or software changes just prior to the pb showing up?
m
0
l
March 7, 2010 5:18:38 PM

My power supply is a Corsair 650TX
http://www.newegg.com/Product/Product.aspx?Item=N82E168...

I'm using Windows 7 Ultimate x64, and I'm just using the ATI Catalyst.

I didn't make any hardware changes. The only software changes that I can think of were that the OS automatically updated, and Steam also installed some DirectX stuff upon the first startup of the games.

Also, it seems that not all my games do this. Shattered Horizon and Red Faction Guerrilla both run perfectly. Batman, Far Cry 2, and Mirror's Edge all have this problem.
m
0
l
Related resources
a b U Graphics card
March 7, 2010 7:26:59 PM

Ok, I think we can focus on the automatic update and direct X stuff.
As far as the automatic update goes, did that update install any graphics drivers? What else was installed?
Which games that you have listed are steam games? I only ask as it may help to narrow down possibilities.
If you have Direct x 11 installed, you may also need to install a previous version. I had 10.1 on my system, but had to install direct x9 also to play some older games. Weird, I know. It didn't used to be that way, the direct x updates were cumulative in the past... Pain in the arse!

What I would do first is take a look under system properties (Or Ati catalyst) and see which version of the video card drivers you are running. Then take a look at your recent updates, to see what was installed. I would then go to ati's website and see what the latest catalyst version available is. If it's a newer version then the one you are running, I'd dl the latest and install it.
If the drivers you're using are the same as the latest version, there should be an option to dl the previous version. Or you could google it.

Finally, I would make sure all the games have the latest patches installed. Direct X11 is fairly new and they are constantly doing little tweaks to improve performance.
m
0
l
March 7, 2010 7:47:44 PM

I don't think it installed any graphics drivers; just some DirectX stuff, random windows updates, and stuff like Windows Live and Punkbustr.

All the games listed are Steam games. Also, TF2 and Crysis both have very minor versions of this problem (also Steam).

I was running an older version of ATI Catalyst, so I updated to see if it would fix the problem. But nope, the problem is still there. And all the games on Steam are automatically updated, so they should be the latest patches.

How do I downgrade my version of DirectX?

Also, people are saying that I may have damaged my GPU when I overclocked it. I guess it's possible, but it doesn't make sense because it always ran at low temperatures when it was overclocked, and only some of my games have this problem.
m
0
l
a b U Graphics card
March 7, 2010 11:30:46 PM

Huh. when you overclocked did you change any voltages? And if so, did you return the voltages to normal?

I would grab ati tool and check for artifacts.
m
0
l
March 8, 2010 12:44:28 AM

To check if it was a software issue of some sort, I just reformatted my computer. Then I installed the latest version of ATI Catalyst, installed Doom 3, and loaded it up. This was even before I updated the DirectX stuff. The problem is still there, so maybe it's a hardware issue?

I didn't change any voltages, only the Core Clock and Memory clock.

ATI Tools doesn't seem to work with Windows 7, so I'm using the OCCT GPU test instead. About 10 minutes in, and there aren't any errors so far. Weird.

http://img130.imageshack.us/img130/5125/gputest.jpg
m
0
l
a b U Graphics card
March 8, 2010 1:46:05 AM

Well, the temps look good and you aren't getting artifacts while testing..Definitely curious.

So I would google the particular problem with your model and see if you get any similar pbs showing up from other owners.
Also check the manufactures website forums and see if there's any help there.

My first guess would be that you may be having overheating issues. Let's say we've eliminated that possibility, they look appropriate from where I sit. Since it happens on some games and not others, I would normally say that its a software issue.

After the reformat and with the latest catalyst drivers, everything should be hunky dory. Let's say that direct X is not a factor, since it is the latest version from CATALYST.
At this point I doubt it will be a software issue. I could be wrong of course, but I find it unlikely. That leaves a hardware issue.
Have you changed anything else like ram timings or speed, northbridge speed, HT speed, etc? Added more ram or other hardware changes? have you done a memory check?

If you eliminate those things then I would pull out your receipt/invoice and start the RMA process. I know the pbs just sprang up recently, but that could happen with a defective card. I have used a set of ram from crucial that works fine from 6 months to a year and then fails. on my 4th RMA with that one set of ram.
m
0
l
March 8, 2010 2:14:26 AM

Yeah, after reformatting I'm almost certain that it's a hardware issue, although I'm still not 100% sure. Plus, it could be either the GPU or the CPU having errors.

I didn't change anything else. And no, I haven't done a memory check. What's that? Just a memory test on the GPU?
m
0
l
March 8, 2010 2:18:28 AM

Talking about the CPU having errors... I just ran the CPU test on OCCT, and it failed instantly, where as the GPU had no errors at all. Could this mean that the CPU is faulty?
m
0
l
March 8, 2010 2:30:02 AM

Oh, wow. I just solved my problem!

The problem was that unleashing mode was still on, or something. That's what I had to turn on to unlock the 4th core; it successfully unlocked, but it became unstable with that setting on, apparently. Turning it off, now all my problems have gone away.

Thanks for all your help, buzznut. I probably wouldn't have realized this problem, and then kill myself over RMAing the GPU and stuff.
m
0
l

Best solution

a b U Graphics card
March 8, 2010 2:00:45 PM

ah ha! that's a great feeling, isn't it? Well, it took extensive testing but by process of elimination you figured out it was CPU related.
Normally you wouldn't need ACC enabled to overclock this CPU, because it already has ACC enabled in the hardware. I'm not certain exactly what unleashed mode does to the CPU, but I do know it can lead to instability. I have read that if one lowers the northbridge speed prior to unlocking the 4th core, then resetting it via AOD once in windows that some folks are having success at achieving stability with their unlocked processor. Haven't tried that with my sempy yet, but as it is running my home server it is zippy enough and I am more interested in stability. I'm actually quite impressed with my $35 proccy!

Anyway, congratutations! Happy to help.

BTW, memtest is the ram testing application used by a lot of folks. It runs outside of windows, via usb or disk. It is like the POST test to check for memory errors, except more extensive. It doesn't take long to run and it can eliminate your ram as a culprit.
Share
March 18, 2010 12:10:43 AM

Best answer selected by somedumbgamer.
m
0
l
!