Sign in with
Sign up | Sign in
Your question

Network Bridgining (ICS)

Last response: in Networking
Share
February 4, 2010 1:06:26 PM

Computer 1 has 2 Ethernet Adapters and one wireless via USB
Is WinXP SP3 .NET 3.5 IIS installed

Adapter A- NVidia Onboard
Adapter B- Realtek PCI
Adapter C- DLink USB (Wifi)


A is connected to the cable modem and shared with B cross over cable to another computer works fine no problem
A is connected to the cable modem and shared with C Wireless Ad-hock P2P connecting a Laptop & an iMac simultaneously I get Google all around

I use the network setup wizards to configure these settings.
In this wizards you will select your primary internet connection to be shared and then you choose which connection to share it to either B or C
or you can choose both and bridge them. This DOES NOT WORK at all and I need it to. I have read through windows help files and found the following statement......

"Adapters that have Internet Connection Sharing (ICS) enabled cannot be part of the network bridge and will not appear on the Network Bridge checklist. Similarly, the Add to Bridge option is available only for adapters that you can add as connections to Network Bridge."

This means I can't bridge A with B or C if I am correct.

SO I ran the wizard again and shared A with B.
Then opened Network connections and attempted to bridge B with C which WinXP says " to create bridge you must select 2 LAN, Highspeed not using (ICS)"

I have gone through countless different settings and have tried manual configurations in various methods
I just want to be able to share My connection from A, to B, & C all at the same time.

Any suggestions ideas are appreciated
I will be watching email for notificaiton but have other things going on so might take me a little

if you need more info let me know

Thank you,

notchris


More about : network bridgining ics

February 5, 2010 1:47:33 AM

I don't fully understand what you're trying to achieve, but I presume that you want your system to behave as a router. You may be interested in reading this: http://www.windowsnetworking.com/articles_tutorials/w2k...

You can only bridge adaptors that are compatible. Since you are using 3 totally different NICs, it won't work.
m
0
l
February 5, 2010 8:17:56 PM

ICS makes a device function as a NAT. Bridging just means "repeater"

your computers would be talking directly to your modem AND your Win7 sharing out ICS
m
0
l
Related resources
February 7, 2010 12:03:30 PM

so if I had a realtek wireless usb with the realtek pci card I would have less conflict

the weird thing is though I got this setup to work late last night

I managed to share connection A with a bridged Mini port of B, & C.
connection B was hard wired to the other desktop with a cross over cable
and the laptop and mac got google via wifi no problem
but connection B was running at 100Mbps via the cross over
the wireless which is graded for 11Mbps is only syncing at 2Mbps

when I share my connection with a non bridged configuration to only the wireless adapter
I get 4.5 - 5Mbps and the mac and laptop are able to connect simultaneously
m
0
l
February 7, 2010 12:04:25 PM

Kewlx25 said:
ICS makes a device function as a NAT. Bridging just means "repeater"

your computers would be talking directly to your modem AND your Win7 sharing out ICS



what do you mean and I am using XP not 7
m
0
l
February 8, 2010 3:39:11 PM

notchris said:
what do you mean and I am using XP not 7


whoops, was thinking i was in the win7 forums. but same difference.
m
0
l
February 8, 2010 4:33:09 PM

I've never had a problem bridging. Although I will say that I've never tried doing that with wireless. It does just act like a switch. So the modem needs to be able to do the DHCP for all of it if you want it connected that way.
m
0
l
February 8, 2010 4:35:46 PM

I read the article mentioned above and enabled IPRouting in the registry. I also manually installed NETBEUI which Microsoft no longer supports in WinXP none of this made a difference.

this configuration works but not completely
I have bridge B, & C, and shared connection A(Built-In Ethernet) with the Bridged Network
I can connect another desktop and run at highspeeds with a cross over cable from 2nd desktop to connection B (PCI Ethernet)
I can connect my iMac to the wifi and get online via an Ad-hock created by connection C (USB WIFI)
the wifi does not work at fullspeed and I cannot get google to display with my laptop but I can ping with a reply and no packet loss
I ran the network setup wizard on the laptop it is also WinXP SP3
m
0
l
February 8, 2010 7:58:21 PM

False_Dmitry_II said:
I've never had a problem bridging. Although I will say that I've never tried doing that with wireless. It does just act like a switch. So the modem needs to be able to do the DHCP for all of it if you want it connected that way.


I can't enable DHCP for the wireless adapter the bridge controls the ip address of both the pci card and the wifi card
which is set to 192.168.0.1 for ICS you have to choose to manually set this or it will not work which means DHCP is forced to be off at the recieving end not sure if thee is a way to have the adapter send DHCP info to client Computer but my other machine obtains its IP automatically so I'd imagine it already is

I enabled NETbios thinking this could help but when I do a ping it says its not enabled

***.***.***.*** This is anywhere my public IP would be displayed maybe someone can decipher what is wrong based on this
How do I enable Netbios on those tunnel adapters

Ethernet adapter Local Area Connection 1:

Connection-specific DNS Suffix . : (My High Speed Provider)
Description . . . . . . . . . . . : NVIDIA nForce Networking Controller
Physical Address. . . . . . . . . : 00-13-8F-1F-51-7E
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : ***.***.***.***
Subnet Mask . . . . . . . . . . . : ***.***.***.***
IP Address. . . . . . . . . . . . : fe80::213:8fff:fe1f:517e%4
Default Gateway . . . . . . . . . : ***.***.***.***
DHCP Server . . . . . . . . . . . : ***.***.***.***
DNS Servers . . . . . . . . . . . : ***.***.***.***
***.***.***.***
fec0:0:0:ffff::1%6
fec0:0:0:ffff::2%6
fec0:0:0:ffff::3%6
Lease Obtained. . . . . . . . . . : Sunday, February 07, 2010 2:40:19 PM
Lease Expires . . . . . . . . . . : Wednesday, February 10, 2010 9:20:50 AM

Ethernet adapter Network Bridge (Network Bridge) 11:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : MAC Bridge Miniport
Physical Address. . . . . . . . . : 02-0D-88-C9-FA-06
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.0.1
Subnet Mask . . . . . . . . . . . : 255.255.255.0
IP Address. . . . . . . . . . . . : 2002:cfff:3cd0:9:7d3d:1539:77a9:2c1
IP Address. . . . . . . . . . . . : 2002:cfff:3cd0:9:D :88ff:fec9:fa06
IP Address. . . . . . . . . . . . : fec0::9:D :88ff:fec9:fa06%2
IP Address. . . . . . . . . . . . : fe80::D :88ff:fec9:fa06%9
Default Gateway . . . . . . . . . : 10.0.0.1
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%2
fec0:0:0:ffff::2%2
fec0:0:0:ffff::3%2

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 80-00-FB-CD-30-00-C3-2F
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : fe80::ffff:ffff:fffd%5
Default Gateway . . . . . . . . . :
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter 6to4 Tunneling Pseudo-Interface:

Connection-specific DNS Suffix . : (My High Speed Provider)
Description . . . . . . . . . . . : 6to4 Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : CF-FF-3C-D0
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 2002:cfff:3cd0::cfff:3cd0
Default Gateway . . . . . . . . . : 2002:c058:6301::c058:6301
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%6
fec0:0:0:ffff::2%6
fec0:0:0:ffff::3%6
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Automatic Tunneling Pseudo-Interface:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Automatic Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : C0-A8-00-01
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : fe80::5efe:192.168.0.1%2
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%2
fec0:0:0:ffff::2%2
fec0:0:0:ffff::3%2
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Automatic Tunneling Pseudo-Interface:

Connection-specific DNS Suffix . : (My High Speed Provider)
Description . . . . . . . . . . . : Automatic Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : CF-FF-3C-D0
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : fe80::5efe:***.***.***.***%2
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%6
fec0:0:0:ffff::2%6
fec0:0:0:ffff::3%6
NetBIOS over Tcpip. . . . . . . . : Disabled

Thanks again for all your input and help I figure there has to be something really stupid I can change somewhere that can fix this just not sure what
it almost works my issue now is speed and proper addressing I figure
m
0
l
February 9, 2010 12:15:42 AM

Well for what I suggested you'd have to disable all ICS, and then add everything to a bridge. If this method is going to work at all that's what would do it, since then every device would be part of the "switch" and the modem would be able to hand DHCP addresses to all. Thing is, most modems don't like dealing with more than one address and as such you probably need a gateway/master device like any kind of router.
m
0
l
February 9, 2010 12:47:49 AM

Is it too late to say this? Just buy a wireless router. That'll give your wireless devices access to the internet, as well as allow you to connect both PCs.
m
0
l
February 9, 2010 12:49:59 AM

I don't own a router but windows XP supports IP routing so I configured this manually as you said disable ICS and bridge the adapters I want to share with then I shared the connection with the bridge
well like before the iMac connects at 2Mbps via wifi but laptop won't and cross over to other PC is fine
m
0
l
February 9, 2010 1:00:42 AM

notchris said:
I don't own a router...


That's why I said you should buy one. Here's on that I recommend. It's less than $60 shipped, has really good range, and will do exactly what you need it to without all the hassle of configuring Windows to share an internet connection the way you want it to.

Buffalo WHR-HP-G54
m
0
l
February 9, 2010 1:11:15 AM

MaizeNBlue2 said:
Is it too late to say this? Just buy a wireless router. That'll give your wireless devices access to the internet, as well as allow you to connect both PCs.

so closed minded you are young jedi
always seeking the easy way out
m
0
l
February 9, 2010 1:12:30 AM

i have 1 dollar i can donate via pay pal for a solution to my problem
that is not a router
m
0
l
February 9, 2010 1:18:12 AM

LOL. Windows isn't made to do what you want it to do. I'm not saying it can't be done, but it's not worth the effort to make it happen.

If you want to do it and someone wants to help you that's fine, but it's a lot of wasted effort when they make hardware to do specifically what you're trying to do that's not that expensive.
m
0
l
February 9, 2010 1:32:47 AM

I have been seeking a solution to this problem for a long time now
I want to find it without a router so if you have any further suggestions reread this entire post and give me your summary of your perspective
m
0
l
!