Sign in with
Sign up | Sign in
Your question

4890 ati strange problem in win7

Last response: in Graphics & Displays
Share
March 7, 2010 5:53:11 PM

System is a custom built, with all new components.
CPU: Phenom II X4 955, Rev C3
MB: Asus m4a79xtd evo - 790x Chipset
RAM: 2 modules, Kingston KHX1600C9D3BK2/4G 4GB DDR3-1600Mhz
PSU: Lc-power 600 w
GPU: PowerC Ati radeon 4890 1gb ddr5

So the problem appeared when I installed win7 64bit. No problem what so ever on XP.

The games runes about (50-100) fps depends on the game, with apsolutly no lag but accompanied by some a kind of jerky motion. Some kind of frame problem. Relay i don't know how to describe it.I tried to reinstalled (formatted) the whole system. fresh drivers for the motherboard and graphics and still nothing.Updated my bios. Tried win7 32bit to. But when i downgrade to Xp, problem simply disappears. Does anyone know what the problem is and how to solve it? ...i don't want to return to Xp again :) 


March 7, 2010 6:05:28 PM

It's really hard to tell. So far I've used my 4890 without a problem on Win7 and never noticed a sudden drop in FPS'es while playing. Check any autoupdater software or something like that. If I can think of anything else, I'll post it.

Cheers!
March 7, 2010 6:16:14 PM

but there is no frame drop. that's the strangest thing in whole story. Just some kind of strange motion. Like the frame's are overlapping or something.
In Xp i don't have this prob.
I tried to update everything like a million times with all kind of version of drivers:( (
Related resources
March 7, 2010 6:25:16 PM

Is the problem going with every 3D app you're using or just a single game?

If it's appearing with just a single game, try with another one, because it can be corrupt textures or something like that. If not, well... How are your GPU temp on Win7? I have to get 100% fan on mine while playing, cause here's very hot (Santiago de Chile, summer time) and keep it around 56ºc while playing.

Cheers!
March 7, 2010 6:32:08 PM

The problem is going with every game:( 
The temp is 70 ºc max.
but if is temp. how do you enplane the absence of problem in xp under the same conditions?
March 7, 2010 6:41:48 PM

This is a blind shot, but still... XP drivers might not have a temp red line for the card, or XP drivers have their value higher than Vista/Seven.

Also, since DX9c on WinXP uses different path codes than DX10/11 on Vista/Seven, they might stress the cards in a different way. This is another blind shot, actually =/

I suggest you turn on the Ati Overdrive and let the fans at 100% while playing games. I created 2 profiles for that purpose: "IDLE" and "Games", pretty straight forward, lol.

If the problem persist, we'll have to look deeper into it.

Cheers!
March 7, 2010 7:05:40 PM

Tried with 100% fan speed with no luck. Problem still persist.
Btw.. I have thermaltake shark case with 2x12 inch fans (front and rear ) + aftermarket cooler for cpu ( cooler master hyper 212+).
This is the strangest thing i ever run in to !:( ((
March 7, 2010 8:00:27 PM

Well, no temp problems CPU wise for the looks of it...

It could be a Win7 problem, but since I haven't heard of anything like it, is kinda hard to tell... What are the titles you play?

Cheers!
March 7, 2010 8:21:34 PM

It isnt a Win 7 issue - almost all of us are running Win 7 without issues.

Which version of ATI driver?

What is vertical refresh set to?
March 7, 2010 8:32:17 PM

ati catalyst 10.2, vsinc is always off.
Btw, i tried almost all version of catalyst.
What are you saying, is it hardware ?? i mean in xp card works normal ??
March 7, 2010 8:34:28 PM

refresh rate is 75hz.
March 7, 2010 10:40:40 PM

It can be corrupt data, but trace that it's easier said than done =/

Do you have another set to try it? A friend or something who can lend you a couple of sticks?

Cheers!
March 8, 2010 3:24:04 AM

another set of ....???
Should I try with another G.card or memory or ....what's the point ..:\
I can do that, but the fact that everything is working normally in Xp prevents me.
Oh man , im so confused :( 
March 8, 2010 3:39:09 AM

Vsync. Enable it.
March 8, 2010 3:50:13 AM

To be honest, when I use XP, games like Battlefield BC2 works normal with the new Catalyst drivers. But the games such as GTA4 lags horribly. I solved the problem in XP (with GTA4), by rolling back to older version of catalyst. And with that older version every game works just fine, with high frame rates and no lag ...and without this kind of problem that i have on win7. On the other hand in win7 i have new catalyst driver no lags in games, high frame rates but i have this strange motion problems like missing frames or something ( its like "teleport" effect, when you are going forward ), overlapping frames...and all of that at frame rate of 80?:( 
Its wherry weird and i cant determine the cause of that ?:( 
March 8, 2010 3:57:32 AM

vsinc does not change anything. I tried that ...:( 
March 8, 2010 9:01:08 AM

Here's what I've noticed. When playing battlefield bad company 2 i have around 70-100fps and problems with motion. but when i run some background process like fraps ( movie capturing with f9 -function on ) that lower frame rate in game , problem disappear . How strange is that ??
March 8, 2010 8:56:43 PM

anybody ???
March 9, 2010 12:15:26 AM

Vsync is the only thing I can think of that would cause what you're talking about. You already said that's not it. I have no more ideas. Did you enable it in the game or drivers?
March 9, 2010 6:24:16 AM

first in the game than form catalyst and vice versa.
I am running out of ideas to:( 
March 9, 2010 11:01:14 AM

Oh, sorry. I meant to say RAM modules. Forgot to add that.

This is quite a weird problem indeed. Did you install your games on XP and on Seven or they're the same install you play on both OSes?

Cheers!
!