Sign in with
Sign up | Sign in
Your question

How to get HDMI to work (ATI Radeon 5770 Series) + Benq G2420HD

Last response: in Graphics & Displays
Share
March 7, 2010 11:01:27 PM

Hello , I have a benq G2420HD Monitor connected to ATI Radeon 5770 graphics card via dvi . When i connect my HDMI to the second monitor which is my lcd tv .The main monitor goes blank like its on stand by .Even if i connect my benq with HDMI it does not recognize it i am not sure what to do and i have tried most logical things like (drivers) but nothing at the moment seems to help
My OS is windows 7 64bit
If anyone can help me it would be much appreciated
thank you
Leo
March 17, 2010 2:45:25 AM

Hmmm... what is your power supply? Feel free to list the specs of your machine.
m
0
l
Anonymous
a b C Monitor
April 26, 2010 8:10:06 PM


Hello i am having a similar problem

Im using an ATI HD 5750 it fetures 2 dvi and 1 HDMI

My spec is

4gb ram

Amd phenom 2x black edition


Basically i had a samsung tv hooked up to my graphic cards HDMI slot and it was working fine and bang the
moniter went blank i panicked and turned the pc off and on safely. Nothing no picture so i grabbed an old vga cable i had and the image came up straight away.

This is driving me nuts i cannot find any thing on this?

I have the latest catalyst and drivers.
I have windows 7 64 bit? (is it me or this just causing people poblems?)

My computer does not recognise the hdmi at all ive tried 4 differnt hdmi and two screens and nothing no luck .


pleeease i need your help i just got this comp and i can still return it would love a fix



m
0
l
Related resources
April 27, 2010 7:40:43 PM

Hmm I would say check your windows settings and make sure you are not duplicating or extending display. That is kinda random bu check the windows diplay property to see if u can up with a solution , also a psu does not matter that much since the tv or monitor already have a power source thus not draining your psu of energy.
m
0
l
June 6, 2010 1:38:28 PM

I had the same problem, but solved it by inserting a VGA-cable and entering the monitor menu using the buttons on the monitor. There is an option that is called Input: dSub and changing this to Input: HDMI. Then I could use the HDMI cable.

It seems it doesn´t automaticly choose HDMI input. This is kind of weird because you can´t enter the menu with a HDMI cable and I only got an HDMI cable with the monitor.
m
0
l
July 26, 2010 10:12:54 AM

amphysvena said:
I had the same problem, but solved it by inserting a VGA-cable and entering the monitor menu using the buttons on the monitor. There is an option that is called Input: dSub and changing this to Input: HDMI. Then I could use the HDMI cable.

It seems it doesn´t automaticly choose HDMI input. This is kind of weird because you can´t enter the menu with a HDMI cable and I only got an HDMI cable with the monitor.


Thanks, I had the same problem. solved it as I had both vga and hdmi cables.
m
0
l
August 7, 2010 7:43:58 PM

Ok guys, if you upgraded or did a clean install you need to install the correct driver for your graphics card because windows 7 just sets it up with a generic driver. I had the same problem and now its totally fixed......
m
0
l
March 4, 2011 3:21:29 AM

Im having a similar problem in the sense that im trying to get a 3rd monitor to run on the same card. Its a radeon 5770 and ive been looking everywhere to see how to activate the hdmi port. Im stil scouring over Catalyst 10.12 but to no luck.
The cable im using is a hdmi to vga and av. So ive plugged in the hdmi to my video card and the vga connector to my monitor. I know eyefinity can support 3 monitors on one card but im not sure if i need additional drivers?
Its not showing up in catalyst and doest seem to be connecting at all.
Ive check the cables 3 times now and its all plugged it right.
Any ideas how to solve this?
m
0
l
October 19, 2011 2:08:20 AM

amphysvena said:
I had the same problem, but solved it by inserting a VGA-cable and entering the monitor menu using the buttons on the monitor. There is an option that is called Input: dSub and changing this to Input: HDMI. Then I could use the HDMI cable.

It seems it doesn´t automaticly choose HDMI input. This is kind of weird because you can´t enter the menu with a HDMI cable and I only got an HDMI cable with the monitor.


Had same problem but your solution fixed it - thanks heaps. Cannot understand why BenQ don't put similar advice in their instructions for Monitor use.
m
0
l
!