Sign in with
Sign up | Sign in
Your question

Dell Latitude C600 battery problem

Last response: in Laptops & Notebooks
Share
Anonymous
a b D Laptop
September 5, 2004 4:29:32 PM

Archived from groups: comp.sys.laptops (More info?)

My Dell Latitude C600 is four years old using the original battery.
Recently, the battery life has been getting smaller.

But a few days ago, I am now getting NO use out of the battery. That is,
when I unplug the AC power, the computer immediately goes dead, despite
Windows XP and the BIOS telling me it is 100% charged and charging. It seems
that maybe there is some electrical contact not being made up or something
similar.

Any idea what is going on? I would like to know if I buy another battery
that it is going to work - but I have a suspicion the same thing might
happen with any battery I install!

Bud H
Anonymous
a b D Laptop
September 5, 2004 4:29:33 PM

Archived from groups: comp.sys.laptops (More info?)

>My Dell Latitude C600 is four years old using the original battery.
>Recently, the battery life has been getting smaller.

>But a few days ago, I am now getting NO use out of the battery. That is,
>when I unplug the AC power, the computer immediately goes dead, despite
>Windows XP and the BIOS telling me it is 100% charged and charging. It seems
>that maybe there is some electrical contact not being made up or something
>similar.

>Any idea what is going on? I would like to know if I buy another battery
>that it is going to work - but I have a suspicion the same thing might
>happen with any battery I install!

>Bud H

Battery's smart chip failed and is giving false info. Get a new
battery on ebay from a trusted seller.


------------
When your PC gives a little they give a lot.
http://www.dslreports.com/forum/disco
Anonymous
a b D Laptop
September 5, 2004 4:29:33 PM

Archived from groups: comp.sys.laptops (More info?)

Get another battery. I had a like problem with my Inspiron 1100 when I
first bought it. I went back to where I bought it and I took a battery
out of another and put it in mine, and it has worked properly ever
since. I use my laptop in my pickup all day five days a week.....

Bud H wrote:

> My Dell Latitude C600 is four years old using the original battery.
> Recently, the battery life has been getting smaller.
>
> But a few days ago, I am now getting NO use out of the battery. That is,
> when I unplug the AC power, the computer immediately goes dead, despite
> Windows XP and the BIOS telling me it is 100% charged and charging. It seems
> that maybe there is some electrical contact not being made up or something
> similar.
>
> Any idea what is going on? I would like to know if I buy another battery
> that it is going to work - but I have a suspicion the same thing might
> happen with any battery I install!
>
> Bud H
>
>



-----= Posted via Newsfeeds.Com, Uncensored Usenet News =-----
http://www.newsfeeds.com - The #1 Newsgroup Service in the World!
-----== Over 100,000 Newsgroups - 19 Different Servers! =-----
!